Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to completely disable website translation?

  • 4 uphendule
  • 27 zinale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu Philip J.

more options

This question was already posted and badly answered in 2016. Now things have changed a lot and Firefox DO try to translate everything which is quite annoying to anyone knowing more than a single language. No extensions related. I need to completely disable that. My firefox is up to date: 118.0.1 (64-bit).

Thank you Arturo

This question was already posted and badly answered in 2016. Now things have changed a lot and Firefox DO try to translate everything which is quite annoying to anyone knowing more than a single language. No extensions related. I need to completely disable that. My firefox is up to date: 118.0.1 (64-bit). Thank you Arturo

Isisombululo esikhethiwe

Enter about:config in the address bar and set browser.translations.automaticallyPopup = false.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 39

All Replies (4)

more options

Isisombululo Esikhethiwe

Enter about:config in the address bar and set browser.translations.automaticallyPopup = false.

more options

Thank you, gracias, merci, danke schön, obrigado

more options

I would - additionally - like to get rid of that translation icon in the urlbar. I don't want to see that feature on my main interface at all.

If there's no setting for it, i would appreciate an userChrome.css setting.

more options

I have just seen this popup for the very first time today (23/01/2024), and I absolutely hate it. I hope you will add a checkbox to completely disable this feature in the future.

But for the time being, I will just toggle the browser.translations.automaticallyPopup option like suggested

Along with the following: browser.translations.enable browser.translations.panelShown

To achieve the behavior that I/we want.

(TBH, I think unnecessary features like this should be downgraded to extensions instead)