Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Helvetica font not displaying properly with greek language, in various applications, including Firefox and Thunderbird

  • 6 uphendule
  • 0 zinale nkinga
  • 80 views
  • Igcine ukuphendulwa ngu iliastolos

more options

Hi everyone!

  I come back for a problem that I faced some months ago and I think is getting worse, meaning that it looks like it is affecting more applications. 
  I first noticed that there are some greek websites, that are loading pop-up cookies settings with corrupted greek characters. The rest of the site displays greek properly. When I open the Inspector and check the font, it is Helvetica family font that is not appearing correctly (image 1). This is the case when in Settings->General->Fonts->Advanced, the "Allow pages to choose their own fonts, instead of your selections above" checkbox is selected-ticked. When the checkbox is de-selected/unticked, the same pop-up cookies settings is displaying properly (image 2). The problem remains using Chrome, but Firefox is my main browser. 
  The same issue exists with Thunderbird as well, where again in Settings->General->Fonts->Advanced, the checkbox "Allow messages to use other fonts" changes the way emails appear in greek language (images 3 and 4). 
  I have also noticed that with Discord application, there is a similar issue (image 5). Some greek characters are not displaying properly. I uninstalled and reinstalled Discord (in greek), but the problem remains the same. When installing english version of Discord, it is ok. 
 The problem also seems to be with greek language versions of websites, like facebook homepage in english and in greek language (images 6 and 7). 
 I have tried to search for similar problems and suggested solutions on the internet, but there is no permanent solution so far for my PC. I have followed https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fi... solution, running Firefox in Troubleshoot mode, which resolves the problem temporarily, but not permanently. According to the above solution, "the likely cause is an extension, theme or hardware acceleration", but when I follow every step to determine which one of these (extension, theme or hardware acceleration) is the problem, all of these prove to work properly (supposing I'm following steps correctly). 
 I'm not sure if this is a Mozilla or a Windows issue. Therefore, any suggestions for a permanent solution would be much appreciated.
Hi everyone! I come back for a problem that I faced some months ago and I think is getting worse, meaning that it looks like it is affecting more applications. I first noticed that there are some greek websites, that are loading pop-up cookies settings with corrupted greek characters. The rest of the site displays greek properly. When I open the '''Inspector '''and check the '''font''', it is '''Helvetica '''family font that is not appearing correctly (image 1). This is the case when in '''Settings->General->Fonts->Advanced''', the "'''Allow pages to choose their own fonts, instead of your selections above'''" checkbox is selected-ticked. When the checkbox is de-selected/unticked, the same pop-up cookies settings is displaying properly (image 2). The problem remains using Chrome, but Firefox is my main browser. The same issue exists with '''Thunderbird''' as well, where again in Settings->General->Fonts->Advanced, the checkbox "'''Allow messages to use other fonts'''" changes the way emails appear in greek language (images 3 and 4). I have also noticed that with '''Discord '''application, there is a similar issue (image 5). Some greek characters are not displaying properly. I uninstalled and reinstalled Discord (in greek), but the problem remains the same. When installing english version of Discord, it is ok. The problem also seems to be with greek language versions of websites, like facebook homepage in english and in greek language (images 6 and 7). I have tried to search for similar problems and suggested solutions on the internet, but there is no permanent solution so far for my PC. I have followed [https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fi...] solution, running Firefox in Troubleshoot mode, which resolves the problem temporarily, but not permanently. According to the above solution, "the likely cause is an extension, theme or hardware acceleration", but when I follow every step to determine which one of these (extension, theme or hardware acceleration) is the problem, all of these prove to work properly (supposing I'm following steps correctly). I'm not sure if this is a Mozilla or a Windows issue. Therefore, any suggestions for a permanent solution would be much appreciated.
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

I finally managed to solve the problem, by reinstalling the font correctly, following these steps:

  1. Download the font, as TyDraniu suggested.
  2. Unzip the file.
  3. Open msconfig (see how here).
  4. In "Boot" tab -> "Boot options", select "Safe boot" -> "Minimal" and click "Ok". This will restart Windows in safe mode.
  5. Once in safe mode, reinstall the font (it seems like I couldn't reinstall correctly in normal mode).
  6. Open again msconfig and in "General" tab select "Normal startup" and click "Ok". This will restart Windows in normal mode and Helvetica font will appear correctly.
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (6)

more options

Try to reinstall font using this file: (download)

Helpful?

more options

TyDraniu said

Try to reinstall font using this file: (download)

Do you mean install it in Windows 10? If yes, is there a guide for this?

Okulungisiwe ngu iliastolos

Helpful?

more options

Yes, install it in Win10.

Helpful?

more options

TyDraniu said

Try to reinstall font using this file: (download)

I followed these instructions (the first option) for re-installing the font, but the problem still exists. Any other advice?

Helpful?

more options

Any other ideas?

Helpful?

more options

Isisombululo Esikhethiwe

I finally managed to solve the problem, by reinstalling the font correctly, following these steps:

  1. Download the font, as TyDraniu suggested.
  2. Unzip the file.
  3. Open msconfig (see how here).
  4. In "Boot" tab -> "Boot options", select "Safe boot" -> "Minimal" and click "Ok". This will restart Windows in safe mode.
  5. Once in safe mode, reinstall the font (it seems like I couldn't reinstall correctly in normal mode).
  6. Open again msconfig and in "General" tab select "Normal startup" and click "Ok". This will restart Windows in normal mode and Helvetica font will appear correctly.

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.