Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Hide recent downloads

  • 2 uphendule
  • 2 zinale nkinga
  • 6 views
  • Igcine ukuphendulwa ngu Terry

more options

Recently there was a change how Firefox behaves regarding the recent downloads pop-up menu.

Up until 98.0 if I downloaded an item, the "Download" icon showed that there is a new downloaded item (it became "active", recolored to blue, so just like a nofiication icon), and If I clicked on the "Download" icon (down arrow), than it showed (a small pop-up below the download icon) the 3 recent items that were downloaded.

In 98.0 this was changed.

Now if I download an item, the recent downloaded pop-up list becomes active, and shows the recent items. So if I control the page with keyboard, I have to move back to the page, because now the keyboard input is controlling that small pop-up recent downloads.

If I download an item, just recolor/notify the download icon to blue showing that there is a new item, DON'T show me the recent downloads, and DON'T make that pop-up active, because I use mostly keyboard, and it is hard to control the page with keyboard presses, when that pop-up comes up.

I want the recent download pop-up functionality as it was before 98.0.

How do I change this behavior back? How do I turn off to NOT open the recent downloads pop-up automatically after each download?

Recently there was a change how Firefox behaves regarding the recent downloads pop-up menu. Up until 98.0 if I downloaded an item, the "Download" icon showed that there is a new downloaded item (it became "active", recolored to blue, so just like a nofiication icon), and If I clicked on the "Download" icon (down arrow), than it showed (a small pop-up below the download icon) the 3 recent items that were downloaded. In 98.0 this was changed. Now if I download an item, the recent downloaded pop-up list becomes active, and shows the recent items. So if I control the page with keyboard, I have to move back to the page, because now the keyboard input is controlling that small pop-up recent downloads. If I download an item, just recolor/notify the download icon to blue showing that there is a new item, DON'T show me the recent downloads, and DON'T make that pop-up active, because I use mostly keyboard, and it is hard to control the page with keyboard presses, when that pop-up comes up. I want the recent download pop-up functionality as it was before 98.0. How do I change this behavior back? How do I turn off to NOT open the recent downloads pop-up automatically after each download?
Ama-screenshot ananyekiwe

All Replies (2)

more options

Yes, someone please halp with this!

more options

Change this preference in about:config to false. browser.download.alwaysOpenPanel

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Okulungisiwe ngu Chris Ilias