Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox running very slow except in troubleshoot mode

  • 2 uphendule
  • 1 inale nkinga
  • 11 views
  • Igcine ukuphendulwa ngu FredMcD

more options

I have Windows 10. Since the last update Firefox has been running very slowly, and scrolling is nearly impossible. I have done everything suggested in troubleshooting including refreshing and and eliminating startup cache. Still Firefox will only run normally in troubleshoot mode. This is true on my desktop in my office. My laptop at home won't scroll in PDF using the up and down buttons but will still do so with the mouse. Other than that, it still runs at the normal speed. At my office I'm using version 96.0.1 (64 bit); I'm not at home to check my laptop.

I have Windows 10. Since the last update Firefox has been running very slowly, and scrolling is nearly impossible. I have done everything suggested in troubleshooting including refreshing and and eliminating startup cache. Still Firefox will only run normally in troubleshoot mode. This is true on my desktop in my office. My laptop at home won't scroll in PDF using the up and down buttons but will still do so with the mouse. Other than that, it still runs at the normal speed. At my office I'm using version 96.0.1 (64 bit); I'm not at home to check my laptop.

All Replies (2)

more options

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting to make changes effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Helpful?

more options

If the above did not help;

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address box to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.