Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

images not showing in firefox browser

  • 22 uphendule
  • 2 zinale nkinga
  • 46 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Not all of the images are showing on Yahoo web site using Firefox. Images are showing using Edge. There must be a bug in Firefox.

Ama-screenshot ananyekiwe

All Replies (20)

more options

Can you reproduce this issue in a troubleshoot mode?

Helpful?

more options

The same problem in troubleshoot mode. Firefox has a bug.

Helpful?

more options

What kind of images are this if you check this in the Inspector via the right-click context menu ?

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

Helpful?

more options

Image class=caas. caas error

Helpful?

more options

.....

Okulungisiwe ngu jonzn4SUSE

Helpful?

more options

I tried that. A full browser screenshot is to large for me to send. What is the problem? Other people have had the same problem. You need to fix the error in Firefox.

Helpful?

more options

We can't reproduce this issue.

Helpful?

more options

Go to Yahoo.com, you will see the problem. There is no problem with Edge browser. Why does Firefox put out an inferior product?

Helpful?

more options

I've been there. Can't see a single missing picture.

Helpful?

more options

you have to click on the articles. Not all the articles have the problem. Do I have to lead you people by the hand? You people have a problem.

Helpful?

more options

Firefox is highly configurable and in a lot of cases you get issues when people do not understand the consequences of making changes. This can be about using content blocking extensions that block important content or about changing settings in Settings (Options/Preferences) or about changing prefs directly on the about:config page.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check for problems with preferences. You can delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Helpful?

more options

dfiala said

Do I have to lead you people by the hand? You people have a problem.

Well, maybe an example link. Note: you can put a space before the .com to break the link and prevent the site from delaying your post.

Most people who previously posted about the "gray box" problem on Yahoo news did not report back in detail on what they tried. The only confirmed solution so far was to disable the Ghostery extension. However, if you had the same issue while running Firefox's Troubleshoot Mode, that should rule out extensions as the culprit and it must be something else in your case.

Helpful?

more options

Blame it on the user. Is that all you have? There is no problem when I use Edge browser,so how could it be on me? I've used firefox browser for years and never had a problem. Congratulations you have managed to screw up a good browser. Go to Microsoft and find out how to make a browser.

Helpful?

more options

See also:

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

Okulungisiwe ngu cor-el

Helpful?

more options

This is all BS. I shouldn't have to do work arounds on your browser. I've tried most of these work arounds. They don't work for me.

Helpful?

more options

Can you provide the url to a troublesome page?

Helpful?

more options

I have given you that. Something is wrong. You people don't seem to be on the same page with this.

Helpful?

more options

Eventually I found one. The thing is, you can't reproduce the problem using a direct link like this:

https://news.yahoo.com/children-vaccination-christmas-124521435.html

The problem occurs when you are loading new stories into the same tab.* For example, you can start on the following page and click the link for that story:

https://news.yahoo.com/originals/

For some reason, Yahoo News uses a style rule to hide certain images (the rule makes them transparent). Presumably a script unhides them after they load, but it doesn't work properly when you are loading stories in the same tab through a simple click. You can see the leftover rule to hide the image in the attached screenshot (from Firefox's Page Inspector panel).

Reloading the story (clicking the Reload button on the toolbar or Ctrl+r) triggers the script to work correctly so after reload, you can see the image. But who wants to do that every time...

Whatever the root cause, it will need to be fixed by Yahoo or reported as a bug related to Yahoo's script by someone who can tease out why the script fails to run (correctly) in Firefox .

* It doesn't occur if you open stories in a new tab using Ctrl+click or middle-click, so that method won't let you see the problem.

Okulungisiwe ngu jscher2000

Helpful?

more options

If you want an immediate workaround, you can fix it by applying a custom style rule to Yahoo News pages using either the Stylus extension or a userContent.css file. Stylus is easier for setup and tweaking, but if you already have a userContent.css file, see #5 below for the code.

(1) Install the extension from https://addons.mozilla.org/firefox/addon/styl-us/ (when the installation confirmation appears, check the box to allow it to run in private windows if you read Yahoo News in private windows)

(2) While viewing a news story with this problem, click the extension's "S" button on the toolbar, and then hover your mouse over "news". Once the confirmation tooltip appears that this will apply to all pages on news.yahoo.com, click. (First attached screenshot.)

(3) If you like, edit the name of the style (by default, news.yahoo.com)

(4) Click in the editor box and paste this code (Second attached screenshot):

/*** Force visibility of hidden "lazy load" image on Yahoo News ***/
     /* Override opacity: 0 */
.caas-img-container.caas-img-loader .caas-img {
  opacity: 1 !important;
}
     /* Suppress gradient haze */
.caas-img-container.caas-img-loader::after {
  display: none !important;
}


(5) Click the Save button, then switch back to your problem tab to see whether it worked. Assuming it worked, this is now going to be done automatically and you can close the Stylus tab. (Third attached screenshot.)

Success?

Note: This kind of site modification is subject to future failure when Yahoo changes how it does things...

Helpful?

more options

Now it is Yahoo's fault. First it was my fault. Edge browser is compatible with yahoo. Firefox needs to make their browser compatible. If you are going to put a browser in the public domain you need to make it compatible with all web sites. Do your job.

Helpful?

  1. 1
  2. 2
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.