Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox opens in tiny window after latest update.

  • 4 uphendule
  • 2 zinale nkinga
  • 23 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Firefox opens in a small box at the top left of the computer screen about 1/9 the size of the viewing area. I have to click on the "maximize" icon (the square box(es)twice to get a normal viewing screen. Note: I am not referring to "full screen." This began after the last Firefox update. I have cleared the cache, cookies, data, etc. and startup cache and restarted Firefox and the computer. I haven't "Refreshed" Firefox, yet, because I don't want to go through the hassle of putting everything back together if it isn't going to work. How do I get Firefox to open in a "maximized" window?

Isisombululo esikhethiwe

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data \Mozilla\Firefox\Profiles\

Search for the above file. Then rename or delete it. Restart Firefox.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

Isisombululo Esikhethiwe

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data \Mozilla\Firefox\Profiles\

Search for the above file. Then rename or delete it. Restart Firefox.

Helpful?

more options

Try the above advice but it did not solve the problem. Luckily, I have Vivaldi working. But I don't have access to my passwords and bookmarks. When I open Firefox, I get the little box on the taskbar icon, but I can't get it to go full screen.

Helpful?

more options

A post was flagged as Solved Problem. If the problem is not solved, please remove that flag. If you don’t, others that can help may not read this post.

Go to that message, and use the Undo link to its right.

Helpful?

more options

Reboot the computer. Start Firefox. Is the problem still there?


Right-click the Firefox icon on the taskbar. Select Open New Window. Anything?

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.