X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

After Firefox 67, auto-filling passwords suddenly make the textboxes where they are entered completely disappear and you cannot tell what is going on.

Kuphostiwe

All details in the title, check the screenshot for more info. Apparently this happens only to me and only after updating to version 67, because I've seen other PCs running Firefox 67 without encountering this issue. P.S. For some reason the screenshot in the original post wouldn't show up, so I posted it as a reply.

NotAnIceWolf said

Screenshot here:

In the attached screenshot, the password HAS been auto-filled, and now the textboxes don't show up, but if I click on login, it works! It's a visual issue. Any help would be appreciated. (A thought of mine: Could it be a graphics driver issue? I haven't changed 'em at all before or after the transition to version 67 though...) Thanks in advance, everyone!

All details in the title, check the screenshot for more info. Apparently this happens only to me and only after updating to version 67, because I've seen other PCs running Firefox 67 without encountering this issue. P.S. For some reason the screenshot in the original post wouldn't show up, so I posted it as a reply. ''NotAnIceWolf [[#answer-1226924|said]]'' <blockquote> Screenshot here: </blockquote> In the attached screenshot, the password HAS been auto-filled, and now the textboxes don't show up, but if I click on login, it works! It's a visual issue. Any help would be appreciated. (A thought of mine: Could it be a graphics driver issue? I haven't changed 'em at all before or after the transition to version 67 though...) Thanks in advance, everyone!
Ama-screenshot ananyekiwe

Okulungisiwe ngu NotAnIceWolf

Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Eminye Imininingwane

Umnikazi wombuzo

Screenshot here:

Screenshot here:
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17408 izisombululo 157258 izimpendulo
Kuphostiwe

This could be a problem with the Windows theme you are using and with the text color getting transparent.

Do you still see the mouse pointer changing? If you click in the input field area then you should be able to make the text visible via select all (Ctrl+A).

What properties do you see applied?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

This could be a problem with the Windows theme you are using and with the text color getting transparent. Do you still see the mouse pointer changing? If you click in the input field area then you should be able to make the text visible via select all (Ctrl+A). What properties do you see applied? You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. *https://developer.mozilla.org/en-US/Tools/Page_Inspector
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

cor-el said

This could be a problem with the Windows theme you are using and with the text color getting transparent. Do you still see the mouse pointer changing? If you click in the input field area then you should be able to make the text visible via select all (Ctrl+A). What properties do you see applied? You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

No, the textboxes are still there. The cursor changes to the text indicator normally, and I have already inspected the elements of the page and the textboxes DO show up, that's why I said it's a visual-only issue. After all, the login works fine, so they would have to be there either way, or the websites wouldn't be able to retrieve the data contained in them.

''cor-el [[#answer-1226927|said]]'' <blockquote> This could be a problem with the Windows theme you are using and with the text color getting transparent. Do you still see the mouse pointer changing? If you click in the input field area then you should be able to make the text visible via select all (Ctrl+A). What properties do you see applied? You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. *https://developer.mozilla.org/en-US/Tools/Page_Inspector </blockquote> No, the textboxes are still there. The cursor changes to the text indicator normally, and I have already inspected the elements of the page and the textboxes DO show up, that's why I said it's a visual-only issue. After all, the login works fine, so they would have to be there either way, or the websites wouldn't be able to retrieve the data contained in them.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
FredMcD
  • Top 10 Contributor
4220 izisombululo 58908 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
jscher2000
  • Top 10 Contributor
8632 izisombululo 70597 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Firefox 67 changes the background color of auto-filled login fields using a CSS "filter" property with a complex brew of instructions:

filter: grayscale(21%) brightness(88%) contrast(161%) invert(10%) sepia(40%) saturate(206%);

Perhaps your Firefox has a problem showing fields modified using a filter?


Note: A custom style rule applied to "Everything" using Stylus or Stylish can strip the filter:

input {
    filter: none !important;
}

However, that could impact visibility of fields that rely on filter for contrast with the text, so some more fine-tuning probably is needed.

Firefox 67 changes the background color of auto-filled login fields using a CSS "filter" property with a complex brew of instructions: filter: grayscale(21%) brightness(88%) contrast(161%) invert(10%) sepia(40%) saturate(206%); Perhaps your Firefox has a problem showing fields modified using a filter? ---- ''Note: A custom style rule applied to "Everything" using Stylus or Stylish can strip the filter:'' <pre>input { filter: none !important; } </pre> ''However, that could impact visibility of fields that rely on filter for contrast with the text, so some more fine-tuning probably is needed.''

Okulungisiwe ngu jscher2000

Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

FredMcD said

Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Yeah, safe mode seems to have fixed it, so I'm guessing an extension is to blame... However, this is quite peculiar, as I haven't installed any new add-ons since updating to version 67. Guess I will have to disable each one manually to find the culprit. However, I still don't get how ver. 67 managed to break 'em...

''FredMcD [[#answer-1227233|said]]'' <blockquote> [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? </blockquote> Yeah, safe mode seems to have fixed it, so I'm guessing an extension is to blame... However, this is quite peculiar, as I haven't installed any new add-ons since updating to version 67. Guess I will have to disable each one manually to find the culprit. However, I still don't get how ver. 67 managed to break 'em...
Ingabe lokhu kube usizo kuwena?
Isicaphuno
FredMcD
  • Top 10 Contributor
4220 izisombululo 58908 izimpendulo
Kuphostiwe

NotAnIceWolf said

. . . I still don't get how ver. 67 managed to break 'em...

You know Mozilla; If it ain't broke, unfix it.  ;-)

''NotAnIceWolf [[#answer-1227314|said]]'' <blockquote> . . . I still don't get how ver. 67 managed to break 'em... </blockquote> You know Mozilla; If it ain't broke, unfix it. ;-)
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

FredMcD said

NotAnIceWolf said
. . . I still don't get how ver. 67 managed to break 'em...

You know Mozilla; If it ain't broke, unfix it.  ;-)

So, I went and disabled every single extension manually (one at a time) to pinpoint the one causing the interference. Apparently, even then, the problem persists so I can't tell what is causing it. Only Safe Mode fixes it but I am at a loss here... Any more tips?

P.S. I didn't restart Firefox after disabling each add-on individually, did I have to do that?

''FredMcD [[#answer-1227335|said]]'' <blockquote> ''NotAnIceWolf [[#answer-1227314|said]]'' <blockquote> . . . I still don't get how ver. 67 managed to break 'em... </blockquote> You know Mozilla; If it ain't broke, unfix it. ;-) </blockquote> So, I went and disabled every single extension manually (one at a time) to pinpoint the one causing the interference. Apparently, even then, the problem persists so I can't tell what is causing it. Only Safe Mode fixes it but I am at a loss here... Any more tips? P.S. I didn't restart Firefox after disabling each add-on individually, did I have to do that?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8632 izisombululo 70597 izimpendulo
Kuphostiwe

Firefox's Safe Mode does a few other things:

  • Disable all extensions
  • Disable Firefox from using hardware acceleration of graphics (to set that manually, see: Firefox's performance settings)
  • Disable custom style sheet files (userChrome.css, userContent.css)
  • Disable JavaScript compilers (probably not relevant here)
Firefox's Safe Mode does a few other things: * Disable all extensions * Disable Firefox from using hardware acceleration of graphics (to set that manually, see: [[Firefox's performance settings]]) * Disable custom style sheet files (userChrome.css, userContent.css) * Disable JavaScript compilers (probably not relevant here)
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17408 izisombululo 157258 izimpendulo
Kuphostiwe

Best is to disable all extensions and then close and restart Firefox and test if the problem has gone or is still there. Then at least you know if this is caused by an extension on something else (possibly hardware acceleration or userContent.css).

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

With WebExtensions a restart might not be necessary, but you never know if there isn't anything left in one of the caches that might still be active.

Best is to disable all extensions and then close and restart Firefox and test if the problem has gone or is still there. Then at least you know if this is caused by an extension on something else (possibly hardware acceleration or userContent.css). If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears. With WebExtensions a restart might not be necessary, but you never know if there isn't anything left in one of the caches that might still be active.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.