X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

opening new private window maximized

Kuphostiwe

I am using a windows taskbar icon to open firefox 66.03 on windows 10 pro, and it is configured to always open private windows. When I click on this icon to open firefox, the window opens about half-screen, so that every time I open firefox I have to click on the maximize button in the upper right. Is there any way to make firefox open with the window maximized? I was pretty sure it used to do this when I was using non-private browsing windows. Thanks

I am using a windows taskbar icon to open firefox 66.03 on windows 10 pro, and it is configured to always open private windows. When I click on this icon to open firefox, the window opens about half-screen, so that every time I open firefox I have to click on the maximize button in the upper right. Is there any way to make firefox open with the window maximized? I was pretty sure it used to do this when I was using non-private browsing windows. Thanks

Okulungisiwe ngu 65719283

Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4221 izisombululo 58912 izimpendulo
Kuphostiwe

The browser should store how the windows were set up when it was closed.

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\

Search for the above files. Then rename or delete it. Restart Firefox.

The browser should store how the windows were set up when it was closed. https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt '''xulstore.json''' file. '''Close Firefox. ''' Open your file browser to this hidden location: * '''Mac: ''' *~/Library/Application Support/Firefox/Profiles * '''Linux: ''' *~/.mozilla/firefox/Profiles * '''Windows: ''' %AppData%\Mozilla\Firefox\Profiles * *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles * '''Windows XP: ''' C:\Documents and Settings\<user>\Application Data<br> \Mozilla\Firefox\Profiles\ Search for the above files. Then rename or delete it. Restart Firefox.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Thanks for the response, my firefox profile is not stored in the default location, but I opened it and deleted the xulstore.json file. Reopened firefox, maximized the window, then closed it again. Re-opening firefox the window is not maximized, so unfortunately this didn't fix the problem.

Thanks for the response, my firefox profile is not stored in the default location, but I opened it and deleted the xulstore.json file. Reopened firefox, maximized the window, then closed it again. Re-opening firefox the window is not maximized, so unfortunately this didn't fix the problem.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8633 izisombululo 70605 izimpendulo
Kuphostiwe

right-clicking Firefox on the Windows Task Bar > New private window, the result varies:

  • When I have a maximized Firefox window active => new private window is maximized
    • When I change focus to a different application before using the Task list command, same result
  • When I have a resizable Firefox window active => new private window is resizable and positioned in relation to the active window
    • When I change focus to a different application before using the Task list command, same result

So that is consistent with what I would expect from pressing Ctrl+Shift+p inside Firefox.


I'm on Windows 10, and you entered Windows 10, but your Firefox reported Windows 7. Hmm, could you check the Compatibility settings on Firefox? Find the icon you use to start Firefox, and either:

  • Right-click a desktop shortcut, then click Properties
  • Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties

You should clear all the boxes on the Compatibility tab for best results (giant screenshot below).

Any difference the next time you start Firefox?

right-clicking Firefox on the Windows Task Bar > New private window, the result varies: * When I have a maximized Firefox window active => new private window is maximized ** When I change focus to a different application before using the Task list command, same result * When I have a resizable Firefox window active => new private window is resizable and positioned in relation to the active window ** When I change focus to a different application before using the Task list command, same result So that is consistent with what I would expect from pressing Ctrl+Shift+p inside Firefox. ---- I'm on Windows 10, and you entered Windows 10, but your Firefox reported Windows 7. Hmm, could you check the Compatibility settings on Firefox? Find the icon you use to start Firefox, and either: * Right-click a desktop shortcut, then click Properties * Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties You should clear all the boxes on the Compatibility tab for best results (giant screenshot below). <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-10-14-29-54-e33666.png"> Any difference the next time you start Firefox?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8633 izisombululo 70605 izimpendulo
Kuphostiwe

I guess I misread your question, sorry.

Still, please check the compatibility settings to see whether that has any effect.

If you stretch out the resizable window to the maximum height and width before maximizing, at least if you get a resizable window in the next section, it should be much larger.

I guess I misread your question, sorry. Still, please check the compatibility settings to see whether that has any effect. If you stretch out the resizable window to the maximum height and width before maximizing, at least if you get a resizable window in the next section, it should be much larger.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Firefox is reported as windows 7 because I have resist fingerprinting set to true. The versions I reported in the post are correct.

When I have a private window opened and maximized, then right click on the task bar and open new private window (or just new window for that matter), it opens half-sized, and not fully maximized. Dragging the window to "close" to maximized before fully maximizing (or just leaving it like this, closing it, then reopening a new window by right clicking on the task bar icon) doesn't change anything, they always open the same half-sized.

All compatibility mode boxes are unchecked.

Firefox is reported as windows 7 because I have resist fingerprinting set to true. The versions I reported in the post are correct. When I have a private window opened and maximized, then right click on the task bar and open new private window (or just new window for that matter), it opens half-sized, and not fully maximized. Dragging the window to "close" to maximized before fully maximizing (or just leaving it like this, closing it, then reopening a new window by right clicking on the task bar icon) doesn't change anything, they always open the same half-sized. All compatibility mode boxes are unchecked.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17411 izisombululo 157274 izimpendulo
Kuphostiwe

"Resist Fingerprinting" also affects the screen dimensions, so try again with disabled RFP to see if that makes a difference.

"Resist Fingerprinting" also affects the screen dimensions, so try again with disabled RFP to see if that makes a difference.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Interesting, you're right, turning off resist.fingerprinting fixed the problem.

So there's no way then to have resist fingerprinting set and also be able to have firefox open windows to full screen size without manually maximizing them?

Interesting, you're right, turning off resist.fingerprinting fixed the problem. So there's no way then to have resist fingerprinting set and also be able to have firefox open windows to full screen size without manually maximizing them?

Okulungisiwe ngu 65719283

Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17411 izisombululo 157274 izimpendulo
Kuphostiwe
See: *https://dxr.mozilla.org/mozilla-release/source/dom/base/nsContentUtils.cpp#2104
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.