X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

can't focus on password input

Kuphostiwe

I cant focus on password fields on some sites.

as mentioned here: https://support.mozilla.org/en-US/questions/1186447

i opened Firefox with safe mode, it works as it should, i can type anything on anywhere. No problem appears.

But still i cant type on Firefox that started normally.

What is the problem here? How can i solve it? Should i open Firefox with safemode everytime?

Ubuntu 18, Firefox 59.0.2 (64-bit)

I cant focus on password fields on some sites. as mentioned here: https://support.mozilla.org/en-US/questions/1186447 i opened Firefox with safe mode, it works as it should, i can type anything on anywhere. No problem appears. But still i cant type on Firefox that started normally. What is the problem here? How can i solve it? Should i open Firefox with safemode everytime? Ubuntu 18, Firefox 59.0.2 (64-bit)

Okulungisiwe ngu khaine

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4254 izisombululo 59572 izimpendulo
Kuphostiwe

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Umnikazi wombuzo

Thanks for the reply, Only addon i have is 'Gnome Shell integration', which is disabled. Nothing else is installed on Firefox, and it still continues.

I cant even right click to 'Inspect Element' on password fields.

Thanks for the reply, Only addon i have is 'Gnome Shell integration', which is disabled. Nothing else is installed on Firefox, and it still continues. I cant even right click to 'Inspect Element' on password fields.
FredMcD
  • Top 10 Contributor
4254 izisombululo 59572 izimpendulo
Kuphostiwe

Let’s do a full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Let’s do a full clean re-install; [http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems] {web link} Save the file. Then '''Close Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows: ''' C:\Program Files C:\Program Files (x86) '''Mac: ''' Open the ''' "Applications" ''' folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux: ''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any '''Mozilla''' or '''Firefox''' program folders. Do not remove the '''Mozilla Thunderbird''' folder if there is one. '''Do Not''' remove any profile folders. After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your '''Computer''' in safe mode and try again. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Umnikazi wombuzo

Hello again,

I did remove/purge, reboot, and reinstall.

I reinstall with package manager, when it didnt work still, i downloaded from https://www.mozilla.org/en-US/firefox/ and tried, still wasnt working out.

Even tried with removing Profile folders.

One weird thing i noticed though: When i continuously click on the field and push random keys from keyboard, it sometimes types some of the keys i pushed. (without focusing or selecting the chars in the field)

And i checked the element with Inspector, no js bindings on it. And i still cant right click the element.

Hello again, I did remove/purge, reboot, and reinstall. I reinstall with package manager, when it didnt work still, i downloaded from https://www.mozilla.org/en-US/firefox/ and tried, still wasnt working out. Even tried with removing Profile folders. One weird thing i noticed though: When i continuously click on the field and push random keys from keyboard, it sometimes types some of the keys i pushed. (without focusing or selecting the chars in the field) And i checked the element with Inspector, no js bindings on it. And i still cant right click the element.

Umnikazi wombuzo

One more note: From inspector, when i change the type to 'text', it types/focuses with no problem, changing it back to 'password', same problem appears.

One more note: From inspector, when i change the type to 'text', it types/focuses with no problem, changing it back to 'password', same problem appears.
user1494117 0 izisombululo 28 izimpendulo
Kuphostiwe

if you are open to running the beta version i can tell you this:

in /home/*username*/ make a random directory. i used /Stuff download the beta version and extract it in Stuff or whatever you chose. it should say /Stuff/firefox/ respectively.

then all you need to do is cd to /home/*username*/Stuff/firefox/ then type ./firefox or ./firefox & to run it

please see if this helps :)

if you are open to running the beta version i can tell you this: in /home/*username*/ make a random directory. i used /Stuff download the beta version and extract it in Stuff or whatever you chose. it should say /Stuff/firefox/ respectively. then all you need to do is cd to /home/*username*/Stuff/firefox/ then type ./firefox or ./firefox & to run it please see if this helps :)

Umnikazi wombuzo

@tesko Thanks for the advice, just tried Firefox Developer and Firefox Beta, both have the same problem, no luck here :)

@tesko Thanks for the advice, just tried Firefox Developer and Firefox Beta, both have the same problem, no luck here :)
user1494117 0 izisombululo 28 izimpendulo
Kuphostiwe

@khaine when you run firefox in console (read terminal) what happens? does it give any weird errors? also what happens when you hit Ctrl+shift+a ? does it go straight to google.com?

@khaine when you run firefox in console (read terminal) what happens? does it give any weird errors? also what happens when you hit Ctrl+shift+a ? does it go straight to google.com?

Umnikazi wombuzo

ctrl+shift+a opens about:addons page, and since its a fresh install, nothing much there.

I run from terminal, it shows nothing, just started and working without any messages.

Attached Screenshots.

btw, this is not happening in any other browser

ctrl+shift+a opens about:addons page, and since its a fresh install, nothing much there. I run from terminal, it shows nothing, just started and working without any messages. Attached Screenshots. btw, this is not happening in any other browser
user1494117 0 izisombululo 28 izimpendulo
Kuphostiwe

hmm, you also dont have anything for DRM either, strange too. this is weird, are you sure you dont have any malware? it can happen with linux too but its rare and can just be annoying because it cant "hurt" linux. can you come visit us on IRC? this is a very unique problem.

hmm, you also dont have anything for DRM either, strange too. this is weird, are you sure you dont have any malware? it can happen with linux too but its rare and can just be annoying because it cant "hurt" linux. can you come visit us on IRC? this is a very unique problem.

Umnikazi wombuzo

Its a fresh Ubuntu 18 install (which came out almost a week ago), so 'malware' is a bit unlikely i guess. No programs installed with external ppa or source.

I can come to IRC channel.

Its a fresh Ubuntu 18 install (which came out almost a week ago), so 'malware' is a bit unlikely i guess. No programs installed with external ppa or source. I can come to IRC channel.
FredMcD
  • Top 10 Contributor
4254 izisombululo 59572 izimpendulo
Kuphostiwe

I'm beginning to think there is a script program causing the issue.

Please provide public link(s) (no password) that we can check out. No Personal Information Please !


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

I'm beginning to think there is a script program causing the issue. Please provide public link(s) (no password) that we can check out. '''No Personal Information Please ! ''' ----------- Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * '''Cookies; ''' [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * '''Cache; ''' [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}
user1494117 0 izisombululo 28 izimpendulo
Kuphostiwe

we solved it! its an issue with ubuntu 18 install, not firefox. if ANY one else runs Ubuntu 18 and has this problem, lettice know :)

good luck with Debian ~wes

we solved it! its an issue with ubuntu 18 install, not firefox. if ANY one else runs Ubuntu 18 and has this problem, lettice know :) good luck with Debian ~wes