Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

When I right click, (when typing text) the option for LANGUAGE or SPELLING is not there anymore. How can I get it back?

  • 8 uphendule
  • 7 zinale nkinga
  • 151 views
  • Igcine ukuphendulwa ngu cor-el

more options

Up until two days ago, when I was typing an email (on web mail for example, or typing this text here), when I right click I would get option to Spell Check and the option to Change the Language. These two options have disappeared. The spell check option is CHECKED in the Options section. When I right click, (when typing text) the option for LANGUAGE or SPELLING is not there anymore. How can I get it back?

Isisombululo esikhethiwe

Can you tell us if this is a rich text editor?

When spell checking is enabled globally and spellcheck="true" then you should see Language in the right-click context menu.


You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (8)

more options

The below is you can set up Check your spelling as you type about:preferences#advanced.

If all else fails, report to this thread as a reference: https://support.mozilla.org/en-US/questions/1114850

more options

That (Check your spelling as you type) was already checked, but still n ot working.

I have also tried the suggested: Type about:config<enter> in the address bar......layout.spellcheck....... etc. - That did not work either.

The options for spellcheck and to change the language are no longer there when I right click while typing text.

Please help!

more options

What kind of editor is used?

Is this a plain text editor like used by this forum or is this a rich text editor that allows HTML formatting code?

There is probably a spellcheck="false" attribute that prevents Firefox from showing the context menu items.

You can right-click in the text area and select "Inspect Element" to open the built-in Inspector with this element selected.

When you see the spellcheck="false" attribute then you can right-click this element and change its value to true. That should bring back the context menu entries.

Possible bookmarklet you can use for a rich text editor:

javascript:void(document.activeElement.contentDocument.querySelector('*[spellcheck]').setAttribute('spellcheck','true'));
more options

Thanks for your reply. Unfortunately, no luck again. I've checked what you suggested and the Spellckeck = true.

So bizzarre!!!

more options

Hi   !

Separate issue :   Your system details show that you have two versions of Shockwave Flash installed,   which could cause problems. Would you please remove the oldest version (21.0.r0)   ?



Then back to your problem :

Let's try Firefox in Safe Mode : If Firefox is not running : Hold down the Shift key when starting Firefox. If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

more options

Isisombululo Esikhethiwe

Can you tell us if this is a rich text editor?

When spell checking is enabled globally and spellcheck="true" then you should see Language in the right-click context menu.


You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

Thank you for your replies all. I have worked it out. The language packs were installed but not "Unpacked" All OK now. Thanks

more options

Language packs (strings for the user interface) do not need to be unpacked, but dictionaries always do need to be unpacked (they have an unpack property), so do not mix up these two.