X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox slow and laggy after updating to Firefox 51

Kuphostiwe

Hello, I have yet another problem to talk about. Today, I updated from Firefox 50.1 to Firefox 51. It's been really slow and buggy ever since. Can anyone help me on the issue? I would really appreciated it.

Hello, I have yet another problem to talk about. Today, I updated from Firefox 50.1 to Firefox 51. It's been really slow and buggy ever since. Can anyone help me on the issue? I would really appreciated it.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 15.23.20053
  • Google Update
  • Next Generation Java Plug-in 11.111.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • Shockwave Flash 24.0 r0
  • 5.1.50901.0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4258 izisombululo 59615 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- '''https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster''' '''https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix''' '''https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding'''

Impendulo Ewusizo

Hello Fred, this problem happens if I use Firefox for an hour. I don't think Safe Mode would help. Even with a "faulty" RAM, Firefox 50.1 ran very smoothly with sometimes minor problems. This issue started happening after updating.

Hello Fred, this problem happens if I use Firefox for an hour. I don't think Safe Mode would help. Even with a "faulty" RAM, Firefox 50.1 ran very smoothly with sometimes minor problems. This issue started happening after updating.
FredMcD
  • Top 10 Contributor
4258 izisombululo 59615 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Don't do this until you are sure. I called for more help.

Install an older version of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under "I still want to downgrade" Click the Directory of other versions and languages link Look for the directory of the version that you want. But remember that old versions may have security issues.

Don't do this until you are sure. I called for more help. '''[https://support.mozilla.org/en-US/kb/install-older-version-of-firefox Install an older version of Firefox]''' {web link} Be sure to read everything here. If you still want to downgrade, look under "I still want to downgrade" Click the '''Directory of other versions and languages''' link Look for the directory of the version that you want. But remember that '''old versions may have security issues.'''

Umnikazi wombuzo

FredMcD said

Don't do this until you are sure. I called for more help. Install an older version of Firefox {web link} Be sure to read everything here. If you still want to downgrade, look under "I still want to downgrade" Click the Directory of other versions and languages link Look for the directory of the version that you want. But remember that old versions may have security issues.

Thanks. I'll try that tomorrow.

''FredMcD [[#answer-957624|said]]'' <blockquote> Don't do this until you are sure. I called for more help. '''[https://support.mozilla.org/en-US/kb/install-older-version-of-firefox Install an older version of Firefox]''' {web link} Be sure to read everything here. If you still want to downgrade, look under "I still want to downgrade" Click the '''Directory of other versions and languages''' link Look for the directory of the version that you want. But remember that '''old versions may have security issues.''' </blockquote> Thanks. I'll try that tomorrow.

Umnikazi wombuzo

Fred, just to give you an update, I found the root cause of the problem. It was because firefox.exe duplicated. I tried closing the one that was eating up all the memory and I got "Bad news first: This tab has crashed".

Fred, just to give you an update, I found the root cause of the problem. It was because firefox.exe duplicated. I tried closing the one that was eating up all the memory and I got "Bad news first: This tab has crashed".
FredMcD
  • Top 10 Contributor
4258 izisombululo 59615 izimpendulo
Kuphostiwe

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess
cor-el
  • Top 10 Contributor
  • Moderator
17534 izisombululo 158551 izimpendulo
Kuphostiwe

Try to disable multi-process tabs in Firefox.

You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false
Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page. *browser.tabs.remote.autostart = false *browser.tabs.remote.autostart.2 = false *http://www.ghacks.net/2016/07/22/multi-process-firefox/