Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

FF lockup due to advertiser javascript

  • 14 uphendule
  • 1 inale nkinga
  • 48 views
  • Igcine ukuphendulwa ngu FredMcD

more options

When browsing on some websites, FireFox will become totally unresponsive and will, on occasion display a dialogue that gives the options to continue running a script, debugging a script or stopping a script. In all most all instances selecting the stop script fails to do so and Firefox remains in an unresponsive state and in some cases the FF thread must be killed in task manager in order to recover.

During the recovery process one must quickly stop the offending website before it has a chance to run the script again or you must again, stop FF from running using Task Manager.

I realise that javascript can be turned off for certain domains, but how is someone supposed to predict what domain he/she will end up on in a typical net browsing session?

Mozilla please fix this issue and prevent wayward scripts from locking up FF. This issue was resolved in earlier versions but it has returned in this version 46.0 and the previous version of FF.

I would welcome any comments and effective solutions for this issue.

TIA

All Replies (14)

more options

I forgot to add some example scripts:

Script: http://secure-ds.serving-sys.c…urstingScript/SZMKFLVPAIDBR.js:12 Script: http://secure-ds.serving-sys.c…urstingScript/SZMKFLVPAIDBR.js:17

Sorry, I also forgot to record the web address of the site running these scripts, all I can say is that I searched google for the 'best apps for raspbian' and selected one of the first results.

I believe it was Sourcedigit.com but may be mistaken.

more options
more options

Thanks Fred, I have increased the dom.max_script_run_time to 20 and I will wait and see if that makes any difference. I will report back if it works or not.

My plugins are up to date also, thanks.

more options

OK, so I visited the link I posted about earlier and left FF sit on that page for 5 mins or so and while it did not lock up completely it did still lockup for 10 to 15 secs at a time, repeatedly.

Maybe I should increase that value to 30?

more options

I changed the value to 30 and revisited that page, but no go, full lock up again.

I don't think that is the solution.

more options

Changing that value back to 20 has definitely not fixed the issue, just had more full lock ups.

more options

I've called the big guys to help you. Good luck.

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

more options

Thanks again for the reply. I started FF in safe mode with addons disabled and yes, FF still locks up completely when I visit that page.

The page in question is this one: https://www.google.com.au/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0ahUKEwigwd_8r7LMAhUkI6YKHceSBHMQFggbMAA&url=http%3A%2F%2Fsourcedigit.com%2F7398-top-10-best-raspberry-pi-apps%2F&usg=AFQjCNF31UzUja8O3n4yJhN_QoCYNePBzw&sig2=bpHqKySOXEjGPpuayTppfw

which resolves to: http://sourcedigit.com/7398-top-10-best-raspberry-pi-apps/

But do note, that it does not lock up every time I visit that page. It appears to only happen when the page runs certain scripts.

PS: I really do appreciate your help on this, thanks again.

Okulungisiwe ngu trumpy81

more options

After updating FireFox to 46.0.1, I revisited that page and apart from some minor performance issues, I did not have any problems with FireFox locking up. :)

I opened the same page many times and let it sit on those pages for several minutes at a time all with no issues except from a little jerkiness when scrolling through the page.

That was most likely to be caused by the page still loading which is the performance issue I spoke of, but I am satisfied that the issue has been resolved for now at least.

Thanks to you and the awesome folks that maintain FireFox, I still think it is the best browser out there. :)

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

more options

Looks like I spoke too soon, I am still experiencing total lock up with Firefox on some sites.

The latest site is http://cpuboss.com/cpus/Intel-Pentium-N3700-vs-Intel-Atom-C2538

Although the stop script dialogue did eventually come up, it is still very annoying to say the least.

I have found on occasion though, if I end task the plugin container for FireFox (32 bit) thread, that will sometimes restore access to FireFox, but not always.

I still have dom.max_script_run_time set to 20 should I change that at all?

more options

I have no problem with the links you posted.

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.

Go to that message, and use the link to it's right.

more options

Thanks and done.

Try entering the page again and wait a few minutes, sometimes the offending script does not run or does not run straight away.

more options

I still have no problems. I've called the big guys to help you. Good luck.