搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox does not remember the volume level on flash files e.g. YouTube videos, why?

  • 5 回覆
  • 3 有這個問題
  • 1 次檢視
  • 最近回覆由 RiCDavid

more options

Audio and video files always begin playing at full volume instead of remembering the previous volume level. Disabling all add-ons does not fix the problem and the problem does not exist when I use other browsers. I have tried going into my flash settings (both local and global when right clicking on a video) and telling it to allow the storage of data on my hard drive but this also hasn't fixed the problem.

Some flash videos actually do retain the volume level/mute status but YouTube, DailyMotion, and others aren't among them even though they function properly when I use Chrome. This is extremely irritating as it resets the volume to max during playlist play.

Audio and video files always begin playing at full volume instead of remembering the previous volume level. Disabling all add-ons does not fix the problem and the problem does not exist when I use other browsers. I have tried going into my flash settings (both local and global when right clicking on a video) and telling it to allow the storage of data on my hard drive but this also hasn't fixed the problem. Some flash videos actually do retain the volume level/mute status but YouTube, DailyMotion, and others aren't among them even though they function properly when I use Chrome. This is extremely irritating as it resets the volume to max during playlist play.

被選擇的解決方法

I only now noticed you somehow seem to have two versions of Flash Player installed. Perform a clean installation of the latest version as follows.

  1. From the following page, save the uninstaller somewhere handy, like the desktop.
  2. From the following page, save the installer for other browsers. If you also use Flash Player in Internet Explorer, also save the ActiveX version.
  3. Exit all applications.
  4. Run the uninstaller.
  5. In Windows Explorer, try to open the following folders. If they still exist, delete them manually.
    • C:\Windows\system32\Macromed\Flash\
    • %AppData%\Adobe\Flash Player\
    • %AppData%\Macromedia\Flash Player\
  6. Restart your computer.
  7. Run the installer for other browsers.
  8. Run the ActiveX installer if you downloaded it.
從原來的回覆中察看解決方案 👍 1

所有回覆 (5)

more options

YouTube sound volume is stored in the soundData.sol Flash cookie from the s.ytimg.com domain.

  • When clearing all cookies in Firefox, Flash cookies are cleared as well.
  • Flash cookies can be independently deleted by an add-on like BetterPrivacy.
  • Content from ytimg.com can be blocked in add-ons like Adblock Plus.
  1. Click either the Firefox button or the Tools menu and choose Add-ons, then Extensions. Disable everything in that category.
  2. Restart Firefox.
  3. Open a YouTube video and adjust the volume; e.g. Bastille - Things We Lost In The Fire.
  4. Open Windows Explorer, paste the following into the address bar and press Enter.
    • %AppData%\Macromedia\Flash Player\#SharedObjects\
  5. In that folder you should see a folder with a random name — open it. Inside that one, does the s.ytimg.com folder exist? If yes, does it contain a soundData.sol file?
more options

Thank you for your reply. I have followed those steps and no, the folder does not contain a 's.ytimg.com' folder.

more options

選擇的解決方法

I only now noticed you somehow seem to have two versions of Flash Player installed. Perform a clean installation of the latest version as follows.

  1. From the following page, save the uninstaller somewhere handy, like the desktop.
  2. From the following page, save the installer for other browsers. If you also use Flash Player in Internet Explorer, also save the ActiveX version.
  3. Exit all applications.
  4. Run the uninstaller.
  5. In Windows Explorer, try to open the following folders. If they still exist, delete them manually.
    • C:\Windows\system32\Macromed\Flash\
    • %AppData%\Adobe\Flash Player\
    • %AppData%\Macromedia\Flash Player\
  6. Restart your computer.
  7. Run the installer for other browsers.
  8. Run the ActiveX installer if you downloaded it.
more options

Make sure that local storage is enabled and working.

You can paste this in the command line of the Web Console (Firefox/Tools > Web Developer):

localStorage["yt-player-volume"]
more options

Thanks Mr. Breadman, uninstalling and reinstalling Flash has fixed it. Cheers!