X
點擊此處開啟此網站的行動版。

技術支援討論區

why do the scroll bars quickly dissapear in firefox on OSX 10.9?

已張貼

I am running OSX 10.9 Maverick on a Macbook Pro . I observe this problem in Firefox 25.1 The scroll bars in any application window all dissapear after about a second. If you resize the window or select an item with subdirectories in a list, the scroll bar in the pane you are in reappears, but it does not dwell long enough to allow you to move a cursor over it. (What is the point of making it dissapear anyway?) Two finger scrolling does not work for some reason, using a function and direction key or just a direction key works to scroll only in some websites but not all of them. This little bit of cleverness, if intentional is both un-needed and dysfunctional.

I am running OSX 10.9 Maverick on a Macbook Pro . I observe this problem in Firefox 25.1 The scroll bars in any application window all dissapear after about a second. If you resize the window or select an item with subdirectories in a list, the scroll bar in the pane you are in reappears, but it does not dwell long enough to allow you to move a cursor over it. (What is the point of making it dissapear anyway?) Two finger scrolling does not work for some reason, using a function and direction key or just a direction key works to scroll only in some websites but not all of them. This little bit of cleverness, if intentional is both un-needed and dysfunctional.

被選擇的解決方法

On Mac the scroll bars can be hidden and only have them show when you scroll the page so you can see the current scroll position.
The idea is that a touch pad is used that doesn't require the scroll bars to be visible and thus have more screen estate for the browsing area.

You can make the scroll bars always visible:

從原來的回覆中察看解決方案 36

額外的系統細節

已安裝的外掛程式

  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Provides information about the default web browser
  • Shockwave Flash 11.9 r900
  • 5.1.10411.0
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • iPhoto6

應用程式

  • Firefox 25.0.1
  • 使用者代理:Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:25.0) Gecko/20100101 Firefox/25.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/25.0.1/Darwin/en-US/

擴充套件

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Greasemonkey 1.12 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription:
  • adapterDeviceID: 0x 46
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce GT 330M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

修改過的偏好設定

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1003520
  • browser.history_expire_days.mirror: 180
  • browser.history_expire_days_min: 1
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131112160018
  • browser.startup.homepage: https://www.lotuslive.com/en/
  • browser.startup.homepage_override.buildID: 20131112160018
  • browser.startup.homepage_override.mstone: 25.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 25.0.1
  • font.internaluseonly.changed: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1386530388
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1324254545
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.history: False
  • privacy.clearOnShutdown.sessions: False
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.disable_button.openDeviceManager: False
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1386283078

其他

  • User JS: 否
  • 輔助功能: 否
cor-el
  • Top 10 Contributor
  • Moderator
17481 個解決方法 157978 個答案

選擇的解決方法

On Mac the scroll bars can be hidden and only have them show when you scroll the page so you can see the current scroll position.
The idea is that a touch pad is used that doesn't require the scroll bars to be visible and thus have more screen estate for the browsing area.

You can make the scroll bars always visible:

On Mac the scroll bars can be hidden and only have them show when you scroll the page so you can see the current scroll position.<br /> The idea is that a touch pad is used that doesn't require the scroll bars to be visible and thus have more screen estate for the browsing area. You can make the scroll bars always visible: *System Preferences > General > Show Scroll Bar > Choose "Always" *http://heresthethingblog.com/2013/02/25/mac-tip-missing-scroll-bars/ *http://macs.about.com/od/usingyourmac/qt/Os-X-Lion-Scroll-Bars.htm

有幫助的回覆

This answer solves the problem for me.

However, it does not address the fact that under Apples OSX 10.9 Maverick, touchpad scrolling currently does not always work, even when you have a touchpad device, and the very latest OS and version of Firefox. The default scroll bar setting for OSX 10.9 ought to be hardware sensitive and set to always on as the default, Other settings might work on an iPad or iPhone device and their competitor clones, I cannot confirm that, but we know that it does not work for all web applications on all touchpad devices. Not even the ones Apple make themselves.

This answer solves the problem for me. However, it does not address the fact that under Apples OSX 10.9 Maverick, touchpad scrolling currently does not always work, even when you have a touchpad device, and the very latest OS and version of Firefox. The default scroll bar setting for OSX 10.9 ought to be hardware sensitive and set to always on as the default, Other settings might work on an iPad or iPhone device and their competitor clones, I cannot confirm that, but we know that it does not work for all web applications on all touchpad devices. Not even the ones Apple make themselves.