搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

When saving a file I can't see a list of folders when I hit the "Browse Folders" button.

  • 16 回覆
  • 40 有這個問題
  • 2673 次檢視
  • 最近回覆由 jscher2000

more options

I am using the latest version of Firefox on W7 64 bit.

I tried reinstalling Firefox and it resolved the issue then shortly afterwards the problem popped up again. Reinstalling a 2nd time didn't fix the problem. Resetting Firefox didn't fix it either.

所有回覆 (16)

more options

When you click Browse Folders to expand the dialog, what do you see? Empty space? I'm attaching my display on Windows 7.

more options

All I see is empty space. I am positive there are folders in that location but I can't see them. I am attaching a screen capture of it.

more options

That dialog is definitely broken. I'm struggling to think of what could have been fixed by one reinstall but not by another one.

Occasionally dialog problems can be caused by corruption in the file that stores your toolbar customizations. You can rename the file and return to default toolbar settings to see whether that makes any difference.

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Leaving that window open, switch back to Firefox and Exit (File menu > Exit or orange Firefox button > Exit)

Pause while Firefox finishes its cleanup, then rename localstore.rdf to something like localstore.old

Restart Firefox. Any improvement?

more options

I followed your instructions and nothing has changed.

more options

Try to delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

You can also check for problems with preferences.

Rename or delete the prefs.js file and possible numbered prefs-##.js and user.js files to reset all prefs to the default value.

由 cor-el 於 修改

more options

Nothing has worked. I tried deleting the profile after uninstalling Firefox and then re-install it. The problem is still there.

more options

Are any special options set on the Compatibility tab of your Firefox program icon? That would be the icon you use to start Firefox.

right-click > Properties > Compatibility tab

Typically all of the checkboxes are blank.

more options

None of the boxes are checked.

Don't know if this is related to my problem but I can't see the folders when I do a "Save As..." in Oxygen Office Pro (enhanced version of Open Office) Writer.

由 tishbite 於 修改

more options

Try saving a file in Safe Mode


Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Hi tishbite, I think it may well be relevant if multiple applications have the same issue.

Is there anything special about the way you run these applications, such as launching them in a security sandbox or virtualization program?

Running out of ideas...

more options

The problem still exists in firefox safe mode.

I just launch them in the normal way without "security sandbox or virtualization programs."

Could this have anything to do with settings in Windows 7?

more options

this happens only firefox?

more options

It could be a Windows-level issue. Most third party applications use a standard interface provided by Windows (FileDialog API), so that could explain the consistency between applications.

In searching around for pages on how to fix a messed up file dialog, I saw two that users reported working for them. I recommend making a good, thorough backup before trying them:

(1) System File Checker - Use the System File Checker tool to repair missing or corrupted system files

(2) Repair Windows using install disk

more options

Try to delete the MRU (Most Recently Used) ComDlg32 registry keys with the registry editor (regedit.exe).

Navigate to: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ComDlg32
Delete the subkeys (LastVisitedPidlMRU and OpenSavePidlMRU)

Be cautious with editing the registry as there is no Undo possible: all changes are applied immediately. You can export registry keys before making changes.

more options

I had the exact same problem, and it manifests not only in Firefox but in any browser and in Office 2007 applications

Reason: The save in window got minimized by accident, unfortunately this applies to all save as screens (except for Office 2003 apps), this happened because I normally I let my 2 yr old and 4 yr old play with the computer, unsupervised :)

Solution: Please resize the window to maximum by hovering your mouse right at the top line above the File Name box (see attached screenshots)

more options

Hi eeleem, I didn't realize that area was resizable. What was Microsoft thinking? Thank you for posting that tip.