X
點擊此處開啟此網站的行動版。

技術支援討論區

Unable to view photos on Instagram properly

已張貼

When viewing a user's photos on instagram.com/user, I click on one photo and it opens in a new tab (as opposed to popping up in the same tab in middle of the screen). Then, when I 'X' out the new tab and return to the old one with the rest of the photos, I cannot click on anymore. I have to refresh the page each time I want to view a new photo. This does NOT occur when I view the instagram.com/user page using Internet Explorer. Shockwave Flash and all other plug-ins are up to date. I just noticed this issue with Firefox's newest upgrade.

When viewing a user's photos on instagram.com/user, I click on one photo and it opens in a new tab (as opposed to popping up in the same tab in middle of the screen). Then, when I 'X' out the new tab and return to the old one with the rest of the photos, I cannot click on anymore. I have to refresh the page each time I want to view a new photo. This does NOT occur when I view the instagram.com/user page using Internet Explorer. Shockwave Flash and all other plug-ins are up to date. I just noticed this issue with Firefox's newest upgrade.

被選擇的解決方法

Firefox 23 "unprefixed" the requestAnimationFrame() function. This means that parts of the script that previously didn't run in Firefox now run in Firefox, and the developers might not have tested that.

Now... is there a workaround? Hmmm...

從原來的回覆中察看解決方案 11

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.8 r800
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • iTunes Detector Plug-in
  • WildTangent Games App V2 Presence Detector
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

更多資訊

cor-el
  • Top 10 Contributor
  • Moderator
17530 個解決方法 158495 個答案

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
Clear the cache and the cookies from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

提出問題者

I cleared the cache and removed cookies. This did not fix the problem.

The problem also occurs while in Safe Mode, so it is not caused by any extensions. My theme is set to default.

Any other suggestions?

I cleared the cache and removed cookies. This did not fix the problem. The problem also occurs while in Safe Mode, so it is not caused by any extensions. My theme is set to default. Any other suggestions?
kobe 441 個解決方法 5048 個答案

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Hello, Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back to us! Thank you.

提出問題者

I unchecked the "Use hardware acceleration when available" checkbox, as it was, in fact, checked. I then restarted Firefox, and the problem still occurs.

I have already visited the first link and determined that the problem occurs while in Safe Mode, so it is not caused by extensions. My theme is set to default.

I visited the second link, and while I have Windows 8 and the instructions were suited for Windows 7 (there is no "Windows Update") I opened the "Action Center" and it states all drivers are up-to-date and there is no need for any other sort of update.

My problem still occurs. Any other suggestions?

I unchecked the "Use hardware acceleration when available" checkbox, as it was, in fact, checked. I then restarted Firefox, and the problem still occurs. I have already visited the first link and determined that the problem occurs while in Safe Mode, so it is not caused by extensions. My theme is set to default. I visited the second link, and while I have Windows 8 and the instructions were suited for Windows 7 (there is no "Windows Update") I opened the "Action Center" and it states all drivers are up-to-date and there is no need for any other sort of update. My problem still occurs. Any other suggestions?
kobe 441 個解決方法 5048 個答案
test in a new profile? * [[Use the Profile Manager to create and remove Firefox profiles]]

由 kobe 於 修改

提出問題者

Created a new profile, problem persists.

I just purchased this new laptop with Windows 8 approximately 60 days ago, so there isn't much on it really. I recently upgraded Firefox and I have not noticed any other issues aside from this one.

Created a new profile, problem persists. I just purchased this new laptop with Windows 8 approximately 60 days ago, so there isn't much on it really. I recently upgraded Firefox and I have not noticed any other issues aside from this one.
kobe 441 個解決方法 5048 個答案
boot into windows safe mode, does it work now? * http://windows.microsoft.com/en-us/windows7/start-your-computer-in-safe-mode

提出問題者

No, problem persists.

The problem DOES NOT occur in Internet Explorer, as I previously mentioned. This problem only occurs when using Firefox, and is caused by something unique to the browser.

No, problem persists. The problem DOES NOT occur in Internet Explorer, as I previously mentioned. This problem only occurs when using Firefox, and is caused by something unique to the browser.
kobe 441 個解決方法 5048 個答案

If you feel strongly about that, write a bug at bugzilla.

If you feel strongly about that, write a bug at bugzilla. * bugzilla.mozilla.org
cor-el
  • Top 10 Contributor
  • Moderator
17530 個解決方法 158495 個答案

Can you post a link to a publicly accessible page that doesn't require authentication (signing on)?

Can you post a link to a publicly accessible page that doesn't require authentication (signing on)?

提出問題者

instagram.com/instagram

On Instagram's user page, linked above, again when I click on a photo it opens in a new tab. When I close that tab, I can no longer click on any Instagram photos.. I must refresh the page to click another (which will also open in a completely new tab).

After I have clicked on one photo and try to click on another, I even try "Ctrl +click" and it still will not be viewed. I must refresh the page.

[http://instagram.com/instagram instagram.com/instagram] On Instagram's user page, linked above, again when I click on a photo it opens in a new tab. When I close that tab, I can no longer click on any Instagram photos.. I must refresh the page to click another (which will also open in a completely new tab). After I have clicked on one photo and try to click on another, I even try "Ctrl +click" and it still will not be viewed. I must refresh the page.

由 circean 於 修改

jscher2000
  • Top 10 Contributor
8761 個解決方法 71690 個答案

Clicking an image on the page causes a script error (tested in Firefox 23 on Windows 7). This is breaking the page's normal behavior:

Timestamp: 8/11/2013 5:03:35 PM
Error: NS_ERROR_XPC_NOT_ENOUGH_ARGS: Not enough arguments [nsIDOMWindow.requestAnimationFrame]
Source File: http://d36xtkk24g8jdx.cloudfront.net/bluebar/d8a6bc2/cache/modules/lib/fullpage/transitions.js
Line: 11

Now... is there is a workaround? Hmmm...

Clicking an image on the page causes a script error (tested in Firefox 23 on Windows 7). This is breaking the page's normal behavior: Timestamp: 8/11/2013 5:03:35 PM Error: NS_ERROR_XPC_NOT_ENOUGH_ARGS: Not enough arguments [nsIDOMWindow.requestAnimationFrame] Source File: http://d36xtkk24g8jdx.cloudfront.net/bluebar/d8a6bc2/cache/modules/lib/fullpage/transitions.js Line: 11 Now... is there is a workaround? Hmmm...
cor-el
  • Top 10 Contributor
  • Moderator
17530 個解決方法 158495 個答案
See also: *https://developer.mozilla.org/en-US/docs/Web/API/window.requestAnimationFrame
jscher2000
  • Top 10 Contributor
8761 個解決方法 71690 個答案

選擇的解決方法

Firefox 23 "unprefixed" the requestAnimationFrame() function. This means that parts of the script that previously didn't run in Firefox now run in Firefox, and the developers might not have tested that.

Now... is there a workaround? Hmmm...

Firefox 23 "unprefixed" the [https://developer.mozilla.org/en-US/docs/Web/API/window.requestAnimationFrame requestAnimationFrame() function]. This means that parts of the script that previously didn't run in Firefox now run in Firefox, and the developers might not have tested that. Now... is there a workaround? Hmmm...

提出問題者

Would you suggest I report this to bugzilla? Or to Instagram?

Would you suggest I report this to bugzilla? Or to Instagram?
jscher2000
  • Top 10 Contributor
8761 個解決方法 71690 個答案

I'd report it to Instagram first. The site probably updates frequently, whereas a fix to Firefox is likely to take at minimum of 6 weeks.

(Also, I can't figure out a way to "hide" the change from the site.)

I'd report it to Instagram first. The site probably updates frequently, whereas a fix to Firefox is likely to take at minimum of 6 weeks. (Also, I can't figure out a way to "hide" the change from the site.)

提出問題者

Thanks very much for all your help! Will do!

Thanks very much for all your help! Will do!
cor-el
  • Top 10 Contributor
  • Moderator
17530 個解決方法 158495 個答案

There is already a bug about this.

  • Bug 871318 - Image slideshow on Instagram profiles is broken with NS_ERROR_XPC_NOT_ENOUGH_ARGS: Not enough arguments [nsIDOMWindow.requestAnimationFrame]
There is already a bug about this. *Bug 871318 - Image slideshow on Instagram profiles is broken with NS_ERROR_XPC_NOT_ENOUGH_ARGS: Not enough arguments [nsIDOMWindow.requestAnimationFrame]

提出問題者

Good to know. I have reported it to Instagram as well.

Good to know. I have reported it to Instagram as well.
drisley77 0 個解決方法 5 個答案

I have the exact same issue as the original post. Instagram opens the first image in a new tab, then from that point on, you can't open any more images unless you refresh the page.

Also, I think related, Apple's download page for iTunes, which uses a popup/javascript, won't work on this Firefox 23.01 either. I've tried safe mode, new profile, everything. You click on DOWNLOAD and are forwarded to the THANK YOU page, but no download for iTunes. http://www.apple.com/ca/itunes/download/

I can only use the download page with Internet Explorer.

I have the exact same issue as the original post. Instagram opens the first image in a new tab, then from that point on, you can't open any more images unless you refresh the page. Also, I think related, Apple's download page for iTunes, which uses a popup/javascript, won't work on this Firefox 23.01 either. I've tried safe mode, new profile, everything. You click on DOWNLOAD and are forwarded to the THANK YOU page, but no download for iTunes. http://www.apple.com/ca/itunes/download/ I can only use the download page with Internet Explorer.