X
點擊此處開啟此網站的行動版。

技術支援討論區

Since upgrade, Firefox 20 and Adobe flash player 11 eat up all my CPU when playing streaming video

已張貼

Win7 64 bit Firefox20 Adobe flashplayer 11 plugin

when streaming, Task Manager notes:

Flashplayerplugin__11__7__700__169.exe *32 -- uses 50% of CPU and higher

plugin - container.exe*32 -- uses 40% of CPU and higher

Using 100% of CPU results in choppy video. I do not believe this heavy CPU use was not the case before I upgraded from Firefox13 and Adobe flashplayer 11. I tried downgrading but this did not seem to make a difference.

Thanks for any help.

Win7 64 bit Firefox20 Adobe flashplayer 11 plugin when streaming, Task Manager notes: Flashplayerplugin__11__7__700__169.exe *32 -- uses 50% of CPU and higher plugin - container.exe*32 -- uses 40% of CPU and higher Using 100% of CPU results in choppy video. I do not believe this heavy CPU use was not the case before I upgraded from Firefox13 and Adobe flashplayer 11. I tried downgrading but this did not seem to make a difference. Thanks for any help.

由 Noah_SUMO 於 修改

被選擇的解決方法

If you have submitted crash reports then please post the IDs of one or more recent crash reports that have a "bp-" prefix:

  • bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

You can find the IDs of the submitted crash reports on the about:crashes page.

  • You can open the about:crashes page via the location bar, like you open a website, or open the crash reports page via "Help > Troubleshooting Information".

See:

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.7 r700
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Amazon MP3 Downloader Plugin 1.0.17
  • VLC media player Web Plugin 2.0.2
  • 4.1.10329.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.0"
  • Pando Web Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • DivX Web Player version 2.1.0.900
  • DivX OVS Helper Plug-in
  • NPWLPG

應用程式

  • Firefox 20.0.1
  • 使用者代理:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • 技術支援網址:http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

擴充套件

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.7 (adblockpopups@jessehakanen.net)
  • ColorfulTabs 17.8 ({0545b830-f0aa-4d7e-8820-50a4629a56fe})
  • Flashblock 1.5.15.1 ({3d7eb24f-2740-49df-8937-200b1cc08f8a})
  • Forecastfox 2.2.2 ({0538E3E3-7E9B-4d49-8831-A227C80A7AD3})
  • MMaGNiiPic 1.5 (awryaio@ozskn-.com)
  • New Tabs at the End 1.0 (new-tabs-at-end@forerunnerdesigns.com)
  • Remove It Permanently 1.0.6.10 ({1dbc4a33-ea62-4330-966c-7bdad3455322})
  • Toolbar Buttons 1.0 ({03B08592-E5B4-45ff-A0BE-C1D975458688})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • X-notifier 3.1.3 ({37fa1426-b82d-11db-8314-0800200c9a66})
  • DivX HiQ 2.1.0.900 ({6904342A-8307-11DF-A508-4AE2DFD72085}) (Inactive)
  • DivX Plus Web Player HTML5 <video> 2.1.0.900 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: ATI Mobility Radeon HD 4225
  • adapterDescription2:
  • adapterDeviceID: 0x9712
  • adapterDeviceID2:
  • adapterDrivers: atiu9p64 atiuxp64 atiu9pag atiuxpag atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 336
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 5-27-2010
  • driverDate2:
  • driverVersion: 8.741.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Mobility Radeon HD 4225 )
  • windowLayerManagerType: Direct3D 10

修改過的偏好設定

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 778240
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.history_expire_days.mirror: 180
  • browser.places.smartBookmarksVersion: 4
  • browser.search.update: False
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: http://www.google.com/
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • font.size.variable.x-western: 18
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://searchab.com/?aff=7&uid=b7c31803-0a55-11e2-8580-206a8a135902&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1365270934
  • places.history.expiration.transient_current_max_pages: 100616
  • places.last_vacuum: 1334117397
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.csp.enable: False
  • security.enable_ssl2: True
  • security.OCSP.disable_button.managecrl: False
  • security.warn_viewing_mixed: False

其他

  • User JS: 是
  • 輔助功能: 否
philipp
  • Top 25 Contributor
  • Moderator
5315 個解決方法 23463 個答案

hello, maybe it's an issue with the protected mode in the flash plugin - you could try if downgrading to flash 10.3 (which is still supported) or disabling protected mode makes a difference.

hello, maybe it's an issue with the protected mode in the flash plugin - you could try if [https://support.mozilla.org/en-US/kb/flash-113-crashes#w_solution-2-downgrade-to-flash-10-3 downgrading to flash 10.3] (which is still supported) or [http://forums.adobe.com/thread/1018071#TemporaryWorkaround disabling protected mode] makes a difference.

提出問題者

Tried both options -- downgrading to flash 10.3, and disabling protected mode -- streaming still eat all the CPU.

Tried both options -- downgrading to flash 10.3, and disabling protected mode -- streaming still eat all the CPU.
cor-el
  • Top 10 Contributor
  • Moderator
17525 個解決方法 158458 個答案

Try to disable hardware acceleration in Firefox.


Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://hacks.mozilla.org/2010/09/hardware-acceleration/ ----- Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.
philipp
  • Top 25 Contributor
  • Moderator
5315 個解決方法 23463 個答案

can you try to replicate this behaviour when you launch firefox in safe mode once?

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

please also make sure that your security software isn't blocking/sandboxing the flash-process and plugin-container.exe in any way. in case you cannot resolve the issue this way, it would probably be best to contact adobe's support too & file a bug report at bugbase.adobe.com. they will have a better understanding of the internals of flash & therefore may know what else might be at the root of the problem you're seeing.

can you try to replicate this behaviour when you launch firefox in safe mode once? [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] please also make sure that your security software isn't blocking/sandboxing the flash-process and plugin-container.exe in any way. in case you cannot resolve the issue this way, it would probably be best to contact adobe's support too & file a bug report at bugbase.adobe.com. they will have a better understanding of the internals of flash & therefore may know what else might be at the root of the problem you're seeing.

提出問題者

Booted in Windows safe mode with Networking, same problem. Booted in Firefox safe mode, same problem. Disabled Firefox hardware acceleration, same problem.

I am streaming, or trying to, different shows from HGTV. No matter which one I pick, the CPU pegs out at 100%, none of the above suggestions have fixed this.

Thanks for trying.

Booted in Windows safe mode with Networking, same problem. Booted in Firefox safe mode, same problem. Disabled Firefox hardware acceleration, same problem. I am streaming, or trying to, different shows from HGTV. No matter which one I pick, the CPU pegs out at 100%, none of the above suggestions have fixed this. Thanks for trying.
Red_Rum 0 個解決方法 4 個答案

I have the same problem - choppy video and sound on all streaming/flash videos - 100% cpu due to plugin container. These used to play fine on earlier versions of ff and are playing fine on Chrome and IE. I have tried all the above solutions and more. Nothing works. I really don't want to give up my Firefox browser please can someone help?

I have the same problem - choppy video and sound on all streaming/flash videos - 100% cpu due to plugin container. These used to play fine on earlier versions of ff and are playing fine on Chrome and IE. I have tried all the above solutions and more. Nothing works. I really don't want to give up my Firefox browser please can someone help?

由 Red_Rum 於 修改

Blacksharpie 0 個解決方法 1 個答案

This is happening to me on Win7 32, Firefox 21, Flash videos on all sites are choppy, and CPU usage is around 98%.

I was able to play 1080p on YouTube almost perfectly until sometime in the last month. Now even 320p won't play without problems. No issues in IE or Chrome.

This is happening to me on Win7 32, Firefox 21, Flash videos on all sites are choppy, and CPU usage is around 98%. I was able to play 1080p on YouTube almost perfectly until sometime in the last month. Now even 320p won't play without problems. No issues in IE or Chrome.

由 Blacksharpie 於 修改

menivek 0 個解決方法 3 個答案

Hi all , I have had similar problems with Firefox21 AND latest Flash upgrade 11.7.700.202 . I first noticed problems with video streaming on sites such as Truefire and YouTube ie choppy and intermittent video and sound out of sync. I tried various things suggested by this and other forums but to no avail. I have now managed to get a better streaming performance by downloading and running the flash uninstall utility from Adobe site thus removing Flash altogether then looking at the archive for Flash again on the Adobe site I chose to download the latest dated release of version Shockwave Flash 10.3.183.86 which has to be unzipped. After installing version 10 everything works much better so I'm convinced it's an issue with Flash itself. The easiest way to get to the flash archive is after doing a web search for 'Flash' is to select 'Adobe-Install Adobe Flash Player' this will come up with the install screen and it will identify your version of windows and browser , then ignoring this information choose 'Do you have a different operating system or browser ?' on the next screen ignore the dropdowns and select 'If your operating system/browser combination is not displayed click here for older versions of Adobe flash player' then scroll down to the archived versions ...I chose (Released 5/14/2013) Flash Player 10.3.183.86 (61.21 MB) , downloaded , unzipped and ran the installer. Since doing this my video streaming issues have almost all but gone. I think the limitations of my hardware are now an issue as my motherboard only supports 2GB of RAM and I'm running windows xp. For now I'm staying with version 10 of Flash until the next release and if that doesn't work with Firefox I will going through this process again. Hope this helps someone.

Hi all , I have had similar problems with Firefox21 AND latest Flash upgrade 11.7.700.202 . I first noticed problems with video streaming on sites such as Truefire and YouTube ie choppy and intermittent video and sound out of sync. I tried various things suggested by this and other forums but to no avail. I have now managed to get a better streaming performance by downloading and running the flash uninstall utility from Adobe site thus removing Flash altogether then looking at the archive for Flash again on the Adobe site I chose to download the latest dated release of version Shockwave Flash 10.3.183.86 which has to be unzipped. After installing version 10 everything works much better so I'm convinced it's an issue with Flash itself. The easiest way to get to the flash archive is after doing a web search for 'Flash' is to select 'Adobe-Install Adobe Flash Player' this will come up with the install screen and it will identify your version of windows and browser , then ignoring this information choose 'Do you have a different operating system or browser ?' on the next screen ignore the dropdowns and select 'If your operating system/browser combination is not displayed click here for older versions of Adobe flash player' then scroll down to the archived versions ...I chose (Released 5/14/2013) Flash Player 10.3.183.86 (61.21 MB) , downloaded , unzipped and ran the installer. Since doing this my video streaming issues have almost all but gone. I think the limitations of my hardware are now an issue as my motherboard only supports 2GB of RAM and I'm running windows xp. For now I'm staying with version 10 of Flash until the next release and if that doesn't work with Firefox I will going through this process again. Hope this helps someone.

由 menivek 於 修改

philipp
  • Top 25 Contributor
  • Moderator
5315 個解決方法 23463 個答案

there's also a directly download link for the latest version of flash 10 at https://www.adobe.com/products/flashplayer/distribution3.html

there's also a directly download link for the latest version of flash 10 at https://www.adobe.com/products/flashplayer/distribution3.html
Red_Rum 0 個解決方法 4 個答案

Just upgraded to a more powerful laptop and all flash vids working fine now so in my case firefox was just not working properly with my slower computer although IE and chrome did - weird! My ram was 1.5 gb and is now 2gb (windows 8) if that helps anyone.

Just upgraded to a more powerful laptop and all flash vids working fine now so in my case firefox was just not working properly with my slower computer although IE and chrome did - weird! My ram was 1.5 gb and is now 2gb (windows 8) if that helps anyone.

由 Red_Rum 於 修改

PilotPirx 1 個解決方法 10 個答案

Win 7 Ultimate (64 bit), Firefox 21, Flash Player 11.7.

1) Eating CPU and Memory (in a form of peaks). 2) On some sites the Flash internal objects are shown as grey bars 3) On some sites the usage of flash players is awful: only moving the mouse around the movie clip and its controls (volume, full screen etc.) makes the whole thing (player object, FireFox, computer etc.) stuck. 4) No problems on the YouTube page

- Problems started to appear with FireFox 20 -> Flash Player 11.7. The problems persisted with FireFox 21. - No problems with IE / Chrome - Checked the Adobe Flash Player home for solution - no relevant solution was found. Got a lot of "advices" to downgrade the player to 10.3. - The current versions of FireFox do NOT allow to use Adobe Player 10.3 - they find it "non-secure" and disable it automatically.

Win 7 Ultimate (64 bit), Firefox 21, Flash Player 11.7. 1) Eating CPU and Memory (in a form of peaks). 2) On some sites the Flash internal objects are shown as grey bars 3) On some sites the usage of flash players is awful: only moving the mouse around the movie clip and its controls (volume, full screen etc.) makes the whole thing (player object, FireFox, computer etc.) stuck. 4) No problems on the YouTube page - Problems started to appear with FireFox 20 -> Flash Player 11.7. The problems persisted with FireFox 21. - No problems with IE / Chrome - Checked the Adobe Flash Player home for solution - no relevant solution was found. Got a lot of "advices" to downgrade the player to 10.3. - The current versions of FireFox do NOT allow to use Adobe Player 10.3 - they find it "non-secure" and disable it automatically.
menivek 0 個解決方法 3 個答案

Well I am using Flash 10.3 with Firefox 21 without an issue , when you download from the Flash archive you have to use last release date of 10.3 ie the date is the same or close to to the release date for version 11.7 as although it doesn't share the additional functionality and features of 11.7 it does have the latest security features I believe.

Well I am using Flash 10.3 with Firefox 21 without an issue , when you download from the Flash archive you have to use last release date of 10.3 ie the date is the same or close to to the release date for version 11.7 as although it doesn't share the additional functionality and features of 11.7 it does have the latest security features I believe.
cor-el
  • Top 10 Contributor
  • Moderator
17525 個解決方法 158458 個答案

You can find the latest Flash player 10.3 version for Firefox on this page if you need it:

You can find the latest Flash player 10.3 version for Firefox on this page if you need it: *http://www.adobe.com/special/products/flashplayer/fp_distribution3.html
delilah 0 個解決方法 12 個答案

I have this problem too. While playing simple flash games on Pogo, my CPU starts screaming... faster and faster until my PC sounds like it is ready to blow up. I get messages that my dual CPUs are nearly maxed out for a simple game. I'm not talking about complicated video games; I'm talking about Pogo Majong Safari, or Bejeweled Twist, etc.

I never had this problem until a few months ago. Not sure which update to what initiated the problem. I stay current on all my plug-ins as well as the latest versions of FF. I don't know enough to go in and start making changes to stuff in safe mode, etc.

IMO this is a bug (FF or Flash?) and users shouldn't have to go changing stuff to maneuver around it. It gets to the point, after just a few minutes of playing a game, I have to exit for fear my PC will be damaged. I have a new ASUS desktop with all the bells and whistles, so it's not because my PC is obsolete.

I have this problem too. While playing simple flash games on Pogo, my CPU starts screaming... faster and faster until my PC sounds like it is ready to blow up. I get messages that my dual CPUs are nearly maxed out for a simple game. I'm not talking about complicated video games; I'm talking about Pogo Majong Safari, or Bejeweled Twist, etc. I never had this problem until a few months ago. Not sure which update to what initiated the problem. I stay current on all my plug-ins as well as the latest versions of FF. I don't know enough to go in and start making changes to stuff in safe mode, etc. IMO this is a bug (FF or Flash?) and users shouldn't have to go changing stuff to maneuver around it. It gets to the point, after just a few minutes of playing a game, I have to exit for fear my PC will be damaged. I have a new ASUS desktop with all the bells and whistles, so it's not because my PC is obsolete.

由 delilah 於 修改

bassboost 0 個解決方法 1 個答案

有幫助的回覆

hello, i had this problem too. i couldnt play youtube videos in 720p or 1080p quality because video was choppy/laging and FlashPlayerPlugin_11_7_700_224.exe was hitting my cpu too hard... i tried chrome/explorer and everything was ok. i tried to reinstall flash but i had no luck... so i tried Ccleaner (im also using CCEnhancer). i checked almost everything under Applications - Firefox (except firefox urlclassifier3, saved form info, saved passwords) and in Applications - Multimedia i checked adobe flash player, adobe flash player more, adobe flash player settings. and that fixed this problem for me :)

hello, i had this problem too. i couldnt play youtube videos in 720p or 1080p quality because video was choppy/laging and FlashPlayerPlugin_11_7_700_224.exe was hitting my cpu too hard... i tried chrome/explorer and everything was ok. i tried to reinstall flash but i had no luck... so i tried Ccleaner (im also using CCEnhancer). i checked almost everything under Applications - Firefox (except firefox urlclassifier3, saved form info, saved passwords) and in Applications - Multimedia i checked adobe flash player, adobe flash player more, adobe flash player settings. and that fixed this problem for me :)
delilah 0 個解決方法 12 個答案

bassboost

thanks for the suggestion, but i also use ccleaner and have everything including saved passwords and form info (and registry junk) cleaned out several times a day (and nearly all applications checked). i haven't noticed any problems with viewing video on youtube. i don't go there very often, but when i do, no problems.

it just doesn't seem right having problems with simple games that have almost no video at all.

bassboost thanks for the suggestion, but i also use ccleaner and have everything including saved passwords and form info (and registry junk) cleaned out several times a day (and nearly all applications checked). i haven't noticed any problems with viewing video on youtube. i don't go there very often, but when i do, no problems. it just doesn't seem right having problems with simple games that have almost no video at all.

由 delilah 於 修改

menivek 0 個解決方法 3 個答案

Hi again. I have also noticed high CPU usage levels and keep getting performance warnings by Norton Internet Security. I recently had Java ask my permission to update as it often does but this time I thought I'd not allow Java Quick Starter to run automatically as it always seems to do do I ran services.msc from the run command , located Java Quick Starter , then both stopped it AND disabled it so that it won't run again on next boot up. Don't know if I'm imagining it but my CPU usage levels seems to have fallen back to more usual levels and I haven't had the constant CPU performance warnings from Norton's so MAY be related to some of the problems people have been experiencing on this forum , could be another 'red herring' but may be worth a try as things can easily be reversed if it doesn't help. My understanding of Java Quick Startes is that it's role in life is to do prefetching on files from the hard drive in order to speed up Java applications and applets but most websites doing video streaming don't actually use Java much as it's mainly done by other means such as flash etc. If Java is still needed for anything it will still work fine with JQS disabled. Sorry if I'm technically incorrect as I'm not an IT guru just going from my own observations when tinkering around trying to resolve this issue. Good Luck.

Hi again. I have also noticed high CPU usage levels and keep getting performance warnings by Norton Internet Security. I recently had Java ask my permission to update as it often does but this time I thought I'd not allow Java Quick Starter to run automatically as it always seems to do do I ran services.msc from the run command , located Java Quick Starter , then both stopped it AND disabled it so that it won't run again on next boot up. Don't know if I'm imagining it but my CPU usage levels seems to have fallen back to more usual levels and I haven't had the constant CPU performance warnings from Norton's so MAY be related to some of the problems people have been experiencing on this forum , could be another 'red herring' but may be worth a try as things can easily be reversed if it doesn't help. My understanding of Java Quick Startes is that it's role in life is to do prefetching on files from the hard drive in order to speed up Java applications and applets but most websites doing video streaming don't actually use Java much as it's mainly done by other means such as flash etc. If Java is still needed for anything it will still work fine with JQS disabled. Sorry if I'm technically incorrect as I'm not an IT guru just going from my own observations when tinkering around trying to resolve this issue. Good Luck.
kobe 441 個解決方法 5048 個答案

http://portableapps.com/apps/internet/firefox_portable Try the Portable Firefox and see if it works

http://portableapps.com/apps/internet/firefox_portable Try the Portable Firefox and see if it works
elainemacko 0 個解決方法 35 個答案

There is no Adobe 10.3 on Firefox!

There is no Adobe 10.3 on Firefox!
Rich Pasco 1 個解決方法 42 個答案

I'm running Firefox 23.0.1 under Window 7 Pro 64-bit on a Dell Studio 1558 and have this problem: After viewing a Flash movie under Firefox, my system slows to a crawl, while CPU usage (per Task Manager) shows nearly 100% -- even after I quit Firefox. Only re-booting helps then.

I followed these instructions to disable Flash protected mode. Not only did this not fix my problem, it induced a new one: After viewing 5 to 10 minutes of flash movies, my system would suddenly power off with no warning I removed the line "ProtectedMode=0" which I had added to C:\Windows\SysWOW64\Macromed\Flash\mms.cfg and the sudden power-off problem no longer recurred. I

I'm running Firefox 23.0.1 under Window 7 Pro 64-bit on a Dell Studio 1558 and have this problem: After viewing a Flash movie under Firefox, my system slows to a crawl, while CPU usage (per Task Manager) shows nearly 100% -- even after I quit Firefox. Only re-booting helps then. I followed [http://forums.adobe.com/thread/1018071 these instructions] to disable Flash protected mode. Not only did this not fix my problem, it induced a new one: After viewing 5 to 10 minutes of flash movies, my system would suddenly power off with no warning I removed the line "ProtectedMode=0" which I had added to C:\Windows\SysWOW64\Macromed\Flash\mms.cfg and the sudden power-off problem no longer recurred. I