搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How do I open a .nrl extension in firefox, currently it returns a string of text instead of opening the file with the default program.

  • 7 回覆
  • 3 有這個問題
  • 10453 次檢視
  • 最近回覆由 jacoffman

more options

When I click on a .nrl file extension (belongs to Autonomy I-Manage Software) it returns a string of code (what is in the shortcut link) instead of following the link and returning the document. Is there a way to tell Forefox connect to the document that the shortcut is linked to? The .nrl file extension belongs to a piece of software called FileSite (document management system).

被選擇的解決方法

Which content type is shown in "Tools > Page Info > General" if you open such a file?

  • Press F10 or tap the Alt key to bring up the "Menu Bar" temporarily if the Menu Bar is hidden.

As posted above, you only need to configure the server to send that file with a supported MIME type to make Firefox open a dialog instead of rendering the file.

從原來的回覆中察看解決方案 👍 0

所有回覆 (7)

more options

http://www.file-extensions.org/nrl-file-extension

Sorry, that isn't a file type which is normally associated with the internet or web browsers. Basically, Firefox won't render that file and doesn't know what program that that file type is associated with.

See if this helps you get that file type associated with the correct program that is installed on your PC.
http://support.mozilla.com/en-US/kb/Managing+file+types

more options

I have viewed that before, is there no way to edit the list of programs available to support file types? When I load the file into SharePoint and click on it to download, it does give me the option to download or open. When I go to the Applications tab I don't even see the file there to associate it with a program. There are applications installed on the computer that allow and know what to do with the file, it just doesn't seem like that information is being passed to Fire Fox.

more options

If Firefox opens a .nrl file in a tab then that usually means that the server sends the file as text/plain (or text/html) and you won't get an open with dialog in such a case.
You can check the type in the Tools > Page Info > General window.


more options

Adding download actions is the relevant section of that article for your situation.

Is the *.nrl file on a website or already saved to your PC?

If it is on a website, the server may not be sending the appropriate Mime-Type telling Firefox how that file is to be handled - "Content-Disposition".

Can you give us the URL of the webpage where you have this problem?
So we can see first hand what the issue is.

more options

Well this is actually on an intranet set for my firm, were currently moving from html intranet over to sharepoint and trying to get the kinks worked out with firefox on this nrl extension stuff during the process. So to answer the question, unforunately I cannot provide a link to it, but I can provide this picture of what it renders when clicked..


The file is actually hosted on the same server as where SharePoint is installed.

more options

選擇的解決方法

Which content type is shown in "Tools > Page Info > General" if you open such a file?

  • Press F10 or tap the Alt key to bring up the "Menu Bar" temporarily if the Menu Bar is hidden.

As posted above, you only need to configure the server to send that file with a supported MIME type to make Firefox open a dialog instead of rendering the file.

more options

The server had no indication how to send the .nrl extension. We were running the html site with APACHE 2.2 and for unknown types it sends as text/plain. I changed it in httpd.config and mime.config and the server is now sending the file with the request to open or save with the proper program. The SharePoint server I am working with however does not face this same issue. Somehow (without any configuration required) it knows to save the document in I.E. and Firefox knows to open or save the document. Changing settings in SharePoint from strict to permissive allowed both browsers to run the document. Thanks for the help guys, sure appreciate it!