搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Every time i type in a wrong url, it redirects me to searchfusion.com instead of google!

  • 7 回覆
  • 8 有這個問題
  • 3515 次檢視
  • 最近回覆由 rustblack

more options

Every time i type in a wrong url, it redirects me to searchfusion.com instead of google!

I've removed all search engine from 'manage search engines' and in about:config i've change the value of 'keyword.URL' to 'http://www.google.com/search?q='

It use to be that when i typed in a wrong url it would present google search results!

所有回覆 (7)

more options

Hi quadlegend,

It sounds like you've take the appropriate steps to fix the issue under normal circumstances. Your issue may be because you've been hit with some Malware.

Hopefully this helps!

more options

Thanks Matt.

I ran an in-depth scan with Eset Nod32, with SuperAntispyware Portable Scanner, and another with Malwarebytes Anti-Malware...no threats or bad objects detected.

So what do i do now?

more options

You may have an ISP that automatically redirects you to a search page if a DNS look up fails.
That takes the control from Firefox to do the normal keyword search like a Google I'm Lucky search.
In such cases you need to contact your ISP and ask for a DNS server to opt-out of that feature.

more options

Doubtful...it only started a few days back.

more options

Do a malware check with some malware scanning programs on the Windows computer.
You need to scan with all programs because each program detects different malware.
Make sure that you update each program to get the latest version of their databases before doing a scan.

See also:

more options

It's happening to me on Centos 6 so it's not a Win issue, also clamscan shows no malware.

more options

Well, it's not every time it only does that when the domain in question is redirected to searchfusion.com. For example type in kat.ph and it will work, but type in kast.com and it will redirect to searchfusion.com. There is no malware at work here....