搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

I have suddenly been getting overwhelmed with pop-ups, idiotic ads, when I use firefox. How do I block these?

  • 13 回覆
  • 3 有這個問題
  • 974 次檢視
  • 最近回覆由 Xircal

more options

This is especially annoying on Facebook, which has now become unusable for me

被選擇的解決方法

Install this add-on: https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/

They may possibly be originating from the Bing Bar you have installed. You can test that by clicking the Firefox button, go to Add-ons, then Extensions and disable it in there. If it doesn't make any difference, you can re-enable it again.

從原來的回覆中察看解決方案 👍 0

所有回覆 (13)

more options

選擇的解決方法

Install this add-on: https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/

They may possibly be originating from the Bing Bar you have installed. You can test that by clicking the Firefox button, go to Add-ons, then Extensions and disable it in there. If it doesn't make any difference, you can re-enable it again.

more options

The adblock plus seems to have worked - Thanks!

more options

You're welcome.

Incidentally, it's a good idea to subscribe to the Malware Domains list to filter that junk out too. You'll find it at the foot of this page: https://adblockplus.org/en/subscriptions Click the "Subscribe" link and you'll get a dialog box.

more options

Wait, I take that back, I'm still getting a large popup when I open Facebook, it's a big notice that I've won something from Firefox - seems pretty bogus

more options

Right click it and choose Adblock image.

more options

OK, great, will try that next time it happens - I have also added the Malware Domains thing. many thanks!

more options

There's another option too. Click the red Adblock Plus button you should have on your toolbar now and then click "Open blockable items". A console will open at the foot of the page and you'll get a number of entries. You can use that to block a few things that slip through the next. Usually, when you click an entry, the page will jump to the relevant item.

EDIT: check your Firefox settings re: blocking popups @ Block popups

由 Xircal 於 修改

more options

I'm still getting the big popups, on Firefox, and most do not have R click Adblock option

more options

Did you check your popup settings @ Block popups ?

more options

Yes, "Block Pop-up windows" is selected (under Contents); but I'm still getting them

more options

Try running Firefox in Diagnose Firefox issues using Troubleshoot Mode. This will actually disable ABP, but also all other add-ons without disabling the Firefox popup blocker.

If you don't get them anymore after that, then there's something you've installed, or something which was installed for you when you installed a 'free program' of some sort or another which is causing the problem.

Do the popups come from a specific site?

more options

I haven't installed any free programs except Adobe reader and Firefox. But the ads were popping up when I opened messages or sites, including Facebook, Adobe reader, etc. I did the Safe Mode thing, and now things seem to be back to where they were before all this; incl. facebook, which no longer has the ads nor the blank spaces for them. And I haven't seen any popups yet. I'll ask again if they show up, but maybe this did the trick! thanks -

more options

If you're in Safe Mode and the popups don't appear anymore, then restart in that mode again and checkmark "Disable All Add-ons" | "Make changes and restart". Then re-enable them one-by-one until the problem recurs. Then you know it was the previous one which is the culprit.