搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How can I get rid of the "Restore Previous Session" box that comes up when you start Firefox?

more options

How can I get rid of the "Restore Previous Session" box that comes up when you start Firefox?

被選擇的解決方法

about:home is the default homepage in Firefox 4 - look at the Location Bar where the web page addresses appear - it has the Google search container, along with a "snippet container", and below those items is the Restore Previous Session button. That is not the same homepage that previous versions of Firefox used (although it is similar in appearance), it is a "local page" that doesn't load from the internet.

Set this page as your homepage, which is what Firefox 3.6 and earlier versions had for the default homepage. It doesn't have that Restore Previous Session button /link.
http://www.google.com/firefox

從原來的回覆中察看解決方案 👍 1

所有回覆 (11)

more options

I thought the reply I got would be helpful, but it is not. The issue i have is that the "Restore Previous Session" box is still there when Firefox starts. i want this feature to be permanently disable for privacy reasons.

more options

Please read this thread to see if it helps:


http://support.mozilla.com/ta-LK/questions/821354

more options

Do the following to disable session restore completely.


  • In the location bar, type about:config and hit Enter.
  • In the filter at the top, copy/paste the following: browser.sessionstore.resume_from_crash
  • Double click it to change it from True to False.

Close Firefox, do some browsing to a few sites and then close and restart Firefox again to check that it works.

more options

Thanks for responding, but this does not fix the issue. My home page is Google. I made the change to about:config, rebooted and restarted Firefox and the "Resume Previous Session" box is still there.

more options

Thanks for responding, but this does not fix the issue. My home page is Google. I made the change to about:config, rebooted and restarted Firefox and the "Resume Previous Session" box is still there.

more options

選擇的解決方法

about:home is the default homepage in Firefox 4 - look at the Location Bar where the web page addresses appear - it has the Google search container, along with a "snippet container", and below those items is the Restore Previous Session button. That is not the same homepage that previous versions of Firefox used (although it is similar in appearance), it is a "local page" that doesn't load from the internet.

Set this page as your homepage, which is what Firefox 3.6 and earlier versions had for the default homepage. It doesn't have that Restore Previous Session button /link.
http://www.google.com/firefox

more options

Firefox 4 saves the previous session automatically, so there is no longer need for the dialog asking if you want to save the current session.
Use "File > Exit" or "Firefox > Exit" if you want to restore multiple windows.
You can use "Firefox > History > Restore Previous Session" to get the previous session at any time.
There is also a "Restore Previous Session" button on the default about:home Home page.


Firefox 4 uses a new build-in home page called about:home

That about:home page only shows some snippets and has a button to restore the previous session if applicable.

If you want a home page without the Restore Previous Session then set another page as the home page like www.google.com or www.google.com/firefox used in Firefox 3 versions.

more options

Hallelujah! This solves the issue. Thank you so much!

more options

this is how i did in ff6 hope it help even when late. first go to options; privacy.https://support.mozilla.com/media/uploads/images/2011-09-26-06-22-26-132640.jpg

check the "clear history" box and go to settings. https://support.mozilla.com/media/uploads/images/2011-09-26-06-22-36-387795.jpg

uncheck what you don't want firefox to clear and clik ok. https://support.mozilla.com/media/uploads/images/2011-09-26-06-22-44-4ddd51.jpg

check the "permanent privacy" box an clik ok. https://support.mozilla.com/media/uploads/images/2011-09-26-06-22-49-b2bd71.jpg firefox will work normally

由 poollyed 於 修改

more options

Thanks bunches for this advice!! Not only did it work, but it was also super quick to conduct the steps in order to permanently remove the "restore previous session" button. Also, it was tremendously simple to conduct those steps as well. The "print screen idea and posting the links per screen which was printed was an awesome idea because it helps to sometimes visually see exactly what window I should be in and which boxes should, or shouldn't be checked. Great tip and advice! Again, thanks! :o)