搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

I'm in a browswer session and pop-ups open a new FFox window rather than a tab. How can I cause a pop-up to open in a tab rather than opening a new FFox window?

  • 7 回覆
  • 13 有這個問題
  • 4 次檢視
  • 最近回覆由 whdale

more options

I'm running FFox 4 on Windows 7 fully up-to-date. I use a stock trading platform (called Trading Desk) that requires the use of limited pop-ups. With IE 8, the pop-ups appear as tabs, but with FFox they open a series of new windows and fill up the task bar!

I'm running FFox 4 on Windows 7 fully up-to-date. I use a stock trading platform (called Trading Desk) that requires the use of limited pop-ups. With IE 8, the pop-ups appear as tabs, but with FFox they open a series of new windows and fill up the task bar!

被選擇的解決方法

You can look at these prefs on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

從原來的回覆中察看解決方案 👍 4

所有回覆 (7)

more options

Using Tools -> Options | content - [x] Block popup window
may solve the problem

more options

Do you have this preference set?

Options > Tabs = Open new windows in a tab instead

more options

John99, The problem is not about blocking pop-ups. It's about having pop-ups appear on a TAB rather than opening a new FFox WINDOW. I tried it with and without the indicated "x" for pop-up blocking. And, I tried it with and without web-site exceptions specified. My conclusion at this point is that FFox doesn't handle this situation, but I wish I could be shown to be wrong. Walt

more options

Yes, the setting Options > Tabs = Open new windows in a tab instead ...was set on

more options

Yes, the setting Options > Tabs = Open new windows in a tab instead ...was set on

more options

選擇的解決方法

You can look at these prefs on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

more options

cor-el: thank you, thank you...the settings of (3) and (0) as suggested in the documentation and as you indicated have solved problem; all pop-ups now open in a new TAB rather than a new window. Thanks again... Walt