X
點擊此處開啟此網站的行動版。

技術支援討論區

how to save tabs when closing firefox 4

已張貼

I have just upgraded from Firefox 3.6.x to Firefox 4. I had assumed that the new version would use the same settings as the previous one but it doesn't

The previous one always asked if I wante tabs saving when I closed it but this version (4) does not.

Is there a way of making it ask?

I have just upgraded from Firefox 3.6.x to Firefox 4. I had assumed that the new version would use the same settings as the previous one but it doesn't The previous one always asked if I wante tabs saving when I closed it but this version (4) does not. Is there a way of making it ask?

額外的系統細節

這發生了

每當開啟 Firefox 的時候

問題發生於...

After upgrading to version 4

已安裝的外掛程式

  • Foxit Reader Plug-In For Firefox and Netscape
  • Windows Activation Technologies Plugin for Mozilla

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

更多資訊

Amal Mampitiya 0 個解決方法 1 個答案

有幫助的回覆

http://www.raymond.cc/blog/archives/2011/03/23/enable-save-tabs-on-exit-for-firefox-4/ there is way to do it
dankyhelpedyou 0 個解決方法 8 個答案

有幫助的回覆

One change in Firefox 4 is to by default stop Firefox displaying the warning message, but it can be turned back on by changing some preferences.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, 

you will be taken to a list of preferences

  3. Locate the preference browser.tabs.warnOnClose,
if its value is set to false, double-click on it to change its value 

to true

  4. Repeat this for these 2 preferences 

browser.warnOnQuit, browser.warnOnRestart

  5. Starting with beta 12 there will be an additional preference 

that needs to be set to true - browser.showQuitWarning

One change in Firefox 4 is to by default stop Firefox displaying the warning message, but it can be turned back on by changing some preferences. 1. Type about:config into the location bar and press enter 2. Accept the warning message that appears, you will be taken to a list of preferences 3. Locate the preference browser.tabs.warnOnClose, if its value is set to false, double-click on it to change its value to true 4. Repeat this for these 2 preferences browser.warnOnQuit, browser.warnOnRestart 5. Starting with beta 12 there will be an additional preference that needs to be set to true - browser.showQuitWarning

由 dankyhelpedyou 於 修改

提出問題者

Many thanks for your help. I have done that but I do not get a warning when I close Firefox. Also, have several other problems with version 4 so rather than footle about with it I am going to uninstall it and use something else.

It seems that every time there is an update or upgrade it never retains previous settings and I am thinking that it is just not worth all the hassle.

Thanks again for your help

Many thanks for your help. I have done that but I do not get a warning when I close Firefox. Also, have several other problems with version 4 so rather than footle about with it I am going to uninstall it and use something else. It seems that every time there is an update or upgrade it never retains previous settings and I am thinking that it is just not worth all the hassle. Thanks again for your help
blazing88 0 個解決方法 5 個答案

Chris, unfortunately could be addon compatibility. Had same problem and solution did not work, but when restarting in safe mode with no themes addons etc it does work, ie FF asks if I want to Save and Quit etc.

So, if you have time you might want to play around with your addons and themes -or go back to FF3 and wait a month for people to upgrade the addons.

Chris, unfortunately could be addon compatibility. Had same problem and solution did not work, but when restarting in safe mode with no themes addons etc it does work, ie FF asks if I want to Save and Quit etc. So, if you have time you might want to play around with your addons and themes -or go back to FF3 and wait a month for people to upgrade the addons.

提出問題者

Thanks I will give it a try. As far as I know there is one addon (Colorful tabs) that is not compatible with V4 but Firefox has inactivated it

Thanks I will give it a try. As far as I know there is one addon (Colorful tabs) that is not compatible with V4 but Firefox has inactivated it
blazing88 0 個解決方法 5 個答案

Ok, utterly bizarre solution for me. It was a bit of script that you can load with the Stylish addon called Sharp Minimal -which should just be appearance and FF4 had no problem with according to itself. Or maybe messing around with Safe Mode reset things for me?

Stopping 'Sharp minimal' solved the save tabs thing AND my own problem (which I can't find to close down) which was the loss of icons in location bar.

Ok, utterly bizarre solution for me. It was a bit of script that you can load with the Stylish addon called Sharp Minimal -which should just be appearance and FF4 had no problem with according to itself. Or maybe messing around with Safe Mode reset things for me? Stopping 'Sharp minimal' solved the save tabs thing AND my own problem (which I can't find to close down) which was the loss of icons in location bar.

提出問題者

Another problem is that when I click on a link it doesn't go into a new tab like the previous version did.

Another problem is that when I click on a link it doesn't go into a new tab like the previous version did.
dankyhelpedyou 0 個解決方法 8 個答案

in options under the tabs section, it addresses links and tab handling. i hope this helps.

in options under the tabs section, it addresses links and tab handling. i hope this helps.

提出問題者

Hi dankyhelpedyou,

I seem to be getting nowhere. I have a tick in the first four boxes under "Tools/Options/Tabs" but they don't work.

I couldn't remember how to run FF in safe mode so I clicked on "Help" and got help with running it in safe mode under Linux. One could not wish for a more Microsoft-esque bit of help than that!

Hi dankyhelpedyou, I seem to be getting nowhere. I have a tick in the first four boxes under "Tools/Options/Tabs" but they don't work. I couldn't remember how to run FF in safe mode so I clicked on "Help" and got help with running it in safe mode under Linux. One could not wish for a more Microsoft-esque bit of help than that!
gvaeth 0 個解決方法 1 個答案

You need to toggle just a single parameter: browser.showQuitWarning

This worked fine for me.

You need to toggle just a single parameter: browser.showQuitWarning This worked fine for me.
henryfm 2 個解決方法 39 個答案

Changing the about:config settings did the job, but I would have hoped Firefox would not have changed from a sensible default with the new version. It's bad enough that favourite extensions (such as Autoformfill, which works on forms that are blocked in autofill in IE ) don't work, a consequence of the openness that allows for add-ons, but core features should be retained. I've had to hunt down my old tabbed pages again, quite a pain.

If you want a more controlled environment, I guess you use IE, but even then things do change when versions change.

Changing the about:config settings did the job, but I would have hoped Firefox would not have changed from a sensible default with the new version. It's bad enough that favourite extensions (such as Autoformfill, which works on forms that are blocked in autofill in IE ) don't work, a consequence of the openness that allows for add-ons, but core features should be retained. I've had to hunt down my old tabbed pages again, quite a pain. If you want a more controlled environment, I guess you use IE, but even then things do change when versions change.

提出問題者

Many thank for all your answers. Nothing seems to work so I have gone back to version 3.6.16. perhaps my version of FF4 has become corrupted in some way but I am going to wait now before re-installing it until there have been a few updates

Many thank for all your answers. Nothing seems to work so I have gone back to version 3.6.16. perhaps my version of FF4 has become corrupted in some way but I am going to wait now before re-installing it until there have been a few updates
Boxing Products 0 個解決方法 1 個答案

Re: Firefox does not ask to save tabs and windows on exit

Firefox Help

   Open your profile folder:
       At the top of the Firefox window, click on the Firefox menu, go over to the Help menu (on Windows XP, click on the Help menu) and select Troubleshooting Information. The Troubleshooting Information tab will open.
       Under the Application Basics section, click on Open Containing Folder. A window with your profile files will open. 
   At the top of the Firefox window, click on the Firefox button (File menu in Windows XP) and then click Exit. 

By : www.boxing-products.com

Re: Firefox does not ask to save tabs and windows on exit Firefox Help Open your profile folder: At the top of the Firefox window, click on the Firefox menu, go over to the Help menu (on Windows XP, click on the Help menu) and select Troubleshooting Information. The Troubleshooting Information tab will open. Under the Application Basics section, click on Open Containing Folder. A window with your profile files will open. At the top of the Firefox window, click on the Firefox button (File menu in Windows XP) and then click Exit. By : www.boxing-products.com
JorgeP 0 個解決方法 18 個答案

All you should do is close Firefox, even with multiple tabs open. The next time you open Firefox, the Restore Previous Session box should come about, click on it and your tabs should reappear. FF4 doesn't prompt to save tabs when closing, it just does.

All you should do is close Firefox, even with multiple tabs open. The next time you open Firefox, the Restore Previous Session box should come about, click on it and your tabs should reappear. FF4 doesn't prompt to save tabs when closing, it just does.
cor-el
  • Top 10 Contributor
  • Moderator
17580 個解決方法 159050 個答案

Firefox 4 saves the session automatically.

You can use "Firefox > History > Restore Previous Session" to get the previous session.

There is also a "Restore Previous Session" button on the default about:home Home page.

Another possibility is to use:

  • Tools > Options > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time"
Firefox 4 saves the session automatically. You can use "Firefox > History > Restore Previous Session" to get the previous session. There is also a "Restore Previous Session" button on the default <b>about:home</b> Home page. Another possibility is to use: *Tools > Options > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time"
Rocky 0 個解決方法 3 個答案

cor-el...

bravo, my friend - bravo!!!

certainly not to downplay the other solutions listed herein (as each may require something as unique as their issue), but why does it always seem that the best and easiest answer to these things is always at the bottom of the "hit" parade...?

been finding recently that it's usually better to start at the "last" entry and work my way back - sure saves a lot of time, work and, yes, sometimes even grief!

thanks again...

cor-el... bravo, my friend - bravo!!! certainly not to downplay the other solutions listed herein (as each may require something as unique as their issue), but why does it always seem that the best and easiest answer to these things is always at the bottom of the "hit" parade...? been finding recently that it's usually better to start at the "last" entry and work my way back - sure saves a lot of time, work and, yes, sometimes even grief! thanks again...
kayjayess 0 個解決方法 1 個答案

Thank you, cor-el! This has been driving me crazy ever since I upgraded.

Thank you, cor-el! This has been driving me crazy ever since I upgraded.
VK4ZW 0 個解決方法 1 個答案

How do I revert back to Firefox v3.6? I am having too many problems with v4.0. If not I'll try another browser.

How do I revert back to Firefox v3.6? I am having too many problems with v4.0. If not I'll try another browser.
lpbedford 0 個解決方法 2 個答案

Try this. Open firefox and type aboutconfig in the address bar. Click on the I'll be careful, I promise button. now type quitwarning' in the filter box It will now show browser.showQuitWarning this will be set to fause. Double click this and it should change to true. Close all windows and it should be back. LPB

Try this. Open firefox and type '''aboutconfig''' in the address bar. Click on the '''I'll be careful, I promise''' button. now type '''quitwarning'''' in the filter box It will now show '''browser.showQuitWarning this will be set to fause. Double click this and it should change to true. Close all windows and it should be back. LPB

由 lpbedford 於 修改

pjaj 1 個解決方法 15 個答案

Re:Cor-el's answer

Maybe I'm wrong, but on the version of FF4 that I've just installed (4.0.1), only the second of these solutions works, the about:home one. The options>general doesn't have this any more and the History>Restore-previous-sessions is grayed out (maybe because I'd already done the about:home solution). Nevertheless thanks for at least finding one interim solution, now please can we have the FF3 save-on-exit back?

Re:Cor-el's answer Maybe I'm wrong, but on the version of FF4 that I've just installed (4.0.1), only the second of these solutions works, the about:home one. The options>general doesn't have this any more and the History>Restore-previous-sessions is grayed out (maybe because I'd already done the about:home solution). Nevertheless thanks for at least finding one interim solution, now please can we have the FF3 save-on-exit back?

由 pjaj 於 修改