搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 4.0b1 and b2 rendering incorrect weight of some fonts

  • 5 回覆
  • 90 有這個問題
  • 201 次檢視
  • 最近回覆由 Jack Yan

more options

Firefox 4.0b1 and b2 rendering incorrect weight of some fonts

The first thing I had noticed when I upgraded from FF 3.6 to 4 beta 1 was that Firefox was incorrectly rendering fonts as bold. After some digging I found out that it was the font-family:"helvetica neue" line in the css file that was causing the ugly bolded font (black weight, actually). After editing the css to "Helvetica 55 Roman", the font displays okay.

Example site: https://addons.mozilla.org/en-US/firefox/?browse=featured The thing happens in the very mozilla addons site.

Also have noticed that the same bug occurs on different fonts, where the font name in css is specified in alternative namings, as in "나눔 고딕" for NanumGothic (korean font).

The bug didn't seem to have fixed in beta 2, nor could I find any other thread/document on the web with the same problem. I doubt it's my own problem, since it worked just fine in older versions and I have the very same font files installed since the start.

Screenshot: http://i25.tinypic.com/zy9co2.jpg

This happened

Every time Firefox opened

== Open certain websites with css font-family:"helvetica neue" in the stylesheets

所有回覆 (5)

more options

Firefox doesn't always display old bitmap versions of Helvetica fonts correctly and having such old fonts installed can cause all kind of problems. You need to find modern vector type (True Type or Open Type) versions of such fonts.

more options

The Helvetica Neue installed on my computer are the modern opentype versions. The biggest proof here that something's wrong with firefox 4 beta and not my computer or the font files I have installed- is that the fonts worked just fine in older versions of firefox, and that only specific alternative names for the font are causing the bug.

more options

Here's a related post in bugzilla where I posted the same issue:

https://bugzilla.mozilla.org/show_bug.cgi?id=578829


A screenshot I attached: https://bug578829.bugzilla.mozilla.org/attachment.cgi?id=465206

more options

I'm using Firefox 4 beta and am also finding it difficult to read sites which use helvetica neue. Using the Stylish addon with a CSS rule to override helvetica neue and replace it with arial works for me: http://userstyles.org/styles/37774

more options

I sympathize with you all, and I spotted Kimatg at the Bugzilla forums. My Firefox 3 is all right with Helvetica and Neue Helvetica in PostScript, TrueType and OpenType. However, my Firefox 4 Beta 7 through 9 goes nuts.

Compared to the situations above, all I can say is: at least you are getting your pages in the right font family or even in the right typeface. Attached are some pages in Helvetica that my Betas are showing. They don’t even come close to a typeface, let alone Helvetica.

It’s not just Helvetica. Our in-house Arial substitute, Lucire, is also displaying oddly on some pages unless the font is embedded.

Cor-el, I know you are one of the most helpful folks here, and I thank you for your continued generosity. I have to make one correction to your statement: PostScript on Windows generally does not have a bitmap component, unlike on a Mac where it had suitcases. So all these fonts are vector-based.

It shouldn’t make a difference to Firefox’s rasterizer anyway, but, for some reason, on 4 Beta, it does.