搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox randomly fails to load certain websites

  • 17 回覆
  • 1 有這個問題
  • 60 次檢視
  • 最近回覆由 zeroknight

more options

Windows 10, Firefox 123.0 (64-bit)

It's so bad that I might have to stop using it entirely.

I've tried creating new profiles, disabling all add-ons, and disabling Enhanced Tracking Protection; none helped.

https://drive.google.com/file/d/1DX19hX88Hz_XUbsd0dAljiiiKY_XUUN_/view

As you can see in the video (about the 00:16 mark) it randomly stops properly loading pages from the website, even in new tabs. The only temporary remedy is to either close and re-open FF, or press Ctrl+F5 (which I did at the end of the video).

I must add that it can happen even when loading the website for the first time in the session.

Windows 10, Firefox 123.0 (64-bit) It's so bad that I might have to stop using it entirely. I've tried creating new profiles, disabling all add-ons, and disabling Enhanced Tracking Protection; none helped. https://drive.google.com/file/d/1DX19hX88Hz_XUbsd0dAljiiiKY_XUUN_/view As you can see in the video (about the 00:16 mark) it randomly stops properly loading pages from the website, even in new tabs. The only temporary remedy is to either close and re-open FF, or press Ctrl+F5 (which I did at the end of the video). I must add that it can happen even when loading the website for the first time in the session.

所有回覆 (17)

more options

When creating a new profile, make sure you don't sign in to your sync account to avoid carrying across the issue.

Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection" and in Connection Settings change "Use system proxy settings" to "No proxy".

Kaspersky can cause performance issues if you have "Inject script into web traffic to interact with web pages" enabled and don't have the companion browser extension installed.

Disable any third-party antivirus or security software, this may require rebooting into Windows Safe Mode (networking enabled).

有幫助嗎?

more options

zeroknight said

When creating a new profile, make sure you don't sign in to your sync account to avoid carrying across the issue.

Why would syncing bring over the issue? What's the point of having a profile then?

This is not an option. I want to use my profile and sync my stuff.

Even if I were to manually export/import the bookmarks and passwords, I want the history. How would I import history then?

Besides, how do you delete the sync data from an account anyway? I don't see an option on accounts.firefox.com. I'm not going to delete the entire account just for that.

Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection" and in Connection Settings change "Use system proxy settings" to "No proxy".

Tried both, zero change.

Kaspersky can cause performance issues if you have "Inject script into web traffic to interact with web pages" enabled and don't have the companion browser extension installed.

I don't use that.

Disable any third-party antivirus or security software, this may require rebooting into Windows Safe Mode (networking enabled).

I don't have any.

I just tried clearing the cache, again, and it didn't help. I then deleted only the cookie of github, and it seemed to have helped, but the problem comes back after a while, so I guess firefox doesn't play right with it.

Why would a cookie cause that and how do I fix it permanently?

Actually, it seems being signed in causes it. Signed out it looks fine, and the loading speed is faster too.

I must point out that isn't the only website with this loading problem.

由 eddman 於 修改

有幫助嗎?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin), always make sure such extensions do not block content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings), click the padlock icon (Clear cookies and site data) for the domain in the selected tab.

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages like blocked content.

有幫助嗎?

more options

Did you read the entirety of my posts?

cor-el said

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin), always make sure such extensions do not block content.
  • make sure your extensions and filters are updated to the latest version

I already mentioned that I've tried with no add-ons.

You can try these steps in case of issues with webpages: You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.
  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings), click the padlock icon (Clear cookies and site data) for the domain in the selected tab. "Remove the Cookies" for websites that cause problems:
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"
"Clear the Cache":
  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

I've already wrote that I've tried those. Clearing the cache has zero effect, and clearing the cookies does seem to make it work but that's only because I get logged out of github. Logging back in causes the problem to return. I've cleared the cache and cookies and created new profiles multiple times.

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.
  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

It's not the extensions; it happens without them too. I've also tried the troubleshoot mode.

Disabling the hardware acceleration doesn't help. It's not the theme since I've tried new, completely stock profiles and it happens there too.

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.
  • click the shield icon for more detail and possibly disable the protection
You can check the Web Console for relevant-looking messages like blocked content.

Again, I've already tried that. It's right there in the first post.

It seems firefox simply doesn't work right with some cookies.

P.S.

The troubleshoot information data that I shared are for my default firefox setup that I use, not the one that I used for testing. As stated before, I've already tested with practically everything disabled.

由 eddman 於 修改

有幫助嗎?

more options

Also tested with version 123.0.1; same problem.

有幫助嗎?

more options

It's also happening with reddit, now that it has its new-new UI. Pages constantly fail to load, or sometimes the content of the OP shows up but the comments don't load.

Tested with the troubleshoot mode too.

由 eddman 於 修改

有幫助嗎?

more options

I just tried to replicate the problem on that github page, but didn't have any issues, but I'm in Linux. Let me go see what happens in windows.

Are you running pro or home version of Windows? If pro, you should have sandbox (VM) enabled to test this issue. https://www.howtogeek.com/399290/how-to-use-windows-10s-new-sandbox-to-safely-test-apps/

Can we get system info? Laptop, Desktop, or DIY? If not DIY, what make and model? Graphics card and driver info? Post a screenshot of the performance tab in Task Manager.

由 jonzn4SUSE 於 修改

有幫助嗎?

more options

Not able to replicate the issue in Win11. Where are you(if US, what state) and who are you using for DNS?

由 jonzn4SUSE 於 修改

有幫助嗎?

more options

eddman said

It's also happening with reddit

Only when signed in to reddit?

Does it still happen with Developer Edition? Make sure you stay signed out of your sync account when testing.

有幫助嗎?

more options

jonzn4SUSE said

Where are you(if US, what state) and who are you using for DNS?

I was using 8.8.8.8. Switched to 1.1.1.1 but it behaves the same.

I tested FF in windows sandbox without signing into my FF account, and the same issue.

Now this is weird. Github was working fine even singed in. I then installed ublock origin and it started misbehaving, which doesn't make sense since I've already tried multiple times before with it disabled and even removed and yet it didn't change anything.

Apparently after disabling ublock, I also have to delete github cookies to make it work. I seems somehow ublock corrupts the cookies.

I switched to edge for testing and the same thing happens there too.

It either or something is wrong with the internet connection, which is doubtful since Ctrl+F5 immediately make the page load (until it happens again).

I'll test to see if it's a general ublock thing or one of the filters is causing it. If you can, please try to replicate it to make sure I'm not losing my mind. :D

由 eddman 於 修改

有幫助嗎?

more options

Reddit's issue happens even without installing any add-ons.

https://drive.google.com/file/d/1kbnrsJbeu2Jgrl5TVIDuZwaymAYfeUro/view?usp=sharing

I honestly don't know anymore.

有幫助嗎?

more options

jonzn4SUSE said

Laptop, Desktop, or DIY? If not DIY, what make and model? Graphics card and driver info? Post a screenshot of the performance tab in Task Manager.

I forgot this part.

Windows 10 64-bit, 22H2 Gigabyte B450 AORUS ELITE Ryzen 5700X 16 GB RAM Geforce GTX 1060 6 GB, driver 546.33

由 eddman 於 修改

有幫助嗎?

more options

Did you try Developer Edition?

有幫助嗎?

more options

zeroknight said

Did you try Developer Edition?

No difference in reddit.

EDIT: I tested it more in the same sandbox and now it's not happening! I don't get it.

EDIT 2: and happening again. It is very random.

由 eddman 於 修改

有幫助嗎?

more options

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

有幫助嗎?

more options

cor-el said

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.
  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Which I had already mentioned I'm doing, which is exactly what I do every single time a page gets stuck, but guess what, it happens again shortly thereafter, meaning I have to press Ctrl+F5 thousands of times a day.

Please post something that's actually helpful.

有幫助嗎?

more options

Do you have active enterprise policies listed in about:policies?

Disable any third-party modules in about:third-party.

Try using a different IP address, you could use your phone's Wi-Fi hotspot feature.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先登入帳號 來回覆文章。還沒有帳號的話,只能發問新問題