搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Stop tabs from automatically refreshing to top of page

  • 4 回覆
  • 5 有這個問題
  • 1 次檢視
  • 最近回覆由 zeroknight

more options

Stop tabs from automatically refreshing to top of page. Many people have this problem and I don't find a fix. One article states to go to Options and "Warn me when websites try to redirect or reload the page," but I can't find options.

Stop tabs from automatically refreshing to top of page. Many people have this problem and I don't find a fix. One article states to go to Options and "Warn me when websites try to redirect or reload the page," but I can't find options.

所有回覆 (4)

more options

You can disable meta refresh with uBlock Origin by adding the following line to the "My filters" tab for each site:

website.com##^meta[http-equiv="refresh"]
more options

Note that a lot of websites use JavaScript to refresh the page and possibly set a timer to trigger this automatically (e.g. drudgereport does this). In this case there is no meta-refresh, but JS can set document.location or use other ways to refresh the page.

Can you post a link to pages where this happens ?

more options

It's on Twitter, and seems to be better using Chrome. But I'm not posting links. I'm looking at my followers, but when I click on the tab in Firefox, the list refreshes to the top of the list and I'm lost to find where I was

more options

Does it still happen in Troubleshoot Mode?