搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

When I type in Amazon the .co.uk site is the first option and I don't know why

  • 6 回覆
  • 0 有這個問題
  • 2 次檢視
  • 最近回覆由 pat.george

more options

I believe I had originally installed Firefox while I was in the UK. Since then I've moved to the US. When I type "amazon" in the location box, the first option is "amazon.co.uk". I've looked for options to change this to amazon.com. I cannot remove it (there's no "..." to the right). I've downloaded and reinstall Firefox now that I'm in the US. I made sure my default language is English (US).

One thing I can't done is completely uninstall Firefox and then reinstall. I'd rather not lose any settings and so am saving that for the last resort.

Anything else I can try?

I believe I had originally installed Firefox while I was in the UK. Since then I've moved to the US. When I type "amazon" in the location box, the first option is "amazon.co.uk". I've looked for options to change this to amazon.com. I cannot remove it (there's no "..." to the right). I've downloaded and reinstall Firefox now that I'm in the US. I made sure my default language is English (US). One thing I can't done is completely uninstall Firefox and then reinstall. I'd rather not lose any settings and so am saving that for the last resort. Anything else I can try?

被選擇的解決方法

Search your history (Ctrl+H) for the unwanted site and right-click > Forget About This Site.

從原來的回覆中察看解決方案 👍 0

所有回覆 (6)

more options
more options

What is the setup on your router? Also on the about:config page, check these sections. see screenshots

由 jonzn4SUSE 於 修改

more options

Go to about:config in the address bar and change browser.search.region to US then restart the browser.

more options

Thanks, all.

browser.search.region was already US

But doh-rollout.home-region was UK.

Unfortunately changing that to US and restarting didn't change anything.

I'm not sure how to get to the second screenshot.

My router is new (I didn't bring it from the UK) but in any event my DNS appears to be US Cloudflare.

more options

選擇的解決方法

Search your history (Ctrl+H) for the unwanted site and right-click > Forget About This Site.

more options

That did it, thank you. I "forgot this site" and then deleted all instances of it. Much appreciated.