搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

No decoder found for audio/mpeg

more options

System: MacOS 13.5 Hardware: Apple M1 Max Firefox version: 116.0.1 about:support / Media Audio Backend: audiounit-rust Codec Support Information: Codec Name Software Decoding Hardware Decoding H264 Supported Unsupported AAC Supported Unsupported Opus Supported Unsupported Vorbis Supported Unsupported Wave Supported Unsupported


Having a problem with an mp3 content on all sites. In console I can see error: Error Code: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) Details: Error no decoder found for audio/mpeg

The same error shows when starting firefox from terminal: [Child 1234, MediaDecoderStateMachine #1] WARNING: Decoder=11dddc400 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - Error no decoder found for audio/mpeg: file /builds/worker/checkouts/gecko/dom/media/MediaDecoderStateMachineBase.cpp:166

It seems like not a system problem, because I can open and listen an mp3 files in quicktime. And chrome browser also not having any problems playing an mp3 content.

Firefox installed with dmg downloaded from site, but also tried install with brew - same result. The problem occurs in incognito mode too.

System: MacOS 13.5 Hardware: Apple M1 Max Firefox version: 116.0.1 about:support / Media Audio Backend: audiounit-rust Codec Support Information: Codec Name Software Decoding Hardware Decoding H264 Supported Unsupported AAC Supported Unsupported Opus Supported Unsupported Vorbis Supported Unsupported Wave Supported Unsupported Having a problem with an mp3 content on all sites. In console I can see error: Error Code: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) Details: Error no decoder found for audio/mpeg The same error shows when starting firefox from terminal: [Child 1234, MediaDecoderStateMachine #1] WARNING: Decoder=11dddc400 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - Error no decoder found for audio/mpeg: file /builds/worker/checkouts/gecko/dom/media/MediaDecoderStateMachineBase.cpp:166 It seems like not a system problem, because I can open and listen an mp3 files in quicktime. And chrome browser also not having any problems playing an mp3 content. Firefox installed with dmg downloaded from site, but also tried install with brew - same result. The problem occurs in incognito mode too.

被選擇的解決方法

As a Windows person, I can't get hands on with a Mac, but I think the first question is whether Mac OS is denying Firefox access to some components, or whether a Firefox setting or add-on could be causing this issue. One method to suss out an issue with settings or add-ons is:

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Return to load it.

Take a quick glance at the page and make a mental note of which Profile has this notation: This is the profile in use and it cannot be deleted. That is your current default profile.

Click the "Create a New Profile" button, then click Next. Assign a name like Test2023, ignore the option to relocate the profile folder, and click the Finish button.

Firefox will switch your default profile to the new one, so click the Set as Default Profile button for your regular one to avoid an unwanted surprise at your next startup.

Scroll down to Test2023 and click its Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system to get a clean test.

Does MPEG-encoded media play in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Test2023 will remain available for future testing.)

從原來的回覆中察看解決方案 👍 2

所有回覆 (4)

more options

Dropa said

Beyond Firefox defaults anything codec that Firefox doesn't use isn't something that can be resolved here. You need to check sites that uses those codec to find out the best format to use.

But mp3 is a codec that Firefox should be able to resolve and play. https://support.mozilla.org/en-US/kb/html5-audio-and-video-firefox#

more options

選擇的解決方法

As a Windows person, I can't get hands on with a Mac, but I think the first question is whether Mac OS is denying Firefox access to some components, or whether a Firefox setting or add-on could be causing this issue. One method to suss out an issue with settings or add-ons is:

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Return to load it.

Take a quick glance at the page and make a mental note of which Profile has this notation: This is the profile in use and it cannot be deleted. That is your current default profile.

Click the "Create a New Profile" button, then click Next. Assign a name like Test2023, ignore the option to relocate the profile folder, and click the Finish button.

Firefox will switch your default profile to the new one, so click the Set as Default Profile button for your regular one to avoid an unwanted surprise at your next startup.

Scroll down to Test2023 and click its Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system to get a clean test.

Does MPEG-encoded media play in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Test2023 will remain available for future testing.)

more options

jscher2000 - Support Volunteer said

As a Windows person, I can't get hands on with a Mac, but I think the first question is whether Mac OS is denying Firefox access to some components, or whether a Firefox setting or add-on could be causing this issue. One method to suss out an issue with settings or add-ons is: New Profile Test This takes about 3 minutes, plus the time to test your problem site(s). Inside Firefox, type or paste about:profiles in the address bar and press Return to load it. Take a quick glance at the page and make a mental note of which Profile has this notation: This is the profile in use and it cannot be deleted. That is your current default profile. Click the "Create a New Profile" button, then click Next. Assign a name like Test2023, ignore the option to relocate the profile folder, and click the Finish button. Firefox will switch your default profile to the new one, so click the Set as Default Profile button for your regular one to avoid an unwanted surprise at your next startup. Scroll down to Test2023 and click its Launch profile in new browser button. Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system to get a clean test. Does MPEG-encoded media play in the new profile? When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Test2023 will remain available for future testing.)

Thanks! That worked. I am able to listen to MP3s in a new profile. Do you have any suggestions for which settings I should check first? I also plan to try cleaning up extensions I no longer use.

Anyway, it's a big relief to know that this is fixable.

UPD: Nevermind, I just reset all settings starting with "media," ignoring "media.gmp-," and it worked. Thank you again for your help!

由 crazytushkan 於 修改

more options

crazytushkan said

UPD: Nevermind, I just reset all settings starting with "media," ignoring "media.gmp-," and it worked. Thank you again for your help!

That was good thinking. Thank you for reporting back.