搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Extremely high Cpu usage after firefox update

  • 9 回覆
  • 4 有這個問題
  • 3336 次檢視
  • 最近回覆由 Dark_mustard

more options

Hello, I hope someone can help me.

Ever since I updated firefox, my cpu is almost at 100%. With only 2 or 3 tabs open. I updated from version 106.0.2 to 112.0.2. Before this update, I could have several tabs open, up to 10 and the computer would run fine. Now with 3 tabs open, it gets really slow. And I can hear my desktop suffering (the fans go to full speed). When checking the task manager, firefox is taking all the memory and the cpu usage is almost at 100%. I have to keep restarting firefox.

The conditions are the same. The only thing that changes was updating firefox. I already searched for ways to reduce the firefox cpu usage, but nothing changed.

Is there a way to fix this? Or how can I go back to an older version of firefox? Because I'm afraid my computer will die from simply opening 3 tabs.

Thank you in advance.

Hello, I hope someone can help me. Ever since I updated firefox, my cpu is almost at 100%. With only 2 or 3 tabs open. I updated from version 106.0.2 to 112.0.2. Before this update, I could have several tabs open, up to 10 and the computer would run fine. Now with 3 tabs open, it gets really slow. And I can hear my desktop suffering (the fans go to full speed). When checking the task manager, firefox is taking all the memory and the cpu usage is almost at 100%. I have to keep restarting firefox. The conditions are the same. The only thing that changes was updating firefox. I already searched for ways to reduce the firefox cpu usage, but nothing changed. Is there a way to fix this? Or how can I go back to an older version of firefox? Because I'm afraid my computer will die from simply opening 3 tabs. Thank you in advance.

被選擇的解決方法

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works, you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

從原來的回覆中察看解決方案 👍 1

所有回覆 (9)

more options
  1. What add-ons do you have?
  2. Is GPU working? Enter about:support in the address bar and check the GPU Process row in the Graphics section.
more options

You can check the about:memory and about:processes pages for info about all processes. There are several toolkit.aboutProcesses prefs on the about:config page to show more info. See also the about:unloads page for info about the tabs.

more options

maybe one of the websites you are using causing this problem if that is not your problem try updating your computers software

more options

TyDraniu said

# What add-ons do you have?
  1. Is GPU working? Enter about:support in the address bar and check the GPU Process row in the Graphics section.

Thank you for replying. I have the ad-ons Kaspersky protection and ublock origin. I've had these for years. The Gpu is working. In the GPU Process it says: default available

In the about:processes page, the gpu's memory is 254mb and 0.50% cpu.

more options

cor-el said

You can check the about:memory and about:processes pages for info about all processes. There are several toolkit.aboutProcesses prefs on the about:config page to show more info. See also the about:unloads page for info about the tabs.


Thank you for replying. Although, I'm not sure what I'm suppose to do with this information. I have sorta basic knowledge on this.

more options

lazizakhmedov1014 said

maybe one of the websites you are using causing this problem if that is not your problem try updating your computers software


Thank you for replying. The software is up to date, and it happens on several websites.

more options

This morning my computer froze completely. When task manager finally opened, it said firefox was using 6000mb. The website open was aliexpress, with 5 tabs.

Yesterday, firefox was using 2000mb with 1 instagram tab and 3 facebook tabs open (no videos playing).

more options

選擇的解決方法

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works, you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

cor-el said

You can create a new profile as a quick test to see if your current profile is causing the problem. See "Creating a profile": If the new profile works, you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Thank you very much! I dind't knew it was possible to test in different profiles. When making a new profile, it runs smoother, so something must be corrupted on the previous one.

I transferred the bookmarks to the new profile, and added the extensions. I tested with 10 tabs open and it was ok. Looks like it's solved. Thank you!