搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

audio in video playing in firefox stops if i add a new tab or add a tab in existing browser

more options

When I play a video or audio, the audio stops abruptly if i add a new tab or switch between tab. This is of recent nature. There is no yellow marks on the device manager. When I click the sound is totally gone. I have not changed any settings. I tried a thread solution of making false in auto pref media in about:config. But that does notfix the problem. why this happens and how to fix it I was adding speakers to a pc after quite long time and the sound plays well. But i could not hear the audio if i change the tab or add a new tab

When I play a video or audio, the audio stops abruptly if i add a new tab or switch between tab. This is of recent nature. There is no yellow marks on the device manager. When I click the sound is totally gone. I have not changed any settings. I tried a thread solution of making false in auto pref media in about:config. But that does notfix the problem. why this happens and how to fix it I was adding speakers to a pc after quite long time and the sound plays well. But i could not hear the audio if i change the tab or add a new tab

所有回覆 (6)

more options

Here are a few things you can try to fix the issue:

1)Check your audio settings: Make sure that your audio settings are set correctly in Firefox. Go to Firefox's preferences and then "Content" and then "Autoplay" and check if the option to "Block audio and video" is disabled. 2)Clear your browser cache: Sometimes, issues with the browser can be caused by problems with the browser cache. Go to Firefox's preferences and then "Privacy & Security" and then "Cookies and Site Data" and then select "Clear Data". 3)Disable hardware acceleration: Sometimes, hardware acceleration can cause issues with audio and video playback in Firefox. Go to Firefox's preferences and then "General" and then "Performance" and uncheck the box for "Use hardware acceleration when available." 4)Check your audio drivers: Make sure your audio drivers are up-to-date and that there are no issues with them. You can check this by going to the Device Manager (search for "Device Manager" in the start menu) and looking for any yellow marks next to your audio device. If there are any, try updating the drivers or reinstalling them. 5)Check your speakers: Make sure that your speakers are connected properly and that they are working properly. Try playing audio from a different source to see if the issue is with Firefox or with your speakers. 6)Try disabling the Firefox's Firefox's Media Session Service. This can be done by going to "about:config" in the Firefox address bar and searching for "media.session" and disabling all the options.

more options

Please note that in some cases, the problem may be caused by a conflict with the operating system or other software on your computer, and the solution might lie in that direction.

more options

Hi, mikh, your tip 1)Check your audio settings: Make sure that your audio settings are set correctly in Firefox. Go to Firefox's preferences and then "Content" and then "Autoplay" and check if the option to "Block audio and video" is disabled. This has solved the problem. I have not changed the auto play settings myself and hope that it is by default the firefox is allowing all videos and videos.who would have changed the setting .i do not know. But one small issue. The tab now allows sound on tabs, but the playback is somewhat slow than normal. please say

more options

Hi, mikh, one more thing. When I get a reply there is two options. One mark as solved and the other one, this does not fix my issue. What I want firefox , is to provide a extra button to go to the thread . How could one say, mark as answer, without going to and perform the suggestion How could you say, this does not fix my issue without going to and perform the suggestion I want firefox moderators or admin to add a link to access the thread page, so that we could go to the thread

more options

Use the menu icon in the top right, click on Help, and select Troubleshoot Mode from the sub-menu. Step 2: Select Restart to launch Firefox in Troubleshoot Mode. Try streaming a video in Firefox. If it is playing alright, then it's one of the Add-ons interfering with the video playback on Firefox

Regards, Will

more options

You can reset the window size for Firefox back to its default settings by deleting the xulstore. json file. It can be found in the root of your Firefox profile folder. You will need to make sure that Firefox is not running when you remove this file.

Regards, Will