搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Webpages have begun to open in random language.

  • 11 回覆
  • 1 有這個問題
  • 6 次檢視
  • 最近回覆由 FredMcD

more options

About a week ago, Firefox began occasionally opening a webpage or even my Google login window in some random language. Opening a new tab and closing the errant tab would result in the same page opening correctly in English. The language used when Firefox erred was never the same twice. In the last couple days the rate of errors has accelerated. Any ideas how to fix this problem? Is someone other than me using my Firefox credentials?

所有回覆 (11)

more options

Are you or have you been outside your home country?

> Reboot the computer

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem,

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

While you are in Troubleshoot(Safe) mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

有幫助嗎?

more options

I have not been out of the country but I was on another network at an airb&b shortly before the problem started. My settings already call for my cache and cookies, etc to be deleted when closing Firefox. I am on Windows10 but I have no "options" selection in my Firefox menu. I am puzzled by the statement in Settings: "your settings are being managed by your organization" since I have no organization of which my network is a part of. I am including a shot of this window before I began entering my response. You can clearly see the "language bug" at work. At least it is not Arabic an Asian language which come up in the "rotation".

有幫助嗎?

more options

Are you possibly using a VPN service that places you in different countries ?

You can use websites like these to see how your location is reported via a reverse DNS look up of your IP:


You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":


Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

有幫助嗎?

more options

scottyNC said

I am puzzled by the statement in Settings: "your settings are being managed by your organization" since I have no organization

Others not part of an organization have reported this problem.

Your organization has disabled the ability to change some options

https://support.mozilla.org/en-US/questions/1256411#answer-1213977

https://support.mozilla.org/en-US/questions/1256411#answer-1214022

https://support.mozilla.org/en-US/questions/1239094

有幫助嗎?

more options

What security software do you have?

This could be a problem with Avast Anti-Track, so if you use this software then try to disable it.

有幫助嗎?

more options

I notice that your System Details list includes some plugins.

  • blockit.dll
  • emailchecker.dll
  • rafwebplugin.dll
  • glsslg.dll

Do these plugins show in "Add-ons -> Plugins" or on the about:plugins page ?

有幫助嗎?

more options

when I last posted, I was running in Safe Mode and problem still existed. Not using a VPN My IP location has always "floated" to several different places but all within a 100 mile diameter circle of the Southeast US. (I assume this is due to multiple server locations of my ISP) I have AVG anti-track ≈ Avast so that could indeed be the source but why does it not manifest in MS_edge or Google Chrome as well as Firefox? cor-el: where do you get the list of .dll files? All I can find within Firefox tools/menus is the list and description of 2 plug-ins and several extensions.

有幫助嗎?

more options

Update: Just now, the problem has migrated to my other browsers. On Firefox, the problem could randomly pop up on what seemed to be a random website but anything Google was more susceptible to the occurrence. Just now Google and Edge browsers are exhibiting the problem for the first time but it seems to be every time I open a window related to Google, -and Google only at this point. Both browsers recognize the issue and ask if I want to translate the page to English. -Ran a virus scan with no results. Whatever, the problem seems to be bigger the just Firefox now.

有幫助嗎?

more options

Are you logged into Google? Did you select a language/location in its settings?

有幫助嗎?

more options

Google acct: English selected for language. I did turn off "Automatically add languages". I didn't find where location could be specified. Location history is set to off. Interesting, I checked these setting by logging in on Chrome with no language issue. Back to random problem again?

有幫助嗎?

more options

Have you contacted Google support on this?

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題