搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Can't rollback from Firefox 91 to 89.

  • 8 回覆
  • 3 有這個問題
  • 48 次檢視
  • 最近回覆由 cor-el

more options

Win10 with what was Firefox 89. I had already disabled the Proton UI on this installation, because it is horrible. Today Firefox decided to update to version 91. All of the Proton UI junk is back. I tried disabling it again, but nothing worked. Doing a web search, it appears that Mozilla has disabled the ability to turn off Proton.

I then set about to rollback the installation back to version 89. I found a Mozilla link on this, went to their ftp server and downloaded the installation files for the last version of 89. The installation went normally, but when I opened Firefox afterwards, a little box popped up saying something to the effect of "To keep your History and Bookmarks from possibly being corrupted, Firefox must create new user profile." I exited out of this and Firefox didn't start. I attempted to restart Firefox again and the same box popped up again. The only way to get past it was to click the accept button.

I did so and Firefox started. This was clearly not version 89. As the UI is junk, it took several minutes to find out that this was now the latest version of 92!!!! I'm absolutely positive that I downloaded the correct file. When I look through the update history, it doesn't even show todays version 89 installation as happening. What a piece of junk.

I then spent 20 minutes figuring out how to revert back to my user profile, not the new one that it had created for me. I then did some research on what had happened. Well it turns out that you can't actually rollback Firefox, despite what Mozilla says. For a while they have added "downgrade protection" which automatically creates the new user profile and stops your old profile from being accessed by it. So unless you want to figure out how to spend a hundred hours reconstructing bookmarks, passwords, settings, etc. it actually isn't possible to rollback Firefox. Doesn't this violate some Microsoft rules about being able to uninstall versions of software from within Windows? If you try to do this with Firefox and go back to a previous version it blows everything up.

Does anyone know how to actually rollback Firefox to a previous version, so that Proton can be disabled?

所有回覆 (8)

more options

The system details seem to indicate that you use Firefox 92 beta.

Do you have multiple Firefox versions installed or is 92.0 beta the only version ?


In Firefox 91+ you can no longer disable Proton and revert changes that come with this design via "browser.proton.enabled = false" on the about:config page. Best in Firefox 91 is to set browser.proton.enabled at its default value true as the false setting can cause issues with checkboxes.

In Firefox 91+ you need to use code in userChrome.css to override changes coming with the Proton design.

有幫助嗎?

more options

I only have and have only ever have installed one copy of Firefox on the computer. I did not install version 92 Beta. Firefox did. The ONLY file I downloaded from the Firefox ftp site is "Firefox Setup 89.0b9.exe" Executed this file and as a result Firefox installed 92 Beta. That is broken behavior.

My question above was "Does anyone know how to actually rollback Firefox to a previous version, so that Proton can be disabled?"

The css style fix doesn't work, because it can't change the line spacing, which is one of the biggest problems with Proton.

It is beyond stupid to write code so that it operates badly on the majority of platforms out there. If there is a problem with the ability to press on the correct lines with a computer that has a touch screen, that is a problem with the hardware, firmware and design on that machine. You shouldn't break everyone else's computer in the world. Let the touchscreen manufacturer fix THEIR problem.

有幫助嗎?

more options

有幫助嗎?

more options

How did you end up downloading that version ?

As you can see by the 'b9' in "Firefox Setup 89.0b9.exe", you downloaded a 89.0 Beta 9 version that did place you on the beta update channel.

The last Firefox 89 release (89.0.2) would be in this location:


You can use code in userChrome.css to modify the menu spacing.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

menupopup > menuitem, menupopup > menu {padding-top: 2px !important; padding-bottom: 2px !important;}
*|*:root {--arrowpanel-menuitem-padding: 2px 8px !important;}

有幫助嗎?

more options

I went to the Firefox ftp site and selected the last version of 89 listed. Then selected my OS, language, etc. The link that sends one to the ftp site doesn't in any way describe the nomenclature of the file naming convention within it. So I downloaded the last version of 89 listed.

That doesn't explain how Firefox magically changed itself to installing version 92.

It is totally unacceptable that one can't rollback to an earlier version without destroying all of your data. If that is the case, then the software needs to explicitly explain this, before installing itself.

有幫助嗎?

more options

What an awful experience! Didn't Firefox just eliminate the ability to access FTP sites?

How do you know which of these files is the correct one to download for FF v. 89.02 for Windows 10, 64-bit?

(In version 89.02, you can reverse many of the Proton and other unwanted features, and update the Wildvine plug-in)

Then, how do you install it?

https://ftp.mozilla.org/pub/firefox/releases/89.0.2/ https://download-installer.cdn.mozilla.net/pub/firefox/releases/89.0.2/win64/

有幫助嗎?

more options

@ cor-el

As you posted, I went to:

   The last Firefox 89 release (89.0.2) would be in this location:
   https://download-installer.cdn.mozilla.net/pub/firefox/releases/89.0.2/ 

It's not clear which file is used to install 89? Guidance please?

Thanks for help.

有幫助嗎?

more options

Note that Firefox 93 comes with a fix for the bookmarks menu spacing via "Density: Compact" mode.


@ gmptee

I don't what platform and Firefox locale you need, but you can browse that download link via the platform and locale if you still want to use 89.0.2.

Firefox 89.0.2 on 64-bit Windows and en-US locale:

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題