搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 91.0 ==> UI issues with appearance of fields, buttons

  • 11 回覆
  • 13 有這個問題
  • 52 次檢視
  • 最近回覆由 wisdomoflove

more options

Updated to Firefox 91.0 (MacOS 10.13.6 High Sierra) ==> UI issues with fields showing no color, inappropriate color, window transparent/skeletal appearance where under-window is visible / inability to use selection buttons. Normally I could solve this by deselecting graphics acceleration but in 91.0 FFx this doesn't solve the problem. If FFx Team Members are reading: Please fix, thanks.

所有回覆 (11)

more options

Just to add 2 points: 1. The UI problem is particularly evident when I'm viewing my Google Mail and Google Calendar pages -- but I also see it with non-Google web pages. 2. I had been using the Firefox Color to customize the appearance of FFx pages, but the problem persists even when I disable Firefox Color.

有幫助嗎?

more options

All Shopify websites are no longer rendering correctly either - BG colors and styling missing from many elements, though most of the CSS styling is still working. hmmm.

Tried in safe mode, deleted cache, etc. Debugger doesnt seem to show any issue I can detect. Uploading an example - Chrome on top, FF below. This is a huge problem!

有幫助嗎?

more options

Last night around 10pm Firefox looked fine. I shut down my computer. When I cut my computer on today and started using Firefox, none of the colors were right. At first I thought it was the particular website (Clockify) but then as I went to each page I use while working (Github, Jira, etc) none looked right. I use dark mode because it helps me not get migraines while working. But it was like their colors were inverted. All pages were white and some parts invisible unless highlighted. When I went into the settings for Firefox they were in dark mode, kind of, but there was a white box with white text for a lot of the options so I can't see what they say unless I highlight them. I tried changing themes (it had been using my system settings) and that only changed the tab colors, the text on the tabs failed to change so the tabs were unreadable, and the issues with the pages remained.

I have to get work done, and I thought I could maybe still use Firefox even though it was light but so many things are invisible because it's white on white. I have to switch to Chrome. So far the web pages show up fine in Chrome so it may just be an issue with Firefox.

I had my tabs all setup for a meeting so it sucks to have to quickly setup in a different browser that doesn't even have my logins saved. I've attached a picture of what the settings in Firefox look like right now (I don't have any theme enabled).

有幫助嗎?

more options

For me the steps below fix the UI problem seen in FFx 91.0 using MacOS (fields showing no color/inappropriate color, windows are transparent/skeletal in appearance where under-window is visible, inability to use some selection buttons)

1. Navigate in Firefox > Preferences > General > Language and Appearance > Colors... 2. In the pop-up panel you'll have 3 choices under "Override the colors specified by the page with your selections above" ==> Select NEVER 3. For the box marked "Use system colors" ==> CHECK IT 4. Quit and restart Firefox 91.0

For me this fixes most webpages -- but fields in some pop-up panels still remain transparent

由 pmaisonpierre 於 修改

有幫助嗎?

more options

pmaisonpierre said

Updated to Firefox 91.0 (MacOS 10.13.6 High Sierra) ==> UI issues with fields showing no color, inappropriate color, window transparent/skeletal appearance where under-window is visible / inability to use selection buttons. Normally I could solve this by deselecting graphics acceleration but in 91.0 FFx this doesn't solve the problem. If FFx Team Members are reading: Please fix, thanks.

I have no colors in Gmail. My Google calendar has no colors just black lines and all appointments are in black and white. It is a holy mess!!!

有幫助嗎?

more options

Could be a problem with High Contrast Mode on Mac. See "New" in the release notes.

Firefox now automatically enables High Contrast Mode when "Increase Contrast" is checked on MacOS in the Accessibility settings.

Make sure you allow pages to choose their own colors.

  • Settings -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

有幫助嗎?

more options

Yes I have the same problems since Firefox 91.0 ( Mac Os Mojave 10.14.6 ) Colors of websites are changed, the buttons on the pages don't exist anymore or not colored , the text on the pages in blue etc. Also in the Firefox menu " privacy " ( the text is not visible ) example on the website Apple : global appearance is not correct ( the text appears in black on a white line on all the pages )

由 Nok31 於 修改

有幫助嗎?

more options

Sad that FF did not test this HOLY MESS before applying it. Based on the comments, you screwed up a lot of people who use it for work. Could have at least waited til the weekend before applying. My pages look like 1990 Windows XP. Way to go Firefox. Reverting back instead of advancing forward. Sorry to say, but I'll be hunting for a new browser.

有幫助嗎?

more options

I got the same problem after Firefox last update two days ago on my iMac Mojave version 10.14.6. I applied the changes recommended by pmaisonpierre to my Preferences and it fixed the problem. Thanks!

有幫助嗎?

more options

I use the 'High Contrast" in the Accessibility Control Panel and at least I can find a work around now by switching it off, but come on Mozilla, this needs to be fixed as this isn't a solution.

有幫助嗎?

more options

pmaisonpierre said

For me the steps below fix the UI problem seen in FFx 91.0 using MacOS (fields showing no color/inappropriate color, windows are transparent/skeletal in appearance where under-window is visible, inability to use some selection buttons) 1. Navigate in Firefox > Preferences > General > Language and Appearance > Colors... 2. In the pop-up panel you'll have 3 choices under "Override the colors specified by the page with your selections above" ==> Select NEVER 3. For the box marked "Use system colors" ==> CHECK IT 4. Quit and restart Firefox 91.0 For me this fixes most webpages -- but fields in some pop-up panels still remain transparent

this worked for me. Thanks. It was driving me crazy all day!

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題