X
點擊此處開啟此網站的行動版。
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

技術支援討論區

Youtube Music skips all the songs. Always.

已張貼

I'm trying to use Youtube Music service from a Windows 10 desktop PC, through Firefox. I always get the following error when trying to reproduce any song: "An error occurred. please try again later." and then it skips to the next song and the next and the next... and falls in a loop without reproducing anything at all. This happens when signed into my Google account and with being logged in. However, it doesn't happen if I open a private window and try to reproduce the same songs or if I sign into my Google account in private mode or if try to use a different browser like Egde, for instance. I have tried to open Firefox with the extensions disabled, but it doesn't make a change. if I try on my laptop on Firefox I get the same thing (I have my Firefox accounts synced). Most probably it's something in Firefox settings, but I cannot find what. I have tried to clear the cache and so, without success.

Any idea? Thanks!

Fernando

I'm trying to use Youtube Music service from a Windows 10 desktop PC, through Firefox. I always get the following error when trying to reproduce any song: "An error occurred. please try again later." and then it skips to the next song and the next and the next... and falls in a loop without reproducing anything at all. This happens when signed into my Google account and with being logged in. However, it doesn't happen if I open a private window and try to reproduce the same songs or if I sign into my Google account in private mode or if try to use a different browser like Egde, for instance. I have tried to open Firefox with the extensions disabled, but it doesn't make a change. if I try on my laptop on Firefox I get the same thing (I have my Firefox accounts synced). Most probably it's something in Firefox settings, but I cannot find what. I have tried to clear the cache and so, without success. Any idea? Thanks! Fernando

被選擇的解決方法

Hmm, your Web Console shows a CORS error for www.youtube.com meaning that the site you are on -- is it music.youtube.com? -- is being denied access to content from www.youtube.com because that is a different origin (host name).

Perhaps this is caused by modifying some settings. Could you check the referring site header settings in case it is one of those:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste referer and pause while the list is filtered

Anything customized (bolded) here?

從原來的回覆中察看解決方案 0
引用

額外的系統細節

已安裝的外掛程式

Plugins: Widevine from Google, OpenH264 Video Codec from Cisco Systems, Inc., Shockwave Flash Extensions: Grammarly, Mega and Notes by Firefox.

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

更多資訊

jscher2000
  • Top 10 Contributor
8950 個解決方法 73359 個答案

Hi Fernando, that's pretty strange.

In Private Windows, Firefox does not use cached files or cookies from regular windows. Did you clear both of those (steps at the end if needed)?

In the past, not sure about now, private windows also would be more accepting of third party cookies since all cookies were temporary anyway. If you are restricting third party cookies in regular windows, you might try modifying those settings. This article will point you to that part of the Options page:

Websites say cookies are blocked - Unblock them


(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Hi Fernando, that's pretty strange. In Private Windows, Firefox does not use cached files or cookies from regular windows. Did you clear both of those (steps at the end if needed)? In the past, not sure about now, private windows also would be more accepting of third party cookies since all cookies were temporary anyway. If you are restricting third party cookies in regular windows, you might try modifying those settings. This article will point you to that part of the Options page: [[Websites say cookies are blocked - Unblock them]] ---- (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that. In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help?
這篇文章有幫助嗎?
引用

提出問題者

Thank you Jeff for taking the time to reply. I agree it's quite strange.

I have cleared cache and cookies and restarted Firefox, but it doesn't seem to affect. Also, tried to change automatic play under permissions, which I had set to block audio and set it to allow audio and video; again, no improvement.

Regarding the level of protection against tracking is Standard.

I have to say the normal Youtube videos play ok, it's only Youtube Music which gives problems.

I think the next step would be to reset Firefox to see if that makes a difference.

Best

Thank you Jeff for taking the time to reply. I agree it's quite strange. I have cleared cache and cookies and restarted Firefox, but it doesn't seem to affect. Also, tried to change automatic play under permissions, which I had set to block audio and set it to allow audio and video; again, no improvement. Regarding the level of protection against tracking is Standard. I have to say the normal Youtube videos play ok, it's only Youtube Music which gives problems. I think the next step would be to reset Firefox to see if that makes a difference. Best
這篇文章有幫助嗎?
引用
Rasmus Kallas 4 個解決方法 38 個答案

Instead of resetting Firefox, create a new profile and test with that: open about:profiles. I suspect it is something to do with auto-play, as I have experienced this with 'block audio' on Tidal, but as it seems it's not it, it might be the user agent.

Google is known to keep 'accidentally' forget other browsers and only make things work on their Google Chrome. To add, they don't really polish their products (see Google Play Music, it barely works) and Youtube Music is a new product.

  1. In a new profile, set Autoplay to allow audio and video ( about:preferences#privacy ).
  2. Install this Add-On: https://addons.mozilla.org/en-US/firefox/addon/user-agent-string-switcher
  3. Go to the add-on settings and make sure it's only Windows and Only Google Chrome.
  4. (you can also do this without the extension) Open up Youtube Music and get to the point it's not working, open the Web Console: Press Ctrl+Shift+K.
  5. Press Ctrl+R to fully reload the page. The console output may give good information.
Instead of resetting Firefox, create a new profile and test with that: open '''about:profiles'''. I suspect it is something to do with auto-play, as I have experienced this with 'block audio' on Tidal, but as it seems it's not it, it might be the user agent. Google is known to keep 'accidentally' forget other browsers and only make things work on their Google Chrome. To add, they don't really polish their products (see Google Play Music, it barely works) and Youtube Music is a new product. # In a new profile, set Autoplay to allow audio and video ( about:preferences#privacy ). # Install this Add-On: https://addons.mozilla.org/en-US/firefox/addon/user-agent-string-switcher # Go to the add-on settings and make sure it's only Windows and Only Google Chrome. # (you can also do this without the extension) Open up Youtube Music and get to the point it's not working, open the Web Console: Press Ctrl+Shift+K. # Press Ctrl+R to fully reload the page. The console output may give good information.

由 Rasmus Kallas 於 修改

這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8950 個解決方法 73359 個答案

有幫助的回覆

ftella said

I have to say the normal Youtube videos play ok, it's only Youtube Music which gives problems.

Hmm, I wonder whether there might be a problem with DRM for those "videos"? The support article on DRM is here: Watch DRM content on Firefox.

''ftella [[#answer-1288579|said]]'' <blockquote>I have to say the normal Youtube videos play ok, it's only Youtube Music which gives problems. </blockquote> Hmm, I wonder whether there might be a problem with DRM for those "videos"? The support article on DRM is here: [[Watch DRM content on Firefox]].
這篇文章有幫助嗎? 1
引用

提出問題者

Thank you Rasmus and Jeff!

I have tried to follow Rasmus' instructions as they offered more options to play with.

I went to about:profiles and created a new profile. Without doing anything else, opened a new Firefox window with it and went to Youtube Music and it worked fine. Ok. Then checked the settings about Autoplay and they were set to "Block Audio".

I went back to my old profile; then installed the User Agent String Switcher extension and tried to set it up as you said. At first I didn't understood how it worked so I didn't set it as it should, so I opened the Console (Ctrl+Shift+K), reloaded the Youtube Music page and got what you can see in the "Console Output" screenshot.

Then went back to the User Agent Switcher extension and managed to set it correctly, (I think) like shown in the "User Agent" screenshot, applied and voilà! It worked. :D

Then went back to the User Agent extension and click on Reset; it automatically got set to Mozilla Firefox only; applied, refreshed the site and got astonished with the result (check "astonished" screenshot). Amazing. It looks very much like you said Rasmus: they make it to work only on Chrome and disregard the rest of browsers.

In any case, there must be something that is preventing it from working in my old profile, as in the new one it worked without having to use the User Agent extension. I can live with the User Agent extension or without Youtube Music (now that I know about this selfish (to say the least) behavior, but it would be nice to learn what makes the difference from one profile to the other. Do you have any idea? Maybe the Console tells you more than me.

Thanks again. Fernando

Thank you Rasmus and Jeff! I have tried to follow Rasmus' instructions as they offered more options to play with. I went to about:profiles and created a new profile. Without doing anything else, opened a new Firefox window with it and went to Youtube Music and it worked fine. Ok. Then checked the settings about Autoplay and they were set to "Block Audio". I went back to my old profile; then installed the User Agent String Switcher extension and tried to set it up as you said. At first I didn't understood how it worked so I didn't set it as it should, so I opened the Console (Ctrl+Shift+K), reloaded the Youtube Music page and got what you can see in the "Console Output" screenshot. Then went back to the User Agent Switcher extension and managed to set it correctly, (I think) like shown in the "User Agent" screenshot, applied and voilà! It worked. :D Then went back to the User Agent extension and click on Reset; it automatically got set to Mozilla Firefox only; applied, refreshed the site and got astonished with the result (check "astonished" screenshot). Amazing. It looks very much like you said Rasmus: they make it to work only on Chrome and disregard the rest of browsers. In any case, there must be something that is preventing it from working in my old profile, as in the new one it worked without having to use the User Agent extension. I can live with the User Agent extension or without Youtube Music (now that I know about this selfish (to say the least) behavior, but it would be nice to learn what makes the difference from one profile to the other. Do you have any idea? Maybe the Console tells you more than me. Thanks again. Fernando
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8950 個解決方法 73359 個答案

選擇的解決方法

Hmm, your Web Console shows a CORS error for www.youtube.com meaning that the site you are on -- is it music.youtube.com? -- is being denied access to content from www.youtube.com because that is a different origin (host name).

Perhaps this is caused by modifying some settings. Could you check the referring site header settings in case it is one of those:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste referer and pause while the list is filtered

Anything customized (bolded) here?

Hmm, your Web Console shows a CORS error for www.youtube.com meaning that the site you are on -- is it music.youtube.com? -- is being denied access to content from www.youtube.com because that is a different origin (host name). Perhaps this is caused by modifying some settings. Could you check the referring site header settings in case it is one of those: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''referer''' and pause while the list is filtered Anything customized (bolded) here?
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17849 個解決方法 161543 個答案

You can try to create a cookie allow exception for involved domains.

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Permissions"
You can try to create a cookie allow exception for involved domains. *Options/Preferences -> Privacy & Security<br>Cookies and Site Data: "Manage Permissions"
這篇文章有幫助嗎?
引用

提出問題者

Thank you both!

When trying the about:config > referer nothing bolded showed.

I then added the two sites (https://music.youtube.com/ and https://www.youtube.com/ and restarted Firefox. Nothing changed in Youtube Music.

I started comparing the about:config of the old session with the one of the new session to see if there's something meaningful. I have not finished yet.

Cheers! Fernando

Thank you both! When trying the about:config > referer nothing bolded showed. I then added the two sites (https://music.youtube.com/ and https://www.youtube.com/ and restarted Firefox. Nothing changed in Youtube Music. I started comparing the about:config of the old session with the one of the new session to see if there's something meaningful. I have not finished yet. Cheers! Fernando
這篇文章有幫助嗎?
引用

提出問題者

Hello again!

I have to say that I probably didn't look for "referer" in the right profile, as I started comparing the whole config with the new profile and I went down to referer, where I found one entry in bold (I think it was referer alone). I went down to referer removing any custom thing in bold that wasn't present in the new profile and stopping from time to time and rebooting to test if it was fixed. It only solved after removing the bolded referer entry.

Thank you all for the help!

Best regards, Fernando

Hello again! I have to say that I probably didn't look for "referer" in the right profile, as I started comparing the whole config with the new profile and I went down to referer, where I found one entry in bold (I think it was referer alone). I went down to referer removing any custom thing in bold that wasn't present in the new profile and stopping from time to time and rebooting to test if it was fixed. It only solved after removing the bolded referer entry. Thank you all for the help! Best regards, Fernando
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題