X
點擊此處開啟此網站的行動版。

技術支援討論區

Fonts displaying as question marks on certain sites (such as the autofill on Google).

已張貼

HI- Recently lots of my fonts have started displaying as question marks on certain sites (such as the autofill on Google). If I uncheck the box in prefs that allows websites to use their own fonts, it's fine. But then the sites look nasty. I've reinstalled Firefox 69.0.2 but its no better. It's a work Apple mac so I can't access all the settings but the issue is only on Firefox. Please don't make me use Chrome! Thanks

HI- Recently lots of my fonts have started displaying as question marks on certain sites (such as the autofill on Google). If I uncheck the box in prefs that allows websites to use their own fonts, it's fine. But then the sites look nasty. I've reinstalled Firefox 69.0.2 but its no better. It's a work Apple mac so I can't access all the settings but the issue is only on Firefox. Please don't make me use Chrome! Thanks
附加的畫面擷圖

被選擇的解決方法

Thanks jbuckingham. I went to the first link and my brain immediately glazed over. :p)

Then I saw these instructions:

"You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level.

   security.sandbox.content.level = 1
   close and restart Firefox to make the change effective. 

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue."

Is that what you did?

從原來的回覆中察看解決方案 0
引用

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:69.0) Gecko/20100101 Firefox/69.0

更多資訊

cor-el
  • Top 10 Contributor
  • Moderator
17757 個解決方法 160593 個答案

有幫助的回覆

This likely means that Firefox isn't able to access the requested font and falls back to a 'last resort' font that shows all glyphs as a '?' or an 'A'.

You can check for sandbox security issues when Firefox has a problem to access fonts installed locally.

You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also:

This likely means that Firefox isn't able to access the requested font and falls back to a 'last resort' font that shows all glyphs as a '?' or an 'A'. You can check for sandbox security issues when Firefox has a problem to access fonts installed locally. *https://wiki.mozilla.org/Security/Sandbox You can set this pref to 2 or 1 on the <b>about:config</b> page to reduce the sandbox security level. *security.sandbox.content.level = 1 *close and restart Firefox to make the change effective. If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox See also: *https://wiki.mozilla.org/Security/Sandbox#Content_Levels
這篇文章有幫助嗎? 2
引用
greg18 0 個解決方法 5 個答案

The same thing happened to me when I upgraded my MacOS to Catalina.

I tried disabling all fonts to try to isolate a conflict and was not able to figure it out. Any help here would be appreciated as it is very annoying.

The same thing happened to me when I upgraded my MacOS to Catalina. I tried disabling all fonts to try to isolate a conflict and was not able to figure it out. Any help here would be appreciated as it is very annoying.
這篇文章有幫助嗎? 0
引用
cor-el
  • Top 10 Contributor
  • Moderator
17757 個解決方法 160593 個答案

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

You can check in the <b>Rules</b> tab in the right panel in the Inspector what font-family is used for selected text. You can check in the <b>Font</b> tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts
這篇文章有幫助嗎? 0
引用
greg18 0 個解決方法 5 個答案

When I hover over ".LastResort" it highlights the question mark boxes. It says what is used is Helvetica, which I have loaded on my computer, but it is not loading for some reason. Any thoughts?

When I hover over ".LastResort" it highlights the question mark boxes. It says what is used is Helvetica, which I have loaded on my computer, but it is not loading for some reason. Any thoughts?
這篇文章有幫助嗎? 1
引用
cor-el
  • Top 10 Contributor
  • Moderator
17757 個解決方法 160593 個答案

This probably means that either the Helvetica font is corrupted or is installed in a location that isn't allowed (whitelisted) in Firefox.

Try to uninstall this Helvetica font via Font Book.

This probably means that either the Helvetica font is corrupted or is installed in a location that isn't allowed (whitelisted) in Firefox. Try to uninstall this Helvetica font via Font Book.
這篇文章有幫助嗎? 0
引用
greg18 0 個解決方法 5 個答案

The system will not allow me to uninstall it. I'm getting the attached message.

The system will not allow me to uninstall it. I'm getting the attached message.
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17757 個解決方法 160593 個答案

Did you make sure that only this one system Helvetica font is installed and not other fonts that report as Helvetica ?

Did you make sure that only this one system Helvetica font is installed and not other fonts that report as Helvetica ?
這篇文章有幫助嗎?
引用
greg18 0 個解決方法 5 個答案

There is also Helvetica Neue installed. But I cannot disable or remove either one.

There is also Helvetica Neue installed. But I cannot disable or remove either one.
這篇文章有幫助嗎?
引用
helen8 0 個解決方法 5 個答案

I am using FontExplorer X Pro on macOS Catalina and also having problems with fonts not displaying properly.

FontExplorer X Pro overides Font Book.

Also noticed numeral nine (9) not displaying properly in documents on the internet!


Any suggestions please as it's driving me crazy.

I am using FontExplorer X Pro on macOS Catalina and also having problems with fonts not displaying properly. FontExplorer X Pro overides Font Book. Also noticed numeral nine (9) not displaying properly in documents on the internet! Any suggestions please as it's driving me crazy.
這篇文章有幫助嗎? 0
引用
CallyCat 1 個解決方法 13 個答案

This started a couple of days ago. Has affected my online email as well as many websites. This issue is rendering firefox completely useless.  :-((

I'm also using a mac and tested on safari and its definitely ff.

I updated in the hopes that would fix it but no such luck. Unfortunately, I am tech-challenged (especially when it comes to macs) & don't feel comfortable trying any of the above suggestions.

If anyone has any updated info, I would appreciate some help.

This started a couple of days ago. Has affected my online email as well as many websites. This issue is rendering firefox completely useless. :-(( I'm also using a mac and tested on safari and its definitely ff. I updated in the hopes that would fix it but no such luck. Unfortunately, I am tech-challenged (especially when it comes to macs) & don't feel comfortable trying any of the above suggestions. If anyone has any updated info, I would appreciate some help.
這篇文章有幫助嗎?
引用
helen8 0 個解決方法 5 個答案

Sorry it's been months and even after an OSX update I still getting the same problem! So unfortunately I have had to switch to using Safari which is sad.


Hope you get a reply from someone…

Sorry it's been months and even after an OSX update I still getting the same problem! So unfortunately I have had to switch to using Safari which is sad. Hope you get a reply from someone…
這篇文章有幫助嗎?
引用
CallyCat 1 個解決方法 13 個答案

Thank you for replying helen. It's really sad & disappointing how mozilla powers that be have allowed firefox to deteriorate over the years with seemingly no regard for their users.

Thank you for replying helen. It's really sad & disappointing how mozilla powers that be have allowed firefox to deteriorate over the years with seemingly no regard for their users.
這篇文章有幫助嗎?
引用

提出問題者

The sandbox security level fix worked for me, and I'm no techie but it was pretty straightforward. Thanks!

The sandbox security level fix worked for me, and I'm no techie but it was pretty straightforward. Thanks!
這篇文章有幫助嗎?
引用
CallyCat 1 個解決方法 13 個答案

選擇的解決方法

Thanks jbuckingham. I went to the first link and my brain immediately glazed over. :p)

Then I saw these instructions:

"You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level.

   security.sandbox.content.level = 1
   close and restart Firefox to make the change effective. 

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue."

Is that what you did?

Thanks jbuckingham. I went to the first link and my brain immediately glazed over. :p) Then I saw these instructions: "You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level. security.sandbox.content.level = 1 close and restart Firefox to make the change effective. If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue." Is that what you did?
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17757 個解決方法 160593 個答案

Hi CallyCat

Did you try to check the font in the Inspector ?

Then at least you know what font this is about.

Are you using an external font manager that might be installing fonts in another location ?


You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Hi CallyCat Did you try to check the font in the Inspector ? Then at least you know what font this is about. Are you using an external font manager that might be installing fonts in another location ? ----- You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/Examine_and_edit_HTML You can check in the <b>Rules</b> tab in the right panel in the Inspector what font-family is used for selected text. You can check in the <b>Font</b> tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/Edit_fonts
這篇文章有幫助嗎?
引用
CallyCat 1 個解決方法 13 個答案

Thank you for your response, Cor-el. No, I didn't. Unfortunately, I know nothing about inspector, html, element button or rules pane. I cannot find any reference in the links as to where/how to access them. I'm sorry I'm so techie illiterate. If I could tell me were to find/access them, then [maybe] I could at least try to follow the directions (even tho they seem like Greek to me).  :-))

Thank you for your response, Cor-el. No, I didn't. Unfortunately, I know nothing about inspector, html, element button or rules pane. I cannot find any reference in the links as to where/how to access them. I'm sorry I'm so techie illiterate. If I could tell me were to find/access them, then [maybe] I could at least try to follow the directions (even tho they seem like Greek to me). :-))
這篇文章有幫助嗎?
引用

有幫助的回覆

CallyCat said

Thanks jbuckingham. I went to the first link and my brain immediately glazed over. :p) Then I saw these instructions: "You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level. security.sandbox.content.level = 1 close and restart Firefox to make the change effective. If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue." Is that what you did?

Yep, that worked for me. I'm no IT expert but followed the instructions and it's been fine ever since. Good luck!

''CallyCat [[#answer-1280935|said]]'' <blockquote> Thanks jbuckingham. I went to the first link and my brain immediately glazed over. :p) Then I saw these instructions: "You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level. security.sandbox.content.level = 1 close and restart Firefox to make the change effective. If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue." Is that what you did? </blockquote> Yep, that worked for me. I'm no IT expert but followed the instructions and it's been fine ever since. Good luck!
這篇文章有幫助嗎? 2
引用
greg18 0 個解決方法 5 個答案

I did the Sandbox fix above and that worked! Praise The Lord!

I did the Sandbox fix above and that worked! Praise The Lord!
這篇文章有幫助嗎?
引用
helen8 0 個解決方法 5 個答案

Over the moon I followed jbuckingham's concise instructions and I'm back with Firefox -- Whoopie. This chap or chapess need a medal, thank you

Over the moon I followed jbuckingham's concise instructions and I'm back with Firefox -- Whoopie. This chap or chapess need a medal, thank you
這篇文章有幫助嗎?
引用
CallyCat 1 個解決方法 13 個答案

Thank you so much, jbuckingham & Cor-el! Changing the sandbox thing to a 1 seems to have worked. I can read my email again AND my email emojis are once again visible.  :-)

'''Thank you so much, jbuckingham & Cor-el!''' Changing the sandbox thing to a 1 seems to have worked. I can read my email again AND my email emojis are once again visible. :-)
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題