X
點擊此處開啟此網站的行動版。

技術支援討論區

Adobe flash will not remain active on our 24h emergency medical web site, need it to alert us to medical data

已張貼

We have medical data coming in 24/7. Our alarm runs off flash. Since the update there isn't a choice to "allow and remember", which is causing us to have to remember to refresh the page constantly. A big problem for the night-staff, problem for the day-staff also as we keep forgeting and data is not alarming. PLEASE HELP!!

We have medical data coming in 24/7. Our alarm runs off flash. Since the update there isn't a choice to "allow and remember", which is causing us to have to remember to refresh the page constantly. A big problem for the night-staff, problem for the day-staff also as we keep forgeting and data is not alarming. PLEASE HELP!!
引用

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

更多資訊

cor-el
  • Top 10 Contributor
  • Moderator
17679 個解決方法 159899 個答案

Do other policies in the file work?

Any related messages in the Browser Console or or the about:policies page ?

  • "3-bar" menu button or Tools -> Web Developer
Do other policies in the file work? Any related messages in the Browser Console or or the about:policies page ? *"3-bar" menu button or Tools -> Web Developer
這篇文章有幫助嗎?
引用
RalphMalph555 0 個解決方法 8 個答案

TyDraniu said

RalphMalph555 said
Generated following code for policies.jason file in distribution folder which does not work....

It is policies.json, not jason. You can check on the about:policies page, if policy is active, or not.

TyDraniu said

RalphMalph555 said
Generated following code for policies.jason file in distribution folder which does not work....

It is policies.json, not jason. You can check on the about:policies page, if policy is active, or not.

Thank you to you, and everyone else who has replied!!!!

As can be seen from the attached pictures, The file name is correct, the file path is correct, the policy is active, but I still get prompt to run flash. I even added in the "backslash" at the end of the URLs.

Still no luck though.

Thanks again to all who are trying to help,

Ralph

''TyDraniu [[#answer-1271023|said]]'' <blockquote> ''RalphMalph555 [[#answer-1271009|said]]'' <blockquote> Generated following code for policies.jason file in distribution folder which does not work.... </blockquote> It is policies.'''json''', not jason. You can check on the ''about:policies'' page, if policy is active, or not. </blockquote> ''TyDraniu [[#answer-1271023|said]]'' <blockquote> ''RalphMalph555 [[#answer-1271009|said]]'' <blockquote> Generated following code for policies.jason file in distribution folder which does not work.... </blockquote> It is policies.'''json''', not jason. You can check on the ''about:policies'' page, if policy is active, or not. </blockquote> Thank you to you, and everyone else who has replied!!!! As can be seen from the attached pictures, The file name is correct, the file path is correct, the policy is active, but I still get prompt to run flash. I even added in the "backslash" at the end of the URLs. Still no luck though. Thanks again to all who are trying to help, Ralph
這篇文章有幫助嗎?
引用
TyDraniu
  • Top 25 Contributor
356 個解決方法 1993 個答案

有幫助的回覆

Remove the last URL.

Remove the last URL.
這篇文章有幫助嗎? 1
引用
jscher2000
  • Top 10 Contributor
8837 個解決方法 72222 個答案

TyDraniu said

Remove the last URL.

That makes sense, since the Allow list is described as a list of "origins" rather than "URLs". https://github.com/mozilla/policy-templates#flashplugin

protocol://hostname/ seems to work for me (screenshots attached).

''TyDraniu [[#answer-1272159|said]]'' <blockquote> Remove the last URL. </blockquote> That makes sense, since the Allow list is described as a list of "origins" rather than "URLs". https://github.com/mozilla/policy-templates#flashplugin protocol://hostname/ seems to work for me (screenshots attached).
這篇文章有幫助嗎? 1
引用
RalphMalph555 0 個解決方法 8 個答案

First things first... a BIG THANK YOU to all who have helped!

jscher2000, your pictures were very helpful, gave me a clue that something was not right. In my picture, shown above, of the "about:policies" page, I could see that I had an active policy for Flash with the default set as "true", but there were no URLs listed with that setting like there were in your picture of the same page.

So I had to find what was different. The policies.json file was correct, or at least I got it correct following the several suggestions on how/what URLs should be used, thanks to TyDraniu and others. (I am also using the "Enterprise Policy Generator" add on offered by Mozilla and found here.. https://addons.mozilla.org/en-US/fire.../enterprise-policy-generator/)

As it turns out I saw a "blurp" somewhere in my research on this issue that said in effect that if you have any other Group policies set to affect Firefox then the policies.json method will not work.

I double checked with our GP group and they said they are not doing anything in GP that would effect Firefox.

So my next step was to go to the registry.

But first a little history on the systems....

The PCs that I am setting up are for student use and are kept "frozen" via "DeepFreze". That means that, once frozen, anything that is done on the system, program or OS updates, for example, are lost when the system reboots. This protects the systems from problems such as malware installation, accidental file deletion or corruption etc. But it also can cause a lot of wasted network bandwidth and user time every time an update, gets installed. So when MS forces updates on you or in my case Firefox, which seems to have an update every few weeks, starts bugging the users about installing it, or on its own, by default, installs an update, it all gets undone on restart and is needless to say a BIG waist of PC and Network resources.

So I looked for ways to stop Firefox from updating or notifying you about updates, since for NO GOOD REASON, they don't provide a simple "Do Not Look for nor Install Updates" option I can easily find and check in the "options" area.

One of the options I found which seems to work very well is a registry adjustment which when combined with a few "about:config" settings stopped Firefox from advertising available updates and downloading and installing them.

The reg setting is as follows....

Go to...

HKLM\SOFTWARE\Policies

Add a new key called "Mozilla", then under that another one called "Firefox". In that key add a DWORD called "DisableAppUpdate" and set its value to 1. (See attached picture)

It is that registry setting that was causing my problem. Once I deleted it, the entire "Mozilla" key and everything under it to be exact, the "policies.json" method started working and I now had the targeted URL listed in the "about:policies" page just like jscher2000 did in his. (See attached picture)

This is the "policie.json" file I finally got to work to let Flash activate without a prompt on the desired web site.

{

 "policies": {
   "FlashPlugin": {
     "Allow": [
       "https://campus.ahima.org/"
     ],
     "Default": true
   }
 }

}

Now I had the problem of Firefox updating itself and/or bugging the user to update it, while the system is frozen, back.

Fortunately, thanks to the "Enterprise Policy Generator" add on which had an option to stop the Firefox updating in it I was able to generate a new "policies.json" file which would handle both of my needs. It is shown below...

{

 "policies": {
   "DisableAppUpdate": true,
   "FlashPlugin": {
     "Allow": [
       "https://campus.ahima.org/"
     ],
     "Default": true
   }
 }

}

Now I have exactly what I need.

Hopefully in the future NO ONE ELSE will every need to do this because Mozilla WILL STOP BABY SITING US and will return the ability to simply check "allow always" for flash, and/or for these "exceptions" which can be pre-programed in to the profile etc. and WILL ADD in a check box or boxes in the "option" area where I can tell it to NEVER EVER UPDATE OR TELL ME ABOUT UPDATES, which is how it should have been designed to start with. DUH

Once again a VERY BIG THANK YOU to all who have helped me get this going!

Ralph

First things first... a BIG THANK YOU to all who have helped! jscher2000, your pictures were very helpful, gave me a clue that something was not right. In my picture, shown above, of the "about:policies" page, I could see that I had an active policy for Flash with the default set as "true", but there were no URLs listed with that setting like there were in your picture of the same page. So I had to find what was different. The policies.json file was correct, or at least I got it correct following the several suggestions on how/what URLs should be used, thanks to TyDraniu and others. (I am also using the "Enterprise Policy Generator" add on offered by Mozilla and found here.. [https://addons.mozilla.org/en-US/firefox/addon/enterprise-policy-generator/]) As it turns out I saw a "blurp" somewhere in my research on this issue that said in effect that if you have any other Group policies set to affect Firefox then the policies.json method will not work. I double checked with our GP group and they said they are not doing anything in GP that would effect Firefox. So my next step was to go to the registry. But first a little history on the systems.... The PCs that I am setting up are for student use and are kept "frozen" via "DeepFreze". That means that, once frozen, anything that is done on the system, program or OS updates, for example, are lost when the system reboots. This protects the systems from problems such as malware installation, accidental file deletion or corruption etc. But it also can cause a lot of wasted network bandwidth and user time every time an update, gets installed. So when MS forces updates on you or in my case Firefox, which seems to have an update every few weeks, starts bugging the users about installing it, or on its own, by default, installs an update, it all gets undone on restart and is needless to say a BIG waist of PC and Network resources. So I looked for ways to stop Firefox from updating or notifying you about updates, since for NO GOOD REASON, they don't provide a simple "Do Not Look for nor Install Updates" option I can easily find and check in the "options" area. One of the options I found which seems to work very well is a registry adjustment which when combined with a few "about:config" settings stopped Firefox from advertising available updates and downloading and installing them. The reg setting is as follows.... Go to... HKLM\SOFTWARE\Policies Add a new key called "Mozilla", then under that another one called "Firefox". In that key add a DWORD called "DisableAppUpdate" and set its value to 1. (See attached picture) It is that registry setting that was causing my problem. Once I deleted it, the entire "Mozilla" key and everything under it to be exact, the "policies.json" method started working and I now had the targeted URL listed in the "about:policies" page just like jscher2000 did in his. (See attached picture) This is the "policie.json" file I finally got to work to let Flash activate without a prompt on the desired web site. { "policies": { "FlashPlugin": { "Allow": [ "https://campus.ahima.org/" ], "Default": true } } } Now I had the problem of Firefox updating itself and/or bugging the user to update it, while the system is frozen, back. Fortunately, thanks to the "Enterprise Policy Generator" add on which had an option to stop the Firefox updating in it I was able to generate a new "policies.json" file which would handle both of my needs. It is shown below... { "policies": { "DisableAppUpdate": true, "FlashPlugin": { "Allow": [ "https://campus.ahima.org/" ], "Default": true } } } Now I have exactly what I need. Hopefully in the future NO ONE ELSE will every need to do this because Mozilla WILL STOP BABY SITING US and will return the ability to simply check "allow always" for flash, and/or for these "exceptions" which can be pre-programed in to the profile etc. and WILL ADD in a check box or boxes in the "option" area where I can tell it to NEVER EVER UPDATE OR TELL ME ABOUT UPDATES, which is how it should have been designed to start with. DUH Once again a VERY BIG THANK YOU to all who have helped me get this going! Ralph
這篇文章有幫助嗎?
引用
TyDraniu
  • Top 25 Contributor
356 個解決方法 1993 個答案

That was easy one :).

Please mark your last post as "Solved".

That was easy one :). Please mark your last post as "Solved".
這篇文章有幫助嗎?
引用
RalphMalph555 0 個解決方法 8 個答案

I don't see a "solved" option, but thanks for the help.

Ralph

I don't see a "solved" option, but thanks for the help. Ralph
這篇文章有幫助嗎?
引用
Chris Peterson 0 個解決方法 15 個答案

I strongly discourage disabling Firefox's auto-updates. You are exposing your computers to security vulnerabilities that get fixed in new releases. You should consider switching from the regular "rapid release" Firefox to the Firefox ESR (Extended Support Release) releases. ESR receives only critical security fixes, no new feature changes.

https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr

Just to be clear: Flash is going away. Adobe, Google, Microsoft, and Mozilla are all planning to remove support for Flash in December 2020. This deadline was announced back in 2017:

http://blogs.adobe.com/conversations/2017/07/adobe-flash-update.html https://www.blog.google/products/chrome/saying-goodbye-flash-chrome/ https://blogs.windows.com/msedgedev/2017/07/25/flash-on-windows-timeline/ https://blog.mozilla.org/futurereleases/2017/07/25/firefox-roadmap-flash-end-life/

If your department depends on a Flash website, your department and your Flash service provider should have started planning a Flash-to-HTML5 migration plan back in 2017.

I strongly discourage disabling Firefox's auto-updates. You are exposing your computers to security vulnerabilities that get fixed in new releases. You should consider switching from the regular "rapid release" Firefox to the Firefox ESR (Extended Support Release) releases. ESR receives only critical security fixes, no new feature changes. https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr Just to be clear: Flash is going away. Adobe, Google, Microsoft, and Mozilla are all planning to remove support for Flash in December 2020. This deadline was announced back in 2017: http://blogs.adobe.com/conversations/2017/07/adobe-flash-update.html https://www.blog.google/products/chrome/saying-goodbye-flash-chrome/ https://blogs.windows.com/msedgedev/2017/07/25/flash-on-windows-timeline/ https://blog.mozilla.org/futurereleases/2017/07/25/firefox-roadmap-flash-end-life/ If your department depends on a Flash website, your department and your Flash service provider should have started planning a Flash-to-HTML5 migration plan back in 2017.

由 Chris Peterson 於 修改

這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17679 個解決方法 159899 個答案

If you look at this article then you also find example code GP for the Flash plugin.

Note that RalphMalph555 isn't the thread creator and thus cannot mark a reply as the solution.

If you look at this article then you also find example code GP for the Flash plugin. *https://github.com/mozilla/policy-templates/blob/master/README.md#flashplugin Note that RalphMalph555 isn't the thread creator and thus cannot mark a reply as the solution.

由 cor-el 於 修改

這篇文章有幫助嗎?
引用
James
  • Top 25 Contributor
  • Moderator
1603 個解決方法 11348 個答案

for in the long run as you cannot use the Flash Plugin forever. https://developer.mozilla.org/en-US/docs/Plugins/Flash_to_HTML5

As said, KCop is the thread starter and not RalphMalph555.

for in the long run as you cannot use the Flash Plugin forever. https://developer.mozilla.org/en-US/docs/Plugins/Flash_to_HTML5 As said, KCop is the thread starter and not RalphMalph555.
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題