搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Why does spell check not work in firefox?

  • 5 回覆
  • 2 有這個問題
  • 11 次檢視
  • 最近回覆由 mtta

more options

Hello,

I have been reading other posts about this but none of the solutions seem to work.

I am using firefox 60.2 esr on linux. I have the British English dicitonary installed and the English (gb) language pack, both enabled. I have the "check spelling as you type" box checked and yet there appears to be no spell check happening.

I have seen people say that you cna check it is enable in context, ie right clicking in a text box there should be a "check spelling" option wiht your languages underneath but I do not have that.

Am I missing anything?

Thanks, Matt

所有回覆 (5)

more options

Separate Security Issue: Update your Flash Player or remove it using these links; Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 32.0.0.114

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

more options

On top of https://addons.mozilla.org/firefox/language-tools/ there is a brief description on what the Dictionaries and Language Packs are used for.

The Language Packs are not used for the inline Spell checker but are used if you want to have one Firefox install and change between User Interface languages.

https://support.mozilla.org/en-US/kb/use-firefox-another-language

more options

I've had this issue for ages also, I've attempted these steps to fix it in the past also, as well as what I found in other support forums on the web. It happened on my main computer (this computer) after patching up to the version that added this function, having to do a system restore to before I did the update to Firefox, then patching back up again (I'm guessing it could be a registry key that might be causing it). Uninstalling & reinstalling Firefox doesn't help, plugins don't appear to be the cause of it (I have 2 other computers with similar plugins that don't have this problem), so far anything I have tried just hasn't fixed it...

more options

So installing the dictionary fixes the issue.

My question now is, I want to install the dictionary with the install of firefox not with my user profile.

How do I generically install this for firefox and not for my profile only?

Thank you