X
點擊此處開啟此網站的行動版。

技術支援討論區

Why is microphone access blocked when I block camera access?

已張貼

In our application, we separately ask users for access to camera and microphone. However, when a user blocks access to camera in the camera permissions dialog by clicking on "Don't allow", this selection get remembered and automatically applied to microphone as well, without prompting the user with a permission dialog for microphone.

At no point there is any mention of microphone when we ask for camera permissions and even when we inspect the page permissions, it states that the camera has been temporarily blocked, but nothing about microphone.

In our application, we separately ask users for access to camera and microphone. However, when a user blocks access to camera in the camera permissions dialog by clicking on "Don't allow", this selection get remembered and automatically applied to microphone as well, without prompting the user with a permission dialog for microphone. At no point there is any mention of microphone when we ask for camera permissions and even when we inspect the page permissions, it states that the camera has been temporarily blocked, but nothing about microphone.
附加的畫面擷圖
WestEnd
  • Top 25 Contributor
60 個解決方法 5379 個答案

How is this a FF Browser issue?

How is this a FF Browser issue?

提出問題者

How is it not? They're browser level permissions, are they not?

How is it not? They're browser level permissions, are they not?
Shadow110 1072 個解決方法 14836 個答案

Hi, it maybe your Extension is not coded right as there was changes to code in ver 60 that broke a few things.

Suggest check that, test on another machine or 2 and determine if it is a bug or not. If you have a bug, file a bug report. https://bugzilla.mozilla.org/ Bug Writing Guidelines : https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines Also for extensions : https://discourse.mozilla.org/

Please let us know if this solved your issue or if need further assistance.

Hi, it maybe your Extension is not coded right as there was changes to code in ver 60 that broke a few things. Suggest check that, test on another machine or 2 and determine if it is a bug or not. If you have a bug, file a bug report. https://bugzilla.mozilla.org/ Bug Writing Guidelines : https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines Also for extensions : https://discourse.mozilla.org/ Please let us know if this solved your issue or if need further assistance.