X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox quantum wrong window behavior in windows 10

已張貼

I have Windows 10 in my work pc and installed firefox quantum however the browser window does not act properly like other OS windows, the following issues I've noticed.

1. I cannot grab the window from the top bar to drag into another screen or move around when fully maximized 2. If I not fully maximize the windows I do not get the arrow to adjust it from the borders. 3. Sometimes If i fully maximize the minimize and maximize buttons disappear. 3. Sometimes if I minimize it I cannot maximize it back ever I have to kill the browser.

I have removed all my extensions and customizations from the browser. Tested in private window mode with same results. Checked the prevent accessibility services from accessing your browser and nothing changed.

I have Windows 10 in my work pc and installed firefox quantum however the browser window does not act properly like other OS windows, the following issues I've noticed. 1. I cannot grab the window from the top bar to drag into another screen or move around when fully maximized 2. If I not fully maximize the windows I do not get the arrow to adjust it from the borders. 3. Sometimes If i fully maximize the minimize and maximize buttons disappear. 3. Sometimes if I minimize it I cannot maximize it back ever I have to kill the browser. I have removed all my extensions and customizations from the browser. Tested in private window mode with same results. Checked the prevent accessibility services from accessing your browser and nothing changed.

被選擇的解決方法

I finally solved it, it's the Theme, Default theme is the one that causes all the issues I had, I switched into light theme and the browser window acts normally now.

從原來的回覆中察看解決方案 16

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 27.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

更多資訊

FredMcD
  • Top 10 Contributor
4259 個解決方法 59631 個答案

I don't know if this will help you.

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json or Localstore.rdf file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\

Search for the above files. Then rename or delete them. Restart Firefox.

I don't know if this will help you. https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt '''xulstore.json''' or '''Localstore.rdf''' file. '''Close Firefox. ''' Open your file browser to this hidden location: * '''Mac: ''' *~/Library/Application Support/Firefox/Profiles * '''Linux: ''' *~/.mozilla/firefox/Profiles * '''Windows: ''' %AppData%\Mozilla\Firefox\Profiles * *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles * '''Windows XP: ''' C:\Documents and Settings\<user>\Application Data<br> \Mozilla\Firefox\Profiles\ Search for the above files. Then rename or delete them. Restart Firefox.

提出問題者

FredMcD said

I don't know if this will help you. https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json or Localstore.rdf file. Close Firefox. Open your file browser to this hidden location:
  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\
Search for the above files. Then rename or delete them. Restart Firefox.

Thanks that partially helped I no longer need to kill the browser and it doesn't crash when I minimize but still I cannot resize the window at my own will and when fully maximized grab it from the top bar to drag it along to other screens

''FredMcD [[#answer-1040877|said]]'' <blockquote> I don't know if this will help you. https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt '''xulstore.json''' or '''Localstore.rdf''' file. '''Close Firefox. ''' Open your file browser to this hidden location: * '''Mac: ''' *~/Library/Application Support/Firefox/Profiles * '''Linux: ''' *~/.mozilla/firefox/Profiles * '''Windows: ''' %AppData%\Mozilla\Firefox\Profiles * *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles * '''Windows XP: ''' C:\Documents and Settings\<user>\Application Data<br> \Mozilla\Firefox\Profiles\ Search for the above files. Then rename or delete them. Restart Firefox. </blockquote> Thanks that partially helped I no longer need to kill the browser and it doesn't crash when I minimize but still I cannot resize the window at my own will and when fully maximized grab it from the top bar to drag it along to other screens

提出問題者

Spoke to soon, after a few minutes longer of usage behavior is the same

Spoke to soon, after a few minutes longer of usage behavior is the same
FredMcD
  • Top 10 Contributor
4259 個解決方法 59631 個答案

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

提出問題者

Safe Mode was worst the window doesn't even load I just get the icon on the task bar, I've also tried uninstalling and reinstall, I got a warning at the first start that if I wanted to completely clean the browser o load the old components from the previous install I did this and the behavior is the same.

I have a virtual machine with other windows 10 same version and I got the same behavior. I'm downloading the latest update for windows 10 maybe that helps but any other pointer with firefox will help.

Safe Mode was worst the window doesn't even load I just get the icon on the task bar, I've also tried uninstalling and reinstall, I got a warning at the first start that if I wanted to completely clean the browser o load the old components from the previous install I did this and the behavior is the same. I have a virtual machine with other windows 10 same version and I got the same behavior. I'm downloading the latest update for windows 10 maybe that helps but any other pointer with firefox will help.
FredMcD
  • Top 10 Contributor
4259 個解決方法 59631 個答案

This is an option;

First, Type about:preferences#advanced<enter> in the address bar. Under Advanced, Select Update.

[v56+] Type about:preferences#general<enter> in the address bar. Select Update.

Select Never Check For Updates.

Also turn off Use a background service to install updates


Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

This is an option; First, Type '''about:preferences#advanced'''<enter> in the address bar. Under '''Advanced, ''' Select '''Update. ''' [v56+] Type '''about:preferences#general'''<enter> in the address bar. Select '''Update. ''' Select '''Never Check For Updates.''' Also turn off '''Use a background service to install updates''' --------------- [https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Install Older Version Of Firefox] {web link} Be sure to read everything here. If you still want to downgrade, look under; '''I still want to downgrade. ''' Click the '''Directory of other versions and languages''' link. Look for the directory of the version that you want. But, remember that '''old versions may have security issues. ''' You should also check out [https://www.mozilla.org/en-US/firefox/organizations/ Firefox; Extended Support Release] {web link} [https://www.mozilla.org/en-US/firefox/organizations/notes/ ESR Notes] [https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ System Requirements]

提出問題者

Unfortunately that doesn't solve my problem I cannot downgrade as my job is to test my web application in new browsers for incompatibilities or issues, which I have not done properly as my browser window doesn't even act in a proper way

Unfortunately that doesn't solve my problem I cannot downgrade as my job is to test my web application in new browsers for incompatibilities or issues, which I have not done properly as my browser window doesn't even act in a proper way

選擇的解決方法

I finally solved it, it's the Theme, Default theme is the one that causes all the issues I had, I switched into light theme and the browser window acts normally now.

I finally solved it, it's the Theme, Default theme is the one that causes all the issues I had, I switched into light theme and the browser window acts normally now.
FredMcD
  • Top 10 Contributor
4259 個解決方法 59631 個答案

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.