搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My Firefox keeps crashing at random times, and it's become more frequent

  • 8 回覆
  • 2 有這個問題
  • 57 次檢視
  • 最近回覆由 John99

more options

I've been using Ubuntu 16.04 LTS and had immediately installed Opera as that was the browser I was used to but I quickly noticed that my cookies would automatically be removed when I shutdown making browsing a problem, so I reverted back to Firefox but it crashes quite often and the interval between the crashing seems to be growing smaller.

所有回覆 (8)

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

While still in Safe Mode,

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.

(Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.)

aboutcrashesFx29
more options

| Report ID | Date Submitted | Time |

| bp-d258d142-5b8d-45ed-a72d-b3b612161210 | 10/12/16 | 16:14 |

| bp-9f32fa81-880e-45af-a768-b9eb92161210 | 10/12/16 | 16:10 |

| bp-c2835654-e2c9-4756-a1a6-c1e3e2161210 | 10/12/16 | 16:07 |

| bp-2639788b-bbdf-4b9d-ac18-7027f2161210 | 10/12/16 | 16:02 |

more options

Was there any trouble in Firefox Safe Mode?

All of those reports show;

Signature: mozilla::gfx::Matrix4x4Typed<T>::TransformBounds<T>

I called for more help.

more options

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

cor-el said

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution. Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window


I am already using Firefox 50.2 and I was already using the default theme when Firefox was crashing.

more options

Hi

You appear to be using a Ubuntu version of Firefox.

I recomend making use of this article to backup your profile and install a Mozilla version of Firefox that you can download from here Mozilla.

由 Seburo 於 修改

more options

I've done that, and so far I've had no crashes, but I'll wait until tomorrow before I mark it as helpful.

more options

I have not got a clue about what causes those crashes. I can make a guess with some crash signatures, or follow the information in related bugs.

Just however posting to say I use Linux and that includes Ubuntu 16.04 and their Canonical Fx50.0.2 works fine for me.