搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox only loads some images, while other browsers load them all

  • 12 回覆
  • 4 有這個問題
  • 19107 次檢視
  • 最近回覆由 Doc_Sheldon

more options

When I checked this morning, one of my WordPress sites only displayed a few of its images in Firefox, although they all display fine in Chrome, Internet Explorer and Vivaldi. I've tried disabling all add-ons, which didn't help. So I backed up my profile and updated to Firefox 49.0.2, which seemed to fix it. But after about 15-20 minutes, I saw that the problem returned. And there aren't even place-holders displaying... the images just aren't there. Also, when I go to the media library, NONE of those images display there, although their descriptions are all present when I click on them. And if I snag their URLs and enter them directly into my address bar, Firefox displays them fine. I had a friend check with FF too, and everything loaded fine. I'd really appreciate any ideas on where this problem might exist. It seems to only be a problem when FF goes to my pages, because the images will load independently. This has me thoroughly stumped! The site is http://topshelfcopy.com/ and the two large images beneath the nav bar are http://topshelfcopy.com/wp-content/uploads/2016/09/Surf1-cropped.jpg and http://topshelfcopy.com/wp-content/uploads/2012/02/banner2a.gif

被選擇的解決方法

Bless you, jscher! That was it! No idea how it happened, but all is well now. Thanks to you and to FredMcD for the help!

從原來的回覆中察看解決方案 👍 0

所有回覆 (12)

more options

Here are screenshots of what I get in Firefox and Chrome

more options

http://kb.mozillazine.org/Images_or_animations_do_not_load https://support.mozilla.org/en-US/kb/fix-problems-images-not-show


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe websites. Are there any problems?

Then restart.

more options

Thanks for that, Fred. I had done most of that already, (but not disabling hardware acceleration). Went through the whole gambit again, but no change. :(

more options

Load the page. Then holding down the <Shift> key, reload the page.

more options

I don't know if it's worth mentioning or not, but my images on that site are jpg, png and gif... there doesn't seem to be any pattern in which ones don't display.

more options

Did a hard refresh, too... no dice!

more options

Please provide a public link to the page.

more options

It's in my original post... http://topshelfcopy.com/

more options

I also just noticed that some of the few images that DID display on one of the pages (http://topshelfcopy.com/client-testimonials/) have disappeared now, although two had displayed earlier this morning. So it seems to be sporadic.

more options

I've also checked a number of other sites and I don't find any images failing to display on any of them.

more options

There's only one way I can reproduce your screenshot. Could you return to the Page Info dialog, Media panel, and check whether image permission is denied for images from your site? See the attached screenshot for reference.

more options

選擇的解決方法

Bless you, jscher! That was it! No idea how it happened, but all is well now. Thanks to you and to FredMcD for the help!