X
點擊此處開啟此網站的行動版。

技術支援討論區

Facebook appears as encrypted text

已張貼

I use Facebook every day via this PC (Windows 10 & Firefox). . but as of yesterday the site started appearing as shown in the attached clip of a small section of the screen. I guess what's happening is the encrypted page is not being decrypted. .but why and how do I get it working again ? btw, I have no problem viewing the same web site (Facebook) on my Android device (Facebook app) and on my Windows 7 laptop, also via Firefox.

Firefox is v46.0.1

Oh. just in case the image doesn't upload, here's a small clip of the screen contents ! :-( : ‡þ䯟«þ÷çËz{Aê@@Œ¸Î3ƇÔM’MÇrþ/•ÿ %²hz ÞeêZ“ëš'Õ†xÆ R©†%¾ÅºJOx•hÑEG’ßÇ/®a&e´Ø V!®±07¾ó3ëŸýö‚ׯچ41™Æí¼³;1q~àp/²‘—ÆvQ£^EzÑ ^”¿œ QÆÝÚÚÝZ>J[¶±Ð~žÔëíÆâõßaý{£uª¥±lÜ„aµ«ì)ÚõÓ‹Ø6Dä¼/؈‚‚Uѱ/ºg«¿œ¹Ñ"˜U*áX<;¶A„zw;Ò‰5€†ïÿïàÔØU±J|5f8¥_Vl£†³Œ/œ“*Ïhñ-艇´e¢tà£ÏÒÏ

I use Facebook every day via this PC (Windows 10 & Firefox). . but as of yesterday the site started appearing as shown in the attached clip of a small section of the screen. I guess what's happening is the encrypted page is not being decrypted. .but why and how do I get it working again ? btw, I have no problem viewing the same web site (Facebook) on my Android device (Facebook app) and on my Windows 7 laptop, also via Firefox. Firefox is v46.0.1 Oh. just in case the image doesn't upload, here's a small clip of the screen contents ! :-( : ‡þ䯟«þ÷çËz{Aê@@Œ¸Î3ƇÔM’MÇrþ/•ÿ %²hz ÞeêZ“ëš'Õ†xÆ R©†%¾ÅºJOx•hÑEG’ßÇ/®a&e´Ø V!®±07¾ó3ëŸýö‚ׯچ41™Æí¼³;1q~àp/²‘—ÆvQ£^EzÑ ^”¿œ QÆÝÚÚÝZ>J[¶±Ð~žÔëíÆâõßaý{£uª¥±lÜ„aµ«ì)ÚõÓ‹Ø6Dä¼/؈‚‚Uѱ/ºg«¿œ¹Ñ"˜U*áX<;¶A„zw;Ò‰5€†ïÿïàÔØU±J|5f8¥_Vl£†³Œ/œ“*Ïhñ-艇´e¢tà£ÏÒÏ

被選擇的解決方法

It's a complicated brew, but from reading cor-el's references it seems:

  • Firefox 44+ accepts a new kind of encoding (compression) called Brotli for secure connections
  • Facebook turned on Brotli encoding last night
  • When Kaspersky passes through the filtered Facebook content, it removes the indication that the site uses Brotli encoding, so Firefox seems to treat it as unencoded

As a workaround, you can set Firefox NOT to tell sites it can read Brotli encoding. I suspect this won't slow your browsing down very much, and it will allow you to use Kaspersky filtering if you like. Please try this (I can't test it myself):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste enco and pause while the list is filtered

(3) Double-click the network.http.accept-encoding.secure preference and edit as follows: delete the , br from the end so it just reads gzip, deflate like the preference above it in the list, and then click OK

Reference for this preference change working for another Kaspersky user: https://twitter.com/lildingus/status/730493386461982720

從原來的回覆中察看解決方案 12

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • GEPlugin
  • Google Update
  • Picasa plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 21.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.5.155
  • 5.1.41212.0
  • iTunes Detector Plug-in

應用程式

  • Firefox 46.0.1
  • 使用者代理:Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/46.0.1/WINNT/en-GB/

擴充套件

  • All-in-One Sidebar 0.7.28 ({097d3191-e6fa-4728-9826-b533d755359d})
  • Duplicate Tabs Closer 2.1.3 (jid0-RvYT2rGWfM8q5yWxIxAHYAeo5Qg@jetpack)
  • Firefox Hello 1.2.6 (loop@mozilla.org)
  • Kaspersky Protection 4.6.3-7 (light_plugin_ACF0E80077C511E59DED005056C00008@kaspersky.com)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0 (firefox@getpocket.com)
  • Tab Groups 1.0.2 (tabgroups@quicksaver)
  • Tab Groups Helper 1.0.24 (tabgroupshelper@kevinallasso.org)
  • Ebay Shopping Assistant 2.3 ({22d8bbb4-3f5f-40da-8fe1-4e1635f22fc4}) (Inactive)
  • Shop and Give reminder 2.2.2.1 ({63F01A06-949F-434C-BFDF-9D54A5426C74}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: AMD Radeon(TM) R7 Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x1313
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 3-21-2016
  • driverDate2:
  • driverVersion: 16.150.2211.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon(TM) R7 Graphics Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

修改過的偏好設定

其他

  • User JS: 是
  • 輔助功能: 否
jscher2000
  • Top 10 Contributor
8689 個解決方法 71030 個答案

有幫助的回覆

I think someone else just reported the same kind of thing: https://support.mozilla.org/questions/1122454

Could you try "the usual" if you haven't already:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page (and log into FB again). Does that help?


If that doesn't help, could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

I think someone else just reported the same kind of thing: https://support.mozilla.org/questions/1122454 Could you try "the usual" if you haven't already: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies" * (menu bar) Tools > Page Info > Security > "View Cookies" * click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually. Then try reloading the page (and log into FB again). Does that help? ---- If that doesn't help, could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? (More info: [[Troubleshoot Firefox issues using Safe Mode]])
jscher2000
  • Top 10 Contributor
8689 個解決方法 71030 個答案

Do you want to experiment with turning off the Kaspersky feature of filtering secure browser connections, or is that already disabled? See the Kaspersky section of this article: How to troubleshoot security error codes on secure websites.

Do you want to experiment with turning off the Kaspersky feature of filtering secure browser connections, or is that already disabled? See the Kaspersky section of this article: [[How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites]].

提出問題者

I thought that this had solved my problem because when I started Firefox in safe mode I saw the Facebook login page OK. However as soon as I actually logged in to Facebook all I saw was gobbledegook again. So problem not solved !

I thought that this had solved my problem because when I started Firefox in safe mode I saw the Facebook login page OK. However as soon as I actually logged in to Facebook all I saw was gobbledegook again. So problem not solved !
cor-el
  • Top 10 Contributor
  • Moderator
17468 個解決方法 157871 個答案

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History").

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

Can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History"). Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. Can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again.
jscher2000
  • Top 10 Contributor
8689 個解決方法 71030 個答案

Hi Sn0flake, did you try turning off the Kaspersky filtering? That seems to have worked in a few other threads about FB gibberish.

Hi Sn0flake, did you try turning off the Kaspersky filtering? That seems to have worked in a few other threads about FB gibberish.
cor-el
  • Top 10 Contributor
  • Moderator
17468 個解決方法 157871 個答案

See also:


Bug 1271875 - Kaspersky's scanning of encrypted connections causes garbled Facebook page

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

See also: *https://forum.kaspersky.com/index.php?s=bbdfcf797a91bc90230472c52c4b103e&showtopic=351027 ---- Bug 1271875 - Kaspersky's scanning of encrypted connections causes garbled Facebook page <i>Please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>

由 cor-el 於 修改

提出問題者

Hi, yes switching off the Kaspersky filtering did solve the problem. So the question is, since I have had Kaspersky installed for a year and a half now (& several months of Kasp 2016), why did it suddenly go wrong last night for bothe me and the other questionner ? Did something change on th FB webste or in Firefox. . or . . ? btw thanks for your quick responses. :-)

Hi, yes switching off the Kaspersky filtering did solve the problem. So the question is, since I have had Kaspersky installed for a year and a half now (& several months of Kasp 2016), why did it suddenly go wrong last night for bothe me and the other questionner ? Did something change on th FB webste or in Firefox. . or . . ? btw thanks for your quick responses. :-)
jscher2000
  • Top 10 Contributor
8689 個解決方法 71030 個答案

選擇的解決方法

It's a complicated brew, but from reading cor-el's references it seems:

  • Firefox 44+ accepts a new kind of encoding (compression) called Brotli for secure connections
  • Facebook turned on Brotli encoding last night
  • When Kaspersky passes through the filtered Facebook content, it removes the indication that the site uses Brotli encoding, so Firefox seems to treat it as unencoded

As a workaround, you can set Firefox NOT to tell sites it can read Brotli encoding. I suspect this won't slow your browsing down very much, and it will allow you to use Kaspersky filtering if you like. Please try this (I can't test it myself):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste enco and pause while the list is filtered

(3) Double-click the network.http.accept-encoding.secure preference and edit as follows: delete the , br from the end so it just reads gzip, deflate like the preference above it in the list, and then click OK

Reference for this preference change working for another Kaspersky user: https://twitter.com/lildingus/status/730493386461982720

It's a complicated brew, but from reading cor-el's references it seems: * Firefox 44+ accepts a new kind of encoding (compression) called Brotli for secure connections * Facebook turned on Brotli encoding last night * When Kaspersky passes through the filtered Facebook content, it removes the indication that the site uses Brotli encoding, so Firefox seems to treat it as unencoded As a workaround, you can set Firefox NOT to tell sites it can read Brotli encoding. I suspect this won't slow your browsing down very much, and it will allow you to use Kaspersky filtering if you like. Please try this (I can't test it myself): (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''enco''' and pause while the list is filtered (3) Double-click the '''network.http.accept-encoding.secure''' preference and edit as follows: delete the ''', br''' from the end so it just reads '''gzip, deflate''' like the preference above it in the list, and then click OK ''Reference for this preference change working for another Kaspersky user:'' https://twitter.com/lildingus/status/730493386461982720

由 jscher2000 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17468 個解決方法 157871 個答案
See also: *https://developer.mozilla.org/en-US/Firefox/Releases/44#HTTP *https://developer.mozilla.org/Web/HTTP/Headers/Content-Encoding

提出問題者

Yes, that works thanks again. I removed the ", br", switched on Kaspersky filtering, re-booted & FB reads OK.

Incidentally I have another problem . . maybe I should log it separately . . For some time I have been having problems with the Windows 10 "Start Menu" crashing - the problem is intermittent - but a knock-on effect is that when start up Firefox, I get a message that says "Firefox is not your default browser" and then I am taken to the Windows settings 'window' which shows clearly that FireFox IS my default browser !. . . See : http://answers.microsoft.com/en-us/windows/forum/windows_10-performance/windows-10-critical-error-your-start-menu-isnt/f1d2762d-ea75-47b3-a858-0d8567f84c5a . . I'll try the MS fix first

Yes, that works thanks again. I removed the ", br", switched on Kaspersky filtering, re-booted & FB reads OK. Incidentally I have another problem . . maybe I should log it separately . . For some time I have been having problems with the Windows 10 "Start Menu" crashing - the problem is intermittent - but a knock-on effect is that when start up Firefox, I get a message that says "Firefox is not your default browser" and then I am taken to the Windows settings 'window' which shows clearly that FireFox IS my default browser !. . . See : http://answers.microsoft.com/en-us/windows/forum/windows_10-performance/windows-10-critical-error-your-start-menu-isnt/f1d2762d-ea75-47b3-a858-0d8567f84c5a . . I'll try the MS fix first