X
點擊此處開啟此網站的行動版。

技術支援討論區

How to prevent the "are you sure you want to leave this page?" prompt on Facebook?

已張貼

I'm using Firefox 35.0.1. If I make a post on my Facebook timeline that contains a link, when I hit "Post" and the page goes to refresh to add my post to my timeline, it asks if I'm sure I want to leave the page. I've seen that messages on some sites before, for example, if I'm on a forum and I write a post and go to leave the page before hitting submit, it'll ask me that, but I've never seen it on Facebook until a couple of days ago.

Is there any way to turn this message off? Or even better, can it be turned off just on Facebook? Thanks.

I'm using Firefox 35.0.1. If I make a post on my Facebook timeline that contains a link, when I hit "Post" and the page goes to refresh to add my post to my timeline, it asks if I'm sure I want to leave the page. I've seen that messages on some sites before, for example, if I'm on a forum and I write a post and go to leave the page before hitting submit, it'll ask me that, but I've never seen it on Facebook until a couple of days ago. Is there any way to turn this message off? Or even better, can it be turned off just on Facebook? Thanks.

被選擇的解決方法

hi DJSigma, to my knowledge you can only disable that behaviour globally: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named dom.disable_beforeunload. double-click it and change its value to true...

從原來的回覆中察看解決方案 9

額外的系統細節

已安裝的外掛程式

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • NPWLPG
  • Shockwave Flash 16.0 r0
  • 5.1.31211.0
  • SumatraPDF Browser Plugin

應用程式

  • Firefox 35.0.1
  • 使用者代理:Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/35.0.1/WINNT/en-US/

擴充套件

  • Adblock Edge 2.1.8 ({fe272bd1-5f76-4ea4-8501-a05d35d823fc})
  • Add to Search Bar 2.8 (add-to-searchbox@maltekraus.de)
  • All-in-One Sidebar 0.7.25 ({097d3191-e6fa-4728-9826-b533d755359d})
  • azid - Amazon Zoom Image Downloader 0.9.3 (azid@craue.de)
  • Copy Link Text 1.7.1 (copylinktext@brett.zamir)
  • Duplicate in Tab Context Menu 1.0.9 (DuplicateInTabContext@schuzak.jp)
  • FireGestures 1.8.7 (firegestures@xuldev.org)
  • Imgur Uploader 1.0.6 (giorgio@gilestro.tk)
  • Open in IE 1.4 (openinie@wittersworld.com)
  • Quick Context Search 1.5.2 (quickcontextsearch@pf)
  • Secure Login 1.0.6 (secureLogin@blueimp.net)
  • URL Link 2.04.3 ({139a120b-c2ea-41d2-bf70-542d9f063dfd})
  • ZenMate Security & Privacy VPN 4.1.7 (firefox@zenmate.com)
  • IDM CC 7.3.93 (mozilla_cc@internetdownloadmanager.com) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: NVIDIA GeForce GTX 780 Ti
  • adapterDescription2:
  • adapterDeviceID: 0x100a
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 3072
  • adapterRAM2:
  • adapterSubsysID: 29831462
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17415
  • driverDate: 1-9-2015
  • driverDate2:
  • driverVersion: 9.18.13.4725
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 780 Ti Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
philipp
  • Top 25 Contributor
  • Moderator
5343 個解決方法 23599 個答案

選擇的解決方法

hi DJSigma, to my knowledge you can only disable that behaviour globally: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named dom.disable_beforeunload. double-click it and change its value to true...

hi DJSigma, to my knowledge you can only disable that behaviour globally: enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''dom.disable_beforeunload'''. double-click it and change its value to '''true'''...

由 philipp 於 修改

有幫助的回覆

Thanks, philipp! I guess Facebook must have made some changes to their code, but I'll make the change you suggested and see how it goes.

Thanks, philipp! I guess Facebook must have made some changes to their code, but I'll make the change you suggested and see how it goes.