X
點擊此處開啟此網站的行動版。

技術支援討論區

Can we change the interface language of Firefox?

已張貼

Hi, I am not able to find a way to change the interface language of Firefox. Is there any way to change the language that Firefox interface/GUI is displayed.

Is downloading and installing the Firefox with the language the only solution?

Hi, I am not able to find a way to change the interface language of Firefox. Is there any way to change the language that Firefox interface/GUI is displayed. Is downloading and installing the Firefox with the language the only solution?

被選擇的解決方法

rat wrote:

Is downloading and installing the Firefox with the language the only solution?

It's the preferred solution.

If you need to switch between different interface languages,

  1. Install the language pack for the desired languages.
  2. Type about:config into the address bar and press Enter.
  3. To bypass the warning, press the big button labeled "I'll be careful, I promise!".
  4. In the search box, paste intl.locale.matchOS
  5. In the search results, if intl.locale.matchOS is set to true, double-click it to set its value to false.
  6. In the search box, paste general.useragent.locale
  7. In the search results, double-click general.useragent.locale and set its value to the desired language.
  8. Restart Firefox for the change to take effect.

If you need to switch languages frequently, you may want to get an add-on like Simple Locale Switcher.

從原來的回覆中察看解決方案 15

額外的系統細節

已安裝的外掛程式

  • LastPass Plugin
  • Shockwave Flash 11.2 r202
  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • DivX Web Player version 1.4.0.233
  • The Videos 3.10.1 plugin handles video and audio streams.

應用程式

  • Firefox 31.0
  • 使用者代理:Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/31.0/Linux/en-US/

擴充套件

  • Adblock Plus 2.6.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Customizable Shortcuts 0.6.2 (customizable-shortcuts@timtaubert.de)
  • LastPass 3.1.54 (support@lastpass.com)
  • Lightbeam 1.0.10.2 (jid1-F9UJ2thwoAm5gQ@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • ChatZilla 0.9.90.1 ({59c81df5-4b7a-477b-912d-4e0fdf64e5f2}) (Inactive)
  • Clear Console 1.10 (clearConsole@penzil.com) (Inactive)
  • DownloadHelper 4.9.24 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d}) (Inactive)
  • Flash and Video Download 1.61 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a}) (Inactive)
  • GNOME Theme Tweak 31.1 ({05f1cdaa-7474-43fa-9f69-c697555f4ea8}) (Inactive)
  • Greasemonkey 2.2 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781}) (Inactive)
  • Media Player for YouTube™ 0.2.9 (jid1-dgnICqQgv2AUZw@jetpack) (Inactive)
  • Shumway 0.9.2718 (shumway@research.mozilla.org) (Inactive)
  • Terms of Service; Didn’t Read 0.4 (jid0-3GUEt1r69sQNSrca5p8kx9Ezc3U@jetpack) (Inactive)
  • YouTube ALL HTML5 2.1.3 (jid1-qj0w91o64N7Eeg@jetpack) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Ironlake Mobile
  • adapterDeviceID: Mesa DRI Intel(R) Ironlake Mobile
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 2.1 Mesa 10.1.5
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Ironlake Mobile
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

修改過的偏好設定

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 2
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140730101922
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20140730101922
  • browser.startup.homepage_override.mstone: 31.0
  • dom.mozApps.maxLocalId: 1006
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 31.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1409932596
  • places.history.expiration.transient_current_max_pages: 75369
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.disable_button.openCertManager: False
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1407275035

其他

  • User JS: 否
  • 輔助功能: 否
Gingerbread Man 403 個解決方法 1537 個答案

選擇的解決方法

rat wrote:

Is downloading and installing the Firefox with the language the only solution?

It's the preferred solution.

If you need to switch between different interface languages,

  1. Install the language pack for the desired languages.
  2. Type about:config into the address bar and press Enter.
  3. To bypass the warning, press the big button labeled "I'll be careful, I promise!".
  4. In the search box, paste intl.locale.matchOS
  5. In the search results, if intl.locale.matchOS is set to true, double-click it to set its value to false.
  6. In the search box, paste general.useragent.locale
  7. In the search results, double-click general.useragent.locale and set its value to the desired language.
  8. Restart Firefox for the change to take effect.

If you need to switch languages frequently, you may want to get an add-on like Simple Locale Switcher.

''rat wrote:'' Is downloading and installing the Firefox with the language the only solution? It's the preferred solution. If you need to switch between different interface languages, # Install the language pack for the desired languages. #* https://addons.mozilla.org/firefox/language-tools/ # Type ''about:config'' into the address bar and press Enter. # To bypass the warning, press the big button labeled "I'll be careful, I promise!". # In the search box, paste ''intl.locale.matchOS'' # In the search results, if ''intl.locale.matchOS'' is set to '''true''', double-click it to set its value to '''false'''. # In the search box, paste ''general.useragent.locale'' # In the search results, double-click ''general.useragent.locale'' and set its value to the desired language. # Restart Firefox for the change to take effect. If you need to switch languages frequently, you may want to get an add-on like Simple Locale Switcher. * https://addons.mozilla.org/firefox/addon/simple-locale-switcher/

提出問題者

Thanks for the reply.

Thanks for the reply.
ffw62 6 個解決方法 85 個答案

有幫助的回覆

As for ME.. it did not work. 1. for English US there is no language pack to be downloaded, likely it is already installed. Available only: English (US) English (US) Install Dictionary (247.6 kB)

2. I did set : intl.locale.matchOS to True 3. I did change: general.useragent.locale to EN 4. Under Options Contents I even moved language [en] to top

Closed/restarted Firefox (v33.0) Interface language remained Dutch.

Yes, Google changed, but not the Firefox GUI (like settings, etc) =

As for ME.. it did not work. 1. for English US there is no language pack to be downloaded, likely it is already installed. Available only: English (US) English (US) Install Dictionary (247.6 kB) 2. I did set : intl.locale.matchOS to True 3. I did change: general.useragent.locale to EN 4. Under Options Contents I even moved language [en] to top Closed/restarted Firefox (v33.0) Interface language remained Dutch. Yes, Google changed, but not the Firefox GUI (like settings, etc) =
cor-el
  • Top 10 Contributor
  • Moderator
17412 個解決方法 157274 個答案

Changing the user agent won't help if you do not have that language version of Firefox installed. You need to install the en-US Firefox version.

You can find the full version of the current Firefox 33.0.3 release in all languages and for all Operating Systems here:

Changing the user agent won't help if you do not have that language version of Firefox installed. You need to install the en-US Firefox version. You can find the full version of the current Firefox 33.0.3 release in all languages and for all Operating Systems here: *https://www.mozilla.org/en-US/firefox/all/
ffw62 6 個解決方法 85 個答案

Thanks!

Well, then the '2nd option' in the first reply under 'If you need to switch between different interface languages' - I guess this is not entirely correct then?

Maybe one day that option will indeed be available, i.e. without having to install a totally different new Firefox...  :-)

Thanks! Well, then the '2nd option' in the first reply under 'If you need to switch between different ''interface languages''' - I guess this is not entirely correct then? Maybe one day that option will indeed be available, i.e. without having to install a totally different new Firefox... :-)
cor-el
  • Top 10 Contributor
  • Moderator
17412 個解決方法 157274 個答案

This only applies to language packs that are installed in the current Firefox profile folder if this isn't about the locale that you have installed. If you have a Dutch (nl) Firefox version and no English language pack(s) then you can't switch to the English language. You would either have to install the English Firefox version or an en-US language pack if you want to be able to switch between languages. If you have ended up with the wrong language for some reason, possibly after an update, then you need to install a full version of your preferred language.

This only applies to language packs that are installed in the current Firefox profile folder if this isn't about the locale that you have installed. If you have a Dutch (nl) Firefox version and no English language pack(s) then you can't switch to the English language. You would either have to install the English Firefox version or an en-US language pack if you want to be able to switch between languages. If you have ended up with the wrong language for some reason, possibly after an update, then you need to install a full version of your preferred language.
ffw62 6 個解決方法 85 個答案

Please would you have a look at the above screenshot, a few postings back. I am not familiar with this, but for me... it looks like English is available (?) Then again, I may very well be mistaken.

Regretfully I can not download EN language pack, it is not listed. Other language packs are listed and downloadable alright, not English. I can download a English US Dictionary pack only though. (That is the reason for me to assume English is already installed?)

Thanks. -

Please would you have a look at the above screenshot, a few postings back. I am not familiar with this, but for me... it looks like English is available (?) Then again, I may very well be mistaken. Regretfully I can not download EN language pack, it is not listed. Other language packs are listed and downloadable alright, not English. I can download a English US Dictionary pack only though. (That is the reason for me to assume English is already installed?) Thanks. -

由 ffw62 於 修改