Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox搜索工具栏无法保存设置

  • 6 回覆
  • 1 有這個問題
  • 38 次檢視
  • 最近回覆由 cor-el

more options

自定义添加了若干搜索引擎于Firfox搜索工具栏内,想根据个人使用频率高低调整这些搜索引擎的排序,但是firefox无法保存排序设置,点确认按钮后没有反应。(经测试,移动1-2个搜索引擎顺序偶尔可保存到位,但firefox重启之后又退回到原来默认的顺序。将十几个搜索引擎顺序全部重新调整时无法通过确认按钮保存。)

自定义添加了若干搜索引擎于Firfox搜索工具栏内,想根据个人使用频率高低调整这些搜索引擎的排序,但是firefox无法保存排序设置,点确认按钮后没有反应。(经测试,移动1-2个搜索引擎顺序偶尔可保存到位,但firefox重启之后又退回到原来默认的顺序。将十几个搜索引擎顺序全部重新调整时无法通过确认按钮保存。)

所有回覆 (6)

more options

This might be a problem with the search.json file in the Firefox profile folder of possibly with the prefs.js file.

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program and the searchplugins folder in the Firefox profile folder.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

Thanks! Appriciate your solutions, but it seems that the problem still not be solved.

I've deleted the search.json file and the search-metadata.json file from Firefox profile folder and reactivate to do settings with search toolbar. Again, the search engines didn't follow the order with my settings. Sad...

more options
more options

I would suspect the organize-search-engines extension as the prime suspect for causing this issue.

I don't know if this extension stores the configuration as a pref in prefs.js (see about:config) or otherwise in the Firefox profile folder.

more options

Thanks. If the extension did not store the configuration, what are the solutions for this problem? I've also tried unistall the 3 add-ons related to search engines but the original search tool bar also cannot store the configuration itself.

I remembered that my toolbar was all right until recently I updated my firefox version (cant't remember from which to the recent version 30.0)

more options

You can check for problems with preferences.

Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.


Try to create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem