在 Firefox 中開啟 PDF 檔案

Firefox 內建 PDF 檢視器,您可以在瀏覽視窗中開啟 PDF 檔案。本文將教您如何使用內建 PDF 檢視器,如何使用其他 PDF 檢視器以及如何解決可能遭遇到的常見問題。

使用內建 PDF 檢視器

Firefox 內建 PDF 檢視器,您不需要使用外掛程式就可以檢視幾乎所有在網路上的 PDF 檔案。預設內建的 PDF 檢視器是開啟的。

PDF JS

PDF 檢視器工具列功能

  • 檢視文件縮圖或大綱 - 左邊的浮動按鈕會開啟文件頁面縮圖的側邊欄。有些文件會有大綱模式。這會讓瀏覽長文件時更容易。
    PDF Thumbnails
  • 上一頁、下一頁或是直接跳到特定頁 - 您可以使用箭頭前往文件的上下頁,或是輸入您想前往頁面的頁數。
    PDF Pager
  • 切換文件的尺寸 - 使用 + 和 - 鈕放大和縮小,或是從下拉選單中選擇一個縮放設定。
    PDF Zoom
  • 全螢幕或簡報模式 - 點擊全螢幕鈕允許 PDF 檔案使用整個螢幕。按 ESC 離開全螢幕模式。
    PDF Fullscreen
  • 列印 - 點擊列印鈕開啟列印設定對話框。
    PDF Print
  • 下載 - 點擊下載鈕儲存此 PDF 檔案至您的電腦或是使用 PDF 閱讀軟體開啟。
    PDF Download
  • 複製目前檢視的內容 - 單點右鍵點選並按住 Ctrl 目前檢視的內容鈕,可在其他分頁或視窗中開啟目前檢視的內容。
    PDF Copy

PDF 檢視器鍵盤快捷鍵

指令 快捷鍵
下一頁 NK
上一頁 PJ
放大 Ctrl + +command + +
縮小 Ctrl + -command + -
自動縮放 Ctrl + 0command + 0
順時針旋轉 R
逆時針旋轉 Shift + R

PDF 檢視器疑難排除

  • 對於某些 PDF 檔案,PDF 檢視器 可能無法正常呈現其中的文字、顏色或開啟整份檔案。若某些 PDF 檔案無法正常顯示或完全空白,點擊文件標題右側的下載鈕,使用電腦中預設的 PDF 程式來開啟。

使用其他 PDF 檢視器

若您不想使用內建 PDF 檢視器,您可以使用外掛程式在 Firefox 中檢視 PDF 檔案,或是使用外部應用程式在 Firefox 外檢視 PDF 檔案。更多資訊,請參閱 如何停用內建的PDF檢視器,並使用其他檢視器

從內建 PDF 檢視器切換為其他 PDF 檢視器:

  1. 按一下 Firefox 視窗最上方的 Firefox 按鈕,然後點選 選項點開 Firefox 視窗上方的 工具 選單,然後點選 選項在選單列上點選 Firefox 選單,然後選擇 偏好設定…點開 Firefox 視窗上方的 編輯 選單,然後點選 偏好設定

    點擊選單按鈕 New Fx Menu 並選擇 選項偏好設定

  2. 選擇 應用程式 面板
  3. 在清單中尋找可攜式文件格式(PDF),點擊選取它。
  4. 點擊此列中動作欄的下拉箭頭。當您使用內建 PDF 檢視器時,此動作欄會顯示在 Firefox 中預覽
    • 使用外部應用程式檢視 PDF 檔案,選擇欄位中您想使用的 PDF 應用程式,像是使用預覽程式使用 Adobe Reader
    • 使用外掛程式在 Firefox 中檢視 PDF 檔案,選擇使用你選用的PDF 瀏覽外掛程式名稱(在 Firefox 開啟)
警告:「Adobe Acrobate NPAPI 外掛程式」已知會在 Firefox 造成問題。更多細節請參閱 PDF files are blank or cause an error message on Mac

使用 PDF 外掛檢視器

提醒:您無法在新版 64 位元 Firefox 中使用 PDF 外掛程式,只有少數的外掛程式有支援。請參閱 How do I tell if I have the 32-bit or 64-bit Firefox?

您可以使用 PDF 外掛程式像是 Adobe ReaderNitro PDF ReaderSumatra PDF像是 Adobe ReaderMozPluggerKParts plugin,任何有用的外掛程式,在 Firefox 中檢視 PDF 檔案。如果您已安裝了 PDF 瀏覽外掛程式但是 PDF 檔案無法在 Firefox 中顯示,請嘗試以下解決方法:

啟用 PDF 外掛程式

您的 PDF 外掛程式可能在 Firefox 中被停用。若要啟用它:

  1. 在 Firefox 視窗頂端點擊 Firefox 按鈕在選單列點選 工具 選單在 Firefox 視窗頂端點選 工具 選單,然後點選 附加元件。「附加元件管理員」分頁將會開啟。

    點擊選單按鈕 New Fx Menu 並選擇 附加元件。「附加元件管理員」分頁將會開啟。

  2. 在附加元件管理員分頁中,選擇 Plugins 面板。
  3. 選擇您的 PDF 外掛程式。
  4. 在下拉式選單中選擇 永遠啟用

重設下載動作

  1. 開啟你的個人設定資料夾:

    按一下 Firefox 視窗頂端的 Firefox 按鈕,游標移至 說明 選單按一下選單列的 說明 選單點開 Firefox 視窗上方的 說明 選單 並點選 疑難排解資訊,疑難排解資訊分頁就會開啟。按一下選單按鈕 New Fx Menu ,按下說明選單圖示 Help-29 然後選擇 疑難排解資訊,疑難排解資訊分頁就會開啟。

  2. 應用程式一般資訊 的段落裡,按下 開啟資料夾在 Finder 中顯示開啟資料夾按鈕。這樣就會打開你的使用者設定資料夾的視窗。
  3. 註: 若您無法開啟 Firefox,請參照在不開啟 Firefox 的情況下尋找您的使用者設定檔當中的步驟進行操作。

  4. 在 Firefox 視窗的上方,按下 Firefox 按鈕然後點選 結束在 Firefox 視窗的上方,按下檔案 選單然後點選 結束在選單列中選擇 Firefox 選單,並選擇 結束 Firefox在 Firefox 視窗的上方,點選 檔案 選單並選擇 結束

    點擊選單按鈕 New Fx Menu 並點擊結束離開 Close 29

  5. 刪除(或重新命名)mimetypes.rdf 檔案。

其他解決方法

  • 重新初始化外掛程式的資料庫。請依照 重新初始化外掛程式的資料庫 的指示進行。
  • 假如 PDF 外掛程式是與某個應用程式一同搭載,請檢查應用程式偏好設定,以了解是否有網際網路設定可啟用外掛程式或是在瀏覽器中顯示 PDF 檔案。
  • 假如 PDF 外掛程式被某個應用程式綁定,請解除安裝,並重新安裝該應用程式。若 PDF 應用程是 Adobe Reader,請解除您的電腦中所有 Adobe Reader 的版本(請參閱 Adobe 解除安裝的指示,適用於 Reader 第 8 版及更新版本)並從 Adobe 下載頁 下載並安裝最新版。如果您仍然無法在 Firefox 中使用 Adobe Reader 外掛程式檢視 PDF,請參閱 Adobe 的支援頁面,疑難排除有關在網頁中檢視 PDF 檔案

這篇文章有幫助嗎? 請稍候...

這些人們幫忙撰寫了這篇文章: petercpg, irvin, forju, leo40102, EricTsai。您也可以幫忙 - 看看要怎麼作