Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Can NOT get rid of AVG Safe Search

  • 14 trả lời
  • 20 gặp vấn đề này
  • 4882 lượt xem
  • Trả lời mới nhất được viết bởi CharlieDoccacook

more options

I've read most of the questions and fixes here for getting rid of AVG Safe Search. Can not get rid of it.

I have no idea how I got it in the first place.

Can someone give me simple steps to get rid of it?

Every time I open a new tab it's no longer blank but has the AVG Safe Search, but I do NOT want.

I've checked my Add-0ns and edited the About:config . Still can't get rid of it.

Giải pháp được chọn

You can find the installation path of all plugins on the about:plugins page and in the pluginreg.dat file.

See also "Manually uninstalling a plugin":

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (14)

more options

Just to confirm, you have set the browser.newtab.url preference to your preferred page (either the default of about:newtab or a different page).

Is your setting getting changed, or is it being ignored?

If Firefox ignores the setting, it has to be one of your extensions.

If the setting changes after you exit and restart Firefox, you probably have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

If you would like feedback on your currently installed extensions, you could paste a list of them into a reply. To most easily grab the list, open the Troubleshooting Information page. Either:

  • Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the upper left corner, click "Copy text to clipboard". When pasting into a reply, you will notice lots of information below the extension list. You can delete the part starting from "Important Modified Settings" to the end.

more options

I changed the browser.newtab.url to about:blank

Closed FF and it was still as I set it to.

I disabled all of my extensions and ran FF in Safemode. Wasn't the extensions.

Each time I closed FF but it's still there.

I will check my profile later and check back here probably tomorrow.

more options

I manage to get to my pref.js file ( I think)

I've attached a copy. Didn't know what to edit.

more options

You need to open the file in a text editor or possibly in Firefox for inspection and not double-click the file as that will give you that error.


There are other things that need your attention.

Note that your System Details List shows multiple Flash plugins.

  1. Shockwave Flash 12.0 r0
  2. Shockwave Flash 11.7 r700

You can find the installation path of all plugins on the about:plugins page.

  • You can open the about:plugins page via the location bar

You can check the Flash player installation folder for multiple Flash player plugins and remove all (older) version(s) of the plugin (NPSWF32) and possibly (re)install the latest Flash player.

  • (32 bit Windows) C:\Windows\System32\Macromed\Flash\
  • (64 bit Windows) C:\Windows\SysWOW64\Macromed\Flash\
more options

Hi vegaspatt, please don't double-click .js files. This causes them to execute. While prefs.js can't do any harm to your system, other .js files might be designed to actually modify your system.

Try using right-click > Edit to view the contents of the file. Or right-click > Open with.

more options

I'm getting a little confused. I tried to copy and paste and then realized that probably wasn't right.

Here is the file I saved. Well, that didn't work either.

Don't know what you do now. Did you need to see that file?

more options

Usually there is hardly anything in the user.js file. To paste it here without creating a message, you can place preformatting tags around it. In other words, put <pre> before it and </pre> after it, and the forum will keep all the original line breaks.

(Note: you don't need to paste prefs.js here. It's user.js that messes with your settings.)

Được chỉnh sửa bởi jscher2000 vào

more options

I think I'm out of my league here. Actually I'm getting pretty confused.

I did find the user.js file and not being really sure about what to do, I will post it here.

If this is incorrect, I guess I'll just install AVG and go with something else. I try to be very careful about what I download but think AVG slipped this in on me.

<user_pref("extentions.y2layers.installId", "a9f535c9-3bc5-4122-b10a-52629de71c81"); user_pref("extentions.y2layers.defaultEnableAppsList", "Buzzdock,Buzzdock,"); user_pref("security.csp.enable", false); user_pref("extensions.autoDisableScopes", 0); user_pref("extensions.shownSelectionUI", true);>

I hope I did this right?

more options

You can delete this user.js file.
It looks that some software tries to install an extension silently in Firefox as extensions.autoDisableScopes = 0 suggests.
You can alternatively delete all the content in the user.js file and make the file read-only.

more options

That file mentions Buzzdock, another search-related extension.

Could you visit the Windows Control Panel, Uninstall a Program, and click the "Installed on" column heading to bring the most recent additions to the top? You may find something that is making these changes that you can remove here. Perhaps it won't have an obvious name, but I suspect it will be something you don't remember intentionally installing.

more options

Okay, guys. This is totally bizarre. Last night before retiring, the problem was still there. I shut Firefox down but this morning when I opened Firefox, the problem was GONE!!

The only thing I changed was the browser.newtab.url

I changed it to blank and even shut Firefox down several times and re-booted my PC. But nothing had changed.

Is it possible it just needed to be closed for a longer period of time? That doesn't make any sense to me at all.

So right now the issue is solved and thanks you folks for all the tips and endurance in trying to help me.

more options

Cor-el,

I was going back over this post to make sure I didn't miss anything and I did.

I attempted to delete the one Plugin as your post mentioned,.(32 bit Windows) C:\Windows\System32\Macromed\Flash\

I deleted the file in Windows but it's still in my Firefox Plugins. The only choice I had was to NOT activate it which I did, but then it also deactivates the other version.

Why is nothing straight forward and simple. How do you uninstall a Firefox Plugin?

more options

Giải pháp được chọn

You can find the installation path of all plugins on the about:plugins page and in the pluginreg.dat file.

See also "Manually uninstalling a plugin":

more options

I found out how to get rid of AVG secure search. It wouldn`t let me update Firefox but when I did I found out they had hijacked my yahoo.toolbar, as soon as I hit button to make yahoo my home page it went away