Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

All updates were disabled - Add-on "could not be verified for use in Firefox and has been disabled."

  • 16 trả lời
  • 4 gặp vấn đề này
  • 90 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I saw a message that my Add-ons were disabled, and when I checked the Add-ons Manager , each of my many Add-ons had a message similar to: "1Password – Password Manager could not be verified for use in Firefox and has been disabled. "

Some searches in the forums suggest that that this can be caused my a certificate at Mozilla expiring, I seem to be the only one with this issue at the moment. All of my Add-ons came through the Mozilla store .

I am using version 123.0.1 (64-bit) on OpenSUSE Leap 15.5, and as far as I can see all of my updates are current (and from the official sources.)

What should I do next? I expect I need to wait for a certificate update or something at Mozilla, but if/when that happens how do I verify it did and re-enable my add-ons?

I saw a message that my Add-ons were disabled, and when I checked [http://about:addons the Add-ons Manager] , each of my many Add-ons had a message similar to: "1Password – Password Manager could not be verified for use in Firefox and has been disabled. " Some searches in the forums suggest that that this can be caused my a certificate at Mozilla expiring, I seem to be the only one with this issue at the moment. All of my Add-ons came through [https://addons.mozilla.org/en-US/firefox/ the Mozilla store] . I am using version 123.0.1 (64-bit) on OpenSUSE Leap 15.5, and as far as I can see all of my updates are current (and from the official sources.) What should I do next? I expect I need to wait for a certificate update or something at Mozilla, but if/when that happens how do I verify it did and re-enable my add-ons?
Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (16)

more options

Same for me, I'm on Tumbleweed, same Firefox (I get mine from the Mozilla repo)

Hữu ích?

more options

Mine was from OpenSUSE:

Information for package MozillaFirefox:


Repository  : Mozilla Name  : MozillaFirefox Version  : 123.0.1-lp155.1.1 Arch  : x86_64 Vendor  : obs://build.opensuse.org/mozilla Installed Size : 246.7 MiB Installed  : Yes Status  : up-to-date Source package : MozillaFirefox-123.0.1-lp155.1.1.src Upstream URL  : http://www.mozilla.org/ Summary  : Mozilla Firefox Web Browser Description  :

   Mozilla Firefox is a standalone web browser, designed for standards
   compliance and performance.  Its functionality can be enhanced via a
   plethora of extensions.

Hữu ích?

more options

Extension certificate verification occurs at different times of day for different users, so others may start reporting the same thing later today... I don't see this on the Firefox subreddit yet.

Extension Updates

When Mozilla changes the certificate in Firefox, the Add-ons site should update all the live extensions. If normal automatic updates are enabled, Firefox should get find and install the updated XPIs automatically. Maybe that failed. Could you click the "gear" or "wheel" button on the Add-on page and run Check for Updates.

Distro Forum

Is there an OpenSUSE forum where other users of Firefox from that repository might be discussing this?

System Clock

Please also check your system clocks to make sure they aren't rolled forward to a time when the internal certificate might no longer be valid.

Hữu ích?

more options

Hữu ích?

more options

Your reply went into the spam link moderation queue. To expedite discussion, I'm reposting:

zaggynl

Appears to be related: https://bugzilla.opensuse.org/show_bug.cgi?id=1221531 I've received a response here as well: https://github.com/mozilla/addons/issues/1575

Hữu ích?

more options

That does appear to answer my question. If I am reading this correct, I would need to uninstall and reinstall all of my add-ons (which will also reset all their settings.)

Is there a faster/easier way to do that? Or some way to go re-enable all of these ones that the Add-Ons Manager believes were not verified?

Hữu ích?

more options

I spoke too soon, re-adding an add-on from the Add-on site gives me "Installation aborted because the add-on appears to be corrupt."

Hữu ích?

more options

There is a faster way to force reverification, but if you still have the problematic files (I can't really understand the specific problem from the OpenSUSE forum thread), you should get the same result.

To Prompt Immediate Reverification

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste xpi- and pause while the list is filtered

(3) Find the app.update.lastUpdateTime.xpi-signature-verification preference and click the trash can at the right end of the row to clear it

(4) Close this tab and do a regular quit/restart of Firefox. It should re-run the verification within the first minute or two after startup.

Hữu ích?

more options

I have tried that, but the results are the same and I can't add something from the Firefox Add-on page still.

Hữu ích?

more options

It looks like Firefox is affected by something in the OpenSUSE/Tumbleweed certificate related updates released over the weekend. It's not clear whether that is going to get patched promptly or whether it can be rolled back safely, etc. I'm a Windows person, so I need to defer to the Linux community to explain the interaction and clarify the workarounds.

Hữu ích?

more options

Hi, to be clear this is a problem with openSUSE and not Firefox itself. Please keep an eye on https://bugzilla.opensuse.org/show_bug.cgi?id=1221531 and do not uninstall/re-install your add-ons to avoid losing your data.

Hữu ích?

more options

Until there is a change on the OpenSUSE side or until Firefox gets rid of the SHA1, you can set the crypto-policy to allow the weaker encryption: sudo update-crypto-policies --set LEGACY

Hữu ích?

more options

`Lex said

Until there is a change on the OpenSUSE side or until Firefox gets rid of the SHA1, you can set the crypto-policy to allow the weaker encryption: sudo update-crypto-policies --set LEGACY

Where there any other steps? I tried the command and a reboot but Firefox still shows the extensions as disabled.

Hữu ích?

more options

zaggynl said

`Lex said

Until there is a change on the OpenSUSE side or until Firefox gets rid of the SHA1, you can set the crypto-policy to allow the weaker encryption: sudo update-crypto-policies --set LEGACY

Where there any other steps? I tried the command and a reboot but Firefox still shows the extensions as disabled.

Try deleting the last verification time preference again so Firefox checks again after the next restart.

Hữu ích?

more options

jscher2000 - Support Volunteer said

zaggynl said

`Lex said

Until there is a change on the OpenSUSE side or until Firefox gets rid of the SHA1, you can set the crypto-policy to allow the weaker encryption: sudo update-crypto-policies --set LEGACY

Where there any other steps? I tried the command and a reboot but Firefox still shows the extensions as disabled.

Try deleting the last verification time preference again so Firefox checks again after the next restart.

Yes, I did both of those things, then gave it a moment and everything re-enabled themselves.

Hữu ích?

more options

Note that there are prefs in about:config to keep extension storage.

  • extensions.webextensions.keepStorageOnUninstall
  • extensions.webextensions.keepUuidOnUninstall

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.