Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox does not play videos on after Ubuntu upgrade

  • 6 trả lời
  • 1 gặp vấn đề này
  • 21 lượt xem
  • Trả lời mới nhất được viết bởi zeroknight

more options

A few days ago Ubuntu (22.04 LTS) showed me a message saying I can upgrade my OS (or something along those lines). I click on agree (any button that would let me proceed) and the upgrade took place (without restarting). Along with the upgrade Firefox was also updated to its latest version at the time (119.0). Since then, videos on Twitter play but without sound. On some other websites also none of the videos play. On YouTube, Firefox shows me a message saying "To play video, you may need to install the required video codecs" but the videos play fine; I haven't tried other websites but I assume all would have some issues. Google Chrome however doesn't have this issue and all videos play without any issues.

Note that I have not restarted my computer since the upgrade. I doubt this could be an issue but please let me know if you think this could be the issue.

I did the followings and restarted Firefox but none have worked so far for Twitter and some other random websites that I come across, but they resolved the issue for YouTube and now YouTube videos play, although I still get that codec message at the top of the tab:

sudo apt-get install ffmpeg sudo apt install ubuntu-restricted-extras sudo apt install libavcodec-extra

Someone told me this is because the default Firefox on Ubuntu 22 comes as a snap package and I should install the APT package manually instead so that it works. I prefer not to do this because I have lots of tabs open and have manually changed lots of the settings (including in about:config) that I want to preserve. I would also like to preserve the history of visited websites and keep the current cookies (don't really want to keep entering username/password on the same websites again). So the best way for me is to fix the issue for the default Firefox on Ubuntu 22.

Could you help me figure out what I should do to fix this issue?

A few days ago Ubuntu (22.04 LTS) showed me a message saying I can upgrade my OS (or something along those lines). I click on agree (any button that would let me proceed) and the upgrade took place (without restarting). Along with the upgrade Firefox was also updated to its latest version at the time (119.0). Since then, videos on Twitter play but without sound. On some other websites also none of the videos play. On YouTube, Firefox shows me a message saying "To play video, you may need to install the required video codecs" but the videos play fine; I haven't tried other websites but I assume all would have some issues. Google Chrome however doesn't have this issue and all videos play without any issues. Note that I have not restarted my computer since the upgrade. I doubt this could be an issue but please let me know if you think this could be the issue. I did the followings and restarted Firefox but none have worked so far for Twitter and some other random websites that I come across, but they resolved the issue for YouTube and now YouTube videos play, although I still get that codec message at the top of the tab: sudo apt-get install ffmpeg sudo apt install ubuntu-restricted-extras sudo apt install libavcodec-extra Someone told me this is because the default Firefox on Ubuntu 22 comes as a snap package and I should install the APT package manually instead so that it works. I prefer not to do this because I have lots of tabs open and have manually changed lots of the settings (including in about:config) that I want to preserve. I would also like to preserve the history of visited websites and keep the current cookies (don't really want to keep entering username/password on the same websites again). So the best way for me is to fix the issue for the default Firefox on Ubuntu 22. Could you help me figure out what I should do to fix this issue?

Tất cả các câu trả lời (6)

more options

Try this;

Hữu ích?

more options

Firefox is dependent on the system supplying restricted codecs while Chrome has them built-in. The snap package is fully compatible with restricted codecs. Youtube does not require them but most other sites do.

Major Ubuntu updates require a system restart for all changes to take effect.

Hữu ích?

more options

zeroknight said

Firefox is dependent on the system supplying restricted codecs while Chrome has them built-in. The snap package is fully compatible with restricted codecs. Youtube does not require them but most other sites do. Major Ubuntu updates require a system restart for all changes to take effect.

I restarted my computer but things are the same as before

Hữu ích?

more options

cor-el said

Try this;

Until today I didn't know you can install things on Ubuntu 22 as a snap package and that by default, Firefox is a "snap" package on Ubuntu 22. So I also did the following and installed ffmpeg as a snap package but still have the same issue after restarting Firefox. Any other thoughts?

   sudo snap install ffmpeg

Hữu ích?

more options

Here is what I have on my rolling release of openSUSE. Is there a similar way to show what you have installed on Ubuntu? Here is a video of Obama 9yrs ago talking about the coming Plandemic (COVID19 virus) years before it happened and it works for me. ;-)) https://youtu.be/w50tZonOgoU?si=kSiesx_J1b8gi0_R&t=950

Try downloading Firefox from Mozilla. Download, unzip, and run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Here is another example from Rumble that works fine for me. https://rumble.com/v13kefy-must-see-the-plan-who-plans-for-10-years-of-pandemics-from-2020-to-2030.html

Được chỉnh sửa bởi jonzn4SUSE vào

Hữu ích?

more options

The snap package works for me with restricted codecs on Ubuntu 22.04.3 LTS, it comes with the necessary libavcodec library built-in. Try re-installing the snap package:

sudo snap remove firefox
sudo snap install firefox
snap saved
sudo snap restore <ID>


Alternatively, install the Firefox flatpak package along with the ffmpeg flatpak package.

flatpak install org.freedesktop.Platform.ffmpeg-full

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.