Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Youtube Constantly Buffering after Pausing and Resuming

  • 13 trả lời
  • 5 gặp vấn đề này
  • 215 lượt xem
  • Trả lời mới nhất được viết bởi beatzoid

more options

I've been watching and following along with a Unreal Engine 4 Course on Youtube for some time now (mentioning in case the resource usage has something to do with it), and in the past couple days I've noticed a pretty serious and annoying bug. When I pause the video, tab (Cmd + Tab on MacOS) into Unreal Engine, do some things, then tab back and resume the video, it will play for one frame and then stop and buffer, but the audio will continue playing. The only way to get the video to resume is to skip forward/backward in the video (either with the arrow keys or the progress bar). I've also tried Troubleshooting/Safe mode and the issue still persits.

I've been watching and following along with a Unreal Engine 4 Course on Youtube for some time now (mentioning in case the resource usage has something to do with it), and in the past couple days I've noticed a pretty serious and annoying bug. When I pause the video, tab (Cmd + Tab on MacOS) into Unreal Engine, do some things, then tab back and resume the video, it will play for one frame and then stop and buffer, but the audio will continue playing. The only way to get the video to resume is to skip forward/backward in the video (either with the arrow keys or the progress bar). I've also tried Troubleshooting/Safe mode and the issue still persits.

Giải pháp được chọn

Ok well I restarted my computer a couple hours ago and haven't run into the bug since. I'll post here if it happens again

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (13)

more options

Does it still happen if the Unreal Engine window is not fully covering the Firefox window?

Things to try/experiment:

  1. Go to about:config and change media.suspend-bkgnd-video.enabled to false.
  2. Set the environment variable MOZ_WINDOW_OCCLUSION=0.
more options

zeroknight said

Does it still happen if the Unreal Engine window is not fully covering the Firefox window? Things to try/experiment:
  1. Go to about:config and change media.suspend-bkgnd-video.enabled to false.
  2. Set the environment variable MOZ_WINDOW_OCCLUSION=0.

Thank you so much, I modifed the two values you suggested and my issue hasn't reoccured!

more options

The problem has resurfaced, and now I don't even have to switch to another app. If I simply pause the video for more than a minute or two and then try to resume, the video buffers but the audio resumes, and I am forced to scrub back and forth through the video to fix it

more options

Now if I pause and resume the video in the span of <5 seconds the issue occurs, and the audio also appears to be lagging but that could be due to my bluetooth headphones

Edit: This seems to happen randomly now, and the timing of the pausing and resuming doesn't appear to affect it

Edit 2: Pausing, switching to another tab, switching back, and trying to resume it is the most constant way to trigger this bug for me

Được chỉnh sửa bởi beatzoid vào

more options

Something interesting I just discovered, if I disconnect my Airpods then the issue stops happening

Được chỉnh sửa bởi beatzoid vào

more options

beatzoid said

if I disconnect my Airpods then the issue stops happening

Does it still happen if you go to about:config and change media.hardwaremediakeys.enabled to false?

more options

zeroknight said

beatzoid said

if I disconnect my Airpods then the issue stops happening

Does it still happen if you go to about:config and change media.hardwaremediakeys.enabled to false?

Yes it does

more options

Now, around 50% of the time I click on a video on Youtube, I don't have to pause, resume, or even click anything; this bug happens right when the video starts.

more options

Still limited to your Airpods? You could try testing some older versions of Firefox with mozregression to see if it ever worked before and find when it broke.

more options

zeroknight said

Still limited to your Airpods? You could try testing some older versions of Firefox with mozregression to see if it ever worked before and find when it broke.

I used that tool and found the issue went all the way back to version 84.0a1, and I tried two versions before that (76.0a1 and 73.0a1) and neither of them would play sound from a Youtube video, not even when I disconnected my Airpods. I'm charging a different pair of Bluetooth headphones and will let you know if the issue happens with them.

more options

This issue doesn't happen with the other pair of Bluetooth headphones, only with my Airpods

Edit: They are AirPods Pro (2nd generation)

Được chỉnh sửa bởi beatzoid vào

more options

Here's a profile I took, where I resumed a video while having my Airpods connected, the video buffered, I paused and resumed it, and it continued playing https://share.firefox.dev/3DwIXyA

more options

Giải pháp được chọn

Ok well I restarted my computer a couple hours ago and haven't run into the bug since. I'll post here if it happens again